summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-02-03 21:48:38 +0000
committerManuel Rüger <mrueg@gentoo.org>2015-02-03 21:48:38 +0000
commit1c1379862563227cab882cb00d2386df5d742e9a (patch)
tree52cc3a4fcd32e9e9925c25dc7dc51481beceda41 /net-libs
parentRemove old. (diff)
downloadgentoo-2-1c1379862563227cab882cb00d2386df5d742e9a.tar.gz
gentoo-2-1c1379862563227cab882cb00d2386df5d742e9a.tar.bz2
gentoo-2-1c1379862563227cab882cb00d2386df5d742e9a.zip
Version bump.
(Portage version: 2.2.15/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/txtorcon/ChangeLog7
-rw-r--r--net-libs/txtorcon/txtorcon-0.12.0.ebuild30
2 files changed, 36 insertions, 1 deletions
diff --git a/net-libs/txtorcon/ChangeLog b/net-libs/txtorcon/ChangeLog
index 1623811b5673..04756980336d 100644
--- a/net-libs/txtorcon/ChangeLog
+++ b/net-libs/txtorcon/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/txtorcon
# Copyright 1999-2015 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/txtorcon/ChangeLog,v 1.4 2015/01/06 03:50:19 mrueg Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/txtorcon/ChangeLog,v 1.5 2015/02/03 21:48:38 mrueg Exp $
+
+*txtorcon-0.12.0 (03 Feb 2015)
+
+ 03 Feb 2015; Manuel Rüger <mrueg@gentoo.org> +txtorcon-0.12.0.ebuild:
+ Version bump.
06 Jan 2015; Manuel Rüger <mrueg@gentoo.org> -txtorcon-0.10.1.ebuild:
Remove old.
diff --git a/net-libs/txtorcon/txtorcon-0.12.0.ebuild b/net-libs/txtorcon/txtorcon-0.12.0.ebuild
new file mode 100644
index 000000000000..bcf8d951f514
--- /dev/null
+++ b/net-libs/txtorcon/txtorcon-0.12.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/txtorcon/txtorcon-0.12.0.ebuild,v 1.1 2015/02/03 21:48:38 mrueg Exp $
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+inherit distutils-r1
+
+DESCRIPTION="Twisted-based Tor controller client, with state-tracking and configuration abstractions"
+HOMEPAGE="https://github.com/meejah/txtorcon https://pypi.python.org/pypi/txtorcon"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/ipaddr[${PYTHON_USEDEP}]
+ net-misc/tor
+ dev-python/zope-interface[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_test() {
+ trial --reporter=text test || die
+}