summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2010-06-29 14:21:08 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2010-06-29 14:21:08 +0000
commit1bf91cd68b0ee8d12bb2966c0bd533a7fe107b40 (patch)
treee5fb45a5d9ec6aab154e23fcb7ac600d7dc06633 /net-libs
parentAdd client interface to czech "datove stranky" soap service. (diff)
downloadgentoo-2-1bf91cd68b0ee8d12bb2966c0bd533a7fe107b40.tar.gz
gentoo-2-1bf91cd68b0ee8d12bb2966c0bd533a7fe107b40.tar.bz2
gentoo-2-1bf91cd68b0ee8d12bb2966c0bd533a7fe107b40.zip
Update to install static libs only when required. Update deps. Use upstream tarball.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/libisds/ChangeLog9
-rw-r--r--net-libs/libisds/libisds-0.3.1.ebuild36
-rw-r--r--net-libs/libisds/libisds-9999.ebuild36
-rw-r--r--net-libs/libisds/metadata.xml5
4 files changed, 56 insertions, 30 deletions
diff --git a/net-libs/libisds/ChangeLog b/net-libs/libisds/ChangeLog
index 02b064312fe1..53187affec9f 100644
--- a/net-libs/libisds/ChangeLog
+++ b/net-libs/libisds/ChangeLog
@@ -1,11 +1,16 @@
# ChangeLog for net-libs/libisds
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/ChangeLog,v 1.1 2010/06/29 14:03:45 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/ChangeLog,v 1.2 2010/06/29 14:21:08 scarabeus Exp $
+
+ 29 Jun 2010; Tomáš Chvátal <scarabeus@gentoo.org> libisds-0.3.1.ebuild,
+ libisds-9999.ebuild, metadata.xml:
+ Update to install static libs only when required. Update deps. Use
+ upstream tarball.
*libisds-9999 (29 Jun 2010)
*libisds-0.3.1 (29 Jun 2010)
29 Jun 2010; Tomáš Chvátal <scarabeus@gentoo.org>
+libisds-0.3.1.ebuild, +libisds-9999.ebuild, +metadata.xml:
- Add client interface to czech "datove stranky" soap service.
+ Add client interface to czech "datove schranky" soap service.
diff --git a/net-libs/libisds/libisds-0.3.1.ebuild b/net-libs/libisds/libisds-0.3.1.ebuild
index fc0ed0738fdf..3343cb0e7d64 100644
--- a/net-libs/libisds/libisds-0.3.1.ebuild
+++ b/net-libs/libisds/libisds-0.3.1.ebuild
@@ -1,46 +1,54 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/libisds-0.3.1.ebuild,v 1.1 2010/06/29 14:03:45 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/libisds-0.3.1.ebuild,v 1.2 2010/06/29 14:21:08 scarabeus Exp $
EAPI=3
-[[ ${PV} = 9999* ]] && GIT="git"
+[[ ${PV} = 9999* ]] && GIT="git autotools"
EGIT_REPO_URI="git://repo.or.cz/${PN}.git"
-inherit base autotools ${GIT}
+inherit base ${GIT}
-DESCRIPTION="Client library to access ISDS Soap service"
-HOMEPAGE="http://www.abclinuxu.cz/datove-schranky/libisds"
+DESCRIPTION="Client library for accessing ISDS Soap services"
+HOMEPAGE="http://xpisar.wz.cz/libisds/"
if [[ ${PV} = 9999* ]]; then
SRC_URI=""
KEYWORDS=""
else
- SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.bz2"
+ SRC_URI="http://xpisar.wz.cz/libisds/dist/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="LGPL-2"
SLOT="0"
-IUSE="debug test"
+IUSE="debug nls static-libs test"
-RDEPEND="
+COMMON_DEPEND="
+ app-crypt/gpgme
dev-libs/expat
dev-libs/libgcrypt
dev-libs/libxml2
net-misc/curl[ssl]
"
-DEPEND="${RDEPEND}
+DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig
- sys-devel/gettext"
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=app-crypt/gnupg-2
+"
+
+DOCS=( "NEWS" "README" "AUTHORS" "ChangeLog" )
src_prepare() {
base_src_prepare
- eautoreconf
+ [[ ${PV} = 9999* ]] && eautoreconf
}
src_configure() {
econf \
--disable-fatalwarnings \
- $(use_enable test) \
- $(use_enable debug)
-
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_enable test)
}
diff --git a/net-libs/libisds/libisds-9999.ebuild b/net-libs/libisds/libisds-9999.ebuild
index 830559645975..47f24886a362 100644
--- a/net-libs/libisds/libisds-9999.ebuild
+++ b/net-libs/libisds/libisds-9999.ebuild
@@ -1,46 +1,54 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/libisds-9999.ebuild,v 1.1 2010/06/29 14:03:45 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libisds/libisds-9999.ebuild,v 1.2 2010/06/29 14:21:08 scarabeus Exp $
EAPI=3
-[[ ${PV} = 9999* ]] && GIT="git"
+[[ ${PV} = 9999* ]] && GIT="git autotools"
EGIT_REPO_URI="git://repo.or.cz/${PN}.git"
-inherit base autotools ${GIT}
+inherit base ${GIT}
-DESCRIPTION="Client library to access ISDS Soap service"
-HOMEPAGE="http://www.abclinuxu.cz/datove-schranky/libisds"
+DESCRIPTION="Client library for accessing ISDS Soap services"
+HOMEPAGE="http://xpisar.wz.cz/libisds/"
if [[ ${PV} = 9999* ]]; then
SRC_URI=""
KEYWORDS=""
else
- SRC_URI="http://dev.gentooexperimental.org/~scarabeus/${P}.tar.bz2"
+ SRC_URI="http://xpisar.wz.cz/libisds/dist/${P}.tar.bz2"
KEYWORDS="~amd64 ~x86"
fi
LICENSE="LGPL-2"
SLOT="0"
-IUSE="debug test"
+IUSE="debug nls static-libs test"
-RDEPEND="
+COMMON_DEPEND="
+ app-crypt/gpgme
dev-libs/expat
dev-libs/libgcrypt
dev-libs/libxml2
net-misc/curl[ssl]
"
-DEPEND="${RDEPEND}
+DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig
- sys-devel/gettext"
+ nls? ( sys-devel/gettext )
+"
+RDEPEND="${COMMON_DEPEND}
+ >=app-crypt/gnupg-2
+"
+
+DOCS=( "NEWS" "README" "AUTHORS" "ChangeLog" )
src_prepare() {
base_src_prepare
- eautoreconf
+ [[ ${PV} = 9999* ]] && eautoreconf
}
src_configure() {
econf \
--disable-fatalwarnings \
- $(use_enable test) \
- $(use_enable debug)
-
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable static-libs static) \
+ $(use_enable test)
}
diff --git a/net-libs/libisds/metadata.xml b/net-libs/libisds/metadata.xml
index 0b14a262fd80..08ee4c90c8b1 100644
--- a/net-libs/libisds/metadata.xml
+++ b/net-libs/libisds/metadata.xml
@@ -1,6 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
+<longdescription>
+ A library for accessing ISDS (Informační systém datových schránek
+ / Data Box Information System) SOAP services as defined in Czech ISDS Act
+ (300/2008 Coll.) and implied documents.
+</longdescription>
<maintainer>
<email>scarabeus@gentoo.org</email>
<name>Tomáš Chvátal</name>