summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2011-11-29 19:01:02 +0000
committerFabian Groffen <grobian@gentoo.org>2011-11-29 19:01:02 +0000
commit1bd7d53b41ae60211116ed41e16c047910f79604 (patch)
treec79b9399f2a9f1766ac398b1c7979f3ec1eb32a7 /net-libs
parentVersion bump (fixes USB regression in 3.1.3) (diff)
downloadgentoo-2-1bd7d53b41ae60211116ed41e16c047910f79604.tar.gz
gentoo-2-1bd7d53b41ae60211116ed41e16c047910f79604.tar.bz2
gentoo-2-1bd7d53b41ae60211116ed41e16c047910f79604.zip
Fix darwin-quartz patch, drop darwin8 patch from ebuild, bug #392385
(Portage version: 2.2.01.19572-prefix/cvs/Darwin i386)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/webkit-gtk/ChangeLog8
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-1.2.5-darwin-quartz.patch8
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-1.6.1-darwin-quartz.patch67
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.6.1-r201.ebuild8
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.6.1-r300.ebuild10
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.6.1-r301.ebuild8
6 files changed, 85 insertions, 24 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index af40c5b95fd1..578be69dc4ae 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.131 2011/11/29 13:25:45 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.132 2011/11/29 19:01:02 grobian Exp $
+
+ 29 Nov 2011; Fabian Groffen <grobian@gentoo.org>
+ +files/webkit-gtk-1.6.1-darwin-quartz.patch, webkit-gtk-1.6.1-r300.ebuild,
+ webkit-gtk-1.6.1-r301.ebuild, webkit-gtk-1.6.1-r201.ebuild,
+ files/webkit-gtk-1.2.5-darwin-quartz.patch:
+ Fix darwin-quartz patch, drop darwin8 patch from ebuild, bug #392385
*webkit-gtk-1.6.1-r301 (29 Nov 2011)
*webkit-gtk-1.6.1-r201 (29 Nov 2011)
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-1.2.5-darwin-quartz.patch b/net-libs/webkit-gtk/files/webkit-gtk-1.2.5-darwin-quartz.patch
index fe1ebc4d50a8..5046118af949 100644
--- a/net-libs/webkit-gtk/files/webkit-gtk-1.2.5-darwin-quartz.patch
+++ b/net-libs/webkit-gtk/files/webkit-gtk-1.2.5-darwin-quartz.patch
@@ -1,8 +1,8 @@
http://trac.macports.org/browser/trunk/dports/www/webkit-gtk/files/patch-quartz-WebCore-plugins-gtk-gtkxtbin.c.diff?format=txt
http://trac.macports.org/browser/trunk/dports/www/webkit-gtk/files/patch-quartz-WebCore-plugins-gtk-PluginViewGtk.cpp.diff?format=txt
---- WebCore/plugins/gtk/gtk2xtbin.c.orig 2010-09-10 06:20:33.000000000 -0700
-+++ WebCore/plugins/gtk/gtk2xtbin.c 2010-10-06 09:45:37.000000000 -0700
+--- Source/WebCore/plugins/gtk/gtk2xtbin.c
++++ Source/WebCore/plugins/gtk/gtk2xtbin.c
@@ -41,7 +41,7 @@
* The GtkXtBin widget allows for Xt toolkit code to be used
* inside a GTK application.
@@ -17,8 +17,8 @@ http://trac.macports.org/browser/trunk/dports/www/webkit-gtk/files/patch-quartz-
return;
}
+#endif
---- WebCore/plugins/gtk/PluginViewGtk.cpp.orig 2010-09-10 06:20:33.000000000 -0700
-+++ WebCore/plugins/gtk/PluginViewGtk.cpp 2010-10-06 09:45:37.000000000 -0700
+--- Source/WebCore/plugins/gtk/PluginViewGtk.cpp
++++ Source/WebCore/plugins/gtk/PluginViewGtk.cpp
@@ -60,10 +60,13 @@
#include "runtime_root.h"
#include <runtime/JSLock.h>
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-1.6.1-darwin-quartz.patch b/net-libs/webkit-gtk/files/webkit-gtk-1.6.1-darwin-quartz.patch
new file mode 100644
index 000000000000..5ad357e9eeed
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-1.6.1-darwin-quartz.patch
@@ -0,0 +1,67 @@
+Original from:
+http://trac.macports.org/browser/trunk/dports/www/webkit-gtk/files/patch-quartz-WebCore-plugins-gtk-gtkxtbin.c.diff?format=txt
+http://trac.macports.org/browser/trunk/dports/www/webkit-gtk/files/patch-quartz-WebCore-plugins-gtk-PluginViewGtk.cpp.diff?format=txt
+
+Adapted for 1.6.1
+
+--- Source/WebCore/plugins/gtk/PluginViewGtk.cpp
++++ Source/WebCore/plugins/gtk/PluginViewGtk.cpp
+@@ -70,6 +70,8 @@
+ #endif
+ #include <gtk/gtk.h>
+
++#undef XP_UNIX
++
+ #if defined(XP_UNIX)
+ #include "RefPtrCairo.h"
+ #include "gtk2xtbin.h"
+@@ -439,9 +441,9 @@
+ event->setDefaultHandled();
+ }
+
+-#if defined(XP_UNIX)
+ void PluginView::handleFocusInEvent()
+ {
++#if defined(XP_UNIX)
+ if (!m_isStarted || m_status != PluginStatusLoadedSuccessfully)
+ return;
+
+@@ -454,10 +456,12 @@
+ event.detail = NotifyDetailNone;
+
+ dispatchNPEvent(npEvent);
++#endif
+ }
+
+ void PluginView::handleFocusOutEvent()
+ {
++#if defined(XP_UNIX)
+ if (!m_isStarted || m_status != PluginStatusLoadedSuccessfully)
+ return;
+
+@@ -470,8 +474,8 @@
+ event.detail = NotifyDetailNone;
+
+ dispatchNPEvent(npEvent);
+-}
+ #endif
++}
+
+ void PluginView::setParent(ScrollView* parent)
+ {
+--- Source/WebCore/plugins/gtk/gtk2xtbin.c
++++ Source/WebCore/plugins/gtk/gtk2xtbin.c
+@@ -41,7 +41,7 @@
+ * The GtkXtBin widget allows for Xt toolkit code to be used
+ * inside a GTK application.
+ */
+-
++#if 0
+ #include "GtkVersioning.h"
+ #include "xembed.h"
+ #include "gtk2xtbin.h"
+@@ -966,3 +966,4 @@
+
+ return;
+ }
++#endif
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.6.1-r201.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.6.1-r201.ebuild
index a5aed44fa4f8..9322f826345a 100644
--- a/net-libs/webkit-gtk/webkit-gtk-1.6.1-r201.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-1.6.1-r201.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.6.1-r201.ebuild,v 1.1 2011/11/29 13:25:45 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.6.1-r201.ebuild,v 1.2 2011/11/29 19:01:02 grobian Exp $
EAPI="4"
@@ -16,8 +16,7 @@ SRC_URI="mirror://gentoo/${P}.tar.xz"
LICENSE="LGPL-2 LGPL-2.1 BSD"
SLOT="2"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd
-~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
# geoclue
IUSE="aqua coverage debug +gstreamer +introspection +jit spell webgl"
@@ -81,8 +80,7 @@ src_prepare() {
# intermediate MacPorts hack while upstream bug is not fixed properly
# https://bugs.webkit.org/show_bug.cgi?id=28727
- # TODO: FAILS TO APPLY!
- #use aqua && epatch "${FILESDIR}"/${PN}-1.2.5-darwin-quartz.patch
+ use aqua && epatch "${FILESDIR}"/${P}-darwin-quartz.patch
# Skip tests phase: here we will place tests we need to skip, any
# skipped test needs to have an upstream report and needs to be
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.6.1-r300.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.6.1-r300.ebuild
index 025a3c75c086..f035fa593137 100644
--- a/net-libs/webkit-gtk/webkit-gtk-1.6.1-r300.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-1.6.1-r300.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.6.1-r300.ebuild,v 1.1 2011/09/30 13:52:33 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.6.1-r300.ebuild,v 1.2 2011/11/29 19:01:02 grobian Exp $
EAPI="4"
@@ -70,14 +70,6 @@ src_prepare() {
# https://bugs.webkit.org/show_bug.cgi?id=19775
use sparc && epatch "${FILESDIR}"/${PN}-1.2.3-fix-pool-sparc.patch
- # intermediate MacPorts hack while upstream bug is not fixed properly
- # https://bugs.webkit.org/show_bug.cgi?id=28727
- use aqua && epatch "${FILESDIR}"/${PN}-1.2.5-darwin-quartz.patch
-
- # Fix build on Darwin8 (10.4 Tiger)
- # XXX: Fails to apply
- #epatch "${FILESDIR}"/${PN}-1.2.5-darwin8.patch
-
# Don't force -O2
sed -i 's/-O2//g' "${S}"/configure.ac
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.6.1-r301.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.6.1-r301.ebuild
index 5311c0f78128..3c03a91ae7d5 100644
--- a/net-libs/webkit-gtk/webkit-gtk-1.6.1-r301.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-1.6.1-r301.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.6.1-r301.ebuild,v 1.1 2011/11/29 13:25:45 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.6.1-r301.ebuild,v 1.2 2011/11/29 19:01:02 grobian Exp $
EAPI="4"
@@ -16,8 +16,7 @@ SRC_URI="mirror://gentoo/${P}.tar.xz"
LICENSE="LGPL-2 LGPL-2.1 BSD"
SLOT="3"
-KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd
-~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
# geoclue
IUSE="aqua coverage debug doc +gstreamer +introspection +jit spell webgl"
@@ -83,8 +82,7 @@ src_prepare() {
# intermediate MacPorts hack while upstream bug is not fixed properly
# https://bugs.webkit.org/show_bug.cgi?id=28727
- # TODO: FAILS TO APPLY!
- #use aqua && epatch "${FILESDIR}"/${PN}-1.2.5-darwin-quartz.patch
+ use aqua && epatch "${FILESDIR}"/${P}-darwin-quartz.patch
# Drop DEPRECATED flags
sed -i -e 's:-D[A-Z_]*DISABLE_DEPRECATED:$(NULL):g' GNUmakefile.am || die