summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2003-12-09 04:02:24 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2003-12-09 04:02:24 +0000
commit0b2931817739b0cdd0ad70723e330054da398a10 (patch)
tree306b843ae4ca48d2b5c83a093459c3ec31455ca5 /net-libs
parentfix bug #35378 and move new ebuild to stable right away to fix some other gli... (diff)
downloadgentoo-2-0b2931817739b0cdd0ad70723e330054da398a10.tar.gz
gentoo-2-0b2931817739b0cdd0ad70723e330054da398a10.tar.bz2
gentoo-2-0b2931817739b0cdd0ad70723e330054da398a10.zip
fix bug #35378 and move new ebuild to stable right away to fix some other glitches
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/c-client/ChangeLog8
-rw-r--r--net-libs/c-client/Manifest5
-rw-r--r--net-libs/c-client/c-client-2002e-r1.ebuild76
-rw-r--r--net-libs/c-client/files/digest-c-client-2002e-r11
4 files changed, 87 insertions, 3 deletions
diff --git a/net-libs/c-client/ChangeLog b/net-libs/c-client/ChangeLog
index 3538ac2e2f87..410e9705b8a0 100644
--- a/net-libs/c-client/ChangeLog
+++ b/net-libs/c-client/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/c-client
# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/ChangeLog,v 1.9 2003/10/26 06:47:35 robbat2 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/ChangeLog,v 1.10 2003/12/09 04:02:22 robbat2 Exp $
+
+*c-client-2002e-r1 (08 Dec 2003)
+
+ 08 Dec 2003; Robin H. Johnson <robbat2@gentoo.org> c-client-2002e-r1.ebuild:
+ fix bug #35378 and move new ebuild to stable right away to fix some other
+ glitches
25 Oct 2003; Robin H. Johnson <robbat2@gentoo.org> metadata.xml:
add metadata.xml
diff --git a/net-libs/c-client/Manifest b/net-libs/c-client/Manifest
index 70a7328b7c18..4680ea473f19 100644
--- a/net-libs/c-client/Manifest
+++ b/net-libs/c-client/Manifest
@@ -1,6 +1,7 @@
-MD5 91b7c453b43492b9038c5190c72fd8e8 c-client-2002e-r1.ebuild 1903
+MD5 bfd0af7da57d3b688c1760bc86807480 c-client-2002e-r1.ebuild 1926
+MD5 9e3e64dc97ef1b565891d29569222d0b c-client-2002e.ebuild 1905
MD5 5ae91327a010a1d207efd745c61a424b c-client-2002d-r1.ebuild 1881
-MD5 37215d57fcdf8493e1261e8d3131db17 ChangeLog 1422
+MD5 ded72dd6ed81c26f6b26d00265c8ec21 ChangeLog 1624
MD5 6b964abdc013cf2bb64040e8e33215ae metadata.xml 242
MD5 921fed101cade175f914be4ef1a4b0a0 c-client-2002d.ebuild 1865
MD5 1fc1132a6fb90046b701e9196e7a96b0 files/digest-c-client-2002d-r1 62
diff --git a/net-libs/c-client/c-client-2002e-r1.ebuild b/net-libs/c-client/c-client-2002e-r1.ebuild
new file mode 100644
index 000000000000..aad6bf13e799
--- /dev/null
+++ b/net-libs/c-client/c-client-2002e-r1.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/c-client/c-client-2002e-r1.ebuild,v 1.1 2003/12/09 04:02:22 robbat2 Exp $
+
+MY_PN=imap
+MY_P=${MY_PN}-${PV}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="UW IMAP c-client library"
+SRC_URI="ftp://ftp.cac.washington.edu/imap/${MY_P}.tar.Z"
+HOMEPAGE="http://www.washington.edu/imap/"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="x86 sparc ppc hppa alpha"
+IUSE="ssl pic"
+
+PROVIDE="virtual/imap-c-client"
+RDEPEND="ssl? ( dev-libs/openssl )
+ !virtual/imap-c-client"
+DEPEND="${RDEPEND}
+ >=sys-libs/pam-0.72"
+
+inherit flag-o-matic eutils
+
+src_unpack() {
+ unpack ${A}
+
+ # Tarball packed with bad file perms
+ chmod -R ug+w ${S}
+
+ # alpha needs -fPIC
+ use pic || use alpha && append-flags -fPIC
+
+ # Modifications so we can build it optimially and correctly
+ sed \
+ -e "s,BASECFLAGS=\".*\",BASECFLAGS=\"${CFLAGS}\",g" \
+ -e 's,SSLDIR=/usr/local/ssl,SSLDIR=/usr,g' \
+ -e 's,SSLCERTS=$(SSLDIR)/certs,SSLCERTS=/etc/ssl/certs,g' \
+ -i ${S}/src/osdep/unix/Makefile
+
+ # Apply a patch to only build the stuff we need for c-client
+ EPATCH_OPTS="${EPATCH_OPTS} -d ${S}" \
+ epatch ${FILESDIR}/2002d-Makefile.patch || die "epatch failed"
+
+ # Remove the pesky checks about SSL stuff
+ sed -e '/read.*exit/d' -i ${S}/Makefile
+}
+
+src_compile() {
+ local ssltype
+ use ssl && ssltype="unix" || ssltype="none"
+ # no parallel builds supported!
+ make lnp SSLTYPE=${ssltype} || die "make failed"
+}
+
+src_install() {
+ into /usr
+
+ # Library binary
+ dolib.a c-client/c-client.a
+ dosym /usr/lib/c-client.a /usr/lib/libc-client.a
+
+ # Headers
+ insinto /usr/include/imap
+ doins c-client/*.h
+ doins c-client/linkage.c
+ #exclude these dupes (can't do it before now due to symlink hell)
+ rm ${D}/usr/include/imap/os_*.h
+
+ # Docs
+ dodoc CPYRIGHT README docs/*.txt docs/CONFIG docs/RELNOTES
+
+ docinto rfc
+ dodoc docs/rfc/*.txt
+}
diff --git a/net-libs/c-client/files/digest-c-client-2002e-r1 b/net-libs/c-client/files/digest-c-client-2002e-r1
new file mode 100644
index 000000000000..cbbff9d87969
--- /dev/null
+++ b/net-libs/c-client/files/digest-c-client-2002e-r1
@@ -0,0 +1 @@
+MD5 0d246d868f20d8c441d235b77c940676 imap-2002e.tar.Z 2157511