summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2011-05-25 01:50:57 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2011-05-25 01:50:57 +0000
commit0830176f6b59b3f83b0718b735b029734e3c3af2 (patch)
treea267bca08cf7f26542b06ab4be07604d4c274d6b /net-libs
parentVersion bump. (diff)
downloadgentoo-2-0830176f6b59b3f83b0718b735b029734e3c3af2.tar.gz
gentoo-2-0830176f6b59b3f83b0718b735b029734e3c3af2.tar.bz2
gentoo-2-0830176f6b59b3f83b0718b735b029734e3c3af2.zip
Version bump, thread-safety fixes.
(Portage version: 2.2.0_alpha34/cvs/Linux x86_64)
Diffstat (limited to 'net-libs')
-rw-r--r--net-libs/glib-networking/ChangeLog8
-rw-r--r--net-libs/glib-networking/glib-networking-2.28.7.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/net-libs/glib-networking/ChangeLog b/net-libs/glib-networking/ChangeLog
index 9d932916504c..fd5e8ce14696 100644
--- a/net-libs/glib-networking/ChangeLog
+++ b/net-libs/glib-networking/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/glib-networking
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/glib-networking/ChangeLog,v 1.4 2011/05/03 15:50:52 darkside Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/glib-networking/ChangeLog,v 1.5 2011/05/25 01:50:57 eva Exp $
+
+*glib-networking-2.28.7 (25 May 2011)
+
+ 25 May 2011; Gilles Dartiguelongue <eva@gentoo.org>
+ +glib-networking-2.28.7.ebuild:
+ Version bump, thread-safety fixes.
03 May 2011; Jeremy Olexa <darkside@gentoo.org>
glib-networking-2.28.6.1.ebuild:
diff --git a/net-libs/glib-networking/glib-networking-2.28.7.ebuild b/net-libs/glib-networking/glib-networking-2.28.7.ebuild
new file mode 100644
index 000000000000..fcab612fdd60
--- /dev/null
+++ b/net-libs/glib-networking/glib-networking-2.28.7.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/glib-networking/glib-networking-2.28.7.ebuild,v 1.1 2011/05/25 01:50:57 eva Exp $
+
+EAPI="3"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+
+inherit gnome2
+
+DESCRIPTION="Network-related giomodules for glib"
+HOMEPAGE="http://git.gnome.org/browse/glib-networking/"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="+gnome +libproxy +ssl"
+
+RDEPEND=">=dev-libs/glib-2.27.90:2
+ gnome? ( gnome-base/gsettings-desktop-schemas )
+ libproxy? ( >=net-libs/libproxy-0.3.1 )
+ ssl? ( >=net-libs/gnutls-2.1.7 )
+"
+DEPEND="${RDEPEND}
+ >=dev-util/intltool-0.35.0
+ >=dev-util/pkgconfig-0.9
+ sys-devel/gettext"
+
+pkg_setup() {
+ # AUTHORS, ChangeLog are empty
+ DOCS="NEWS README"
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-maintainer-mode
+ --with-ca-certificates=/etc/ssl/certs/ca-certificates.crt
+ $(use_with gnome gnome-proxy)
+ $(use_with libproxy)
+ $(use_with ssl gnutls)"
+}