summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2012-06-06 20:33:49 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2012-06-06 20:33:49 +0000
commit6d695289607e75cd3f493ef2b5345bf5fb1cefad (patch)
tree64c04ad153d5463f93df3cd78a3e1614487c9f18 /net-libs/wvstreams
parentDrop HPPA keywording for more ancient versions. (diff)
downloadgentoo-2-6d695289607e75cd3f493ef2b5345bf5fb1cefad.tar.gz
gentoo-2-6d695289607e75cd3f493ef2b5345bf5fb1cefad.tar.bz2
gentoo-2-6d695289607e75cd3f493ef2b5345bf5fb1cefad.zip
Pass --localstatedir=/var to correct uniconfd.ini location. Use -fno-strict-aliasing since this package is not ready for aliasing. Fix compability with sys-devel/gcc >= 4.7 wrt #419563 and #419971 by Ioannis Galanomatis. inherit eutils for epatch
(Portage version: 2.2.0_alpha109/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/wvstreams')
-rw-r--r--net-libs/wvstreams/ChangeLog15
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.6.1-gcc47.patch50
-rw-r--r--net-libs/wvstreams/wvstreams-4.6.1-r1.ebuild4
-rw-r--r--net-libs/wvstreams/wvstreams-4.6.1-r2.ebuild98
4 files changed, 164 insertions, 3 deletions
diff --git a/net-libs/wvstreams/ChangeLog b/net-libs/wvstreams/ChangeLog
index 4421e98ba120..16e9921bfbcd 100644
--- a/net-libs/wvstreams/ChangeLog
+++ b/net-libs/wvstreams/ChangeLog
@@ -1,6 +1,19 @@
# ChangeLog for net-libs/wvstreams
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.143 2012/05/05 02:54:29 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/ChangeLog,v 1.144 2012/06/06 20:33:49 ssuominen Exp $
+
+ 06 Jun 2012; Samuli Suominen <ssuominen@gentoo.org>
+ wvstreams-4.6.1-r1.ebuild:
+ inherit eutils for epatch
+
+*wvstreams-4.6.1-r2 (06 Jun 2012)
+
+ 06 Jun 2012; Samuli Suominen <ssuominen@gentoo.org>
+ +wvstreams-4.6.1-r2.ebuild, +files/wvstreams-4.6.1-gcc47.patch:
+ Pass --localstatedir=/var to correct uniconfd.ini location. Use
+ -fno-strict-aliasing since this package is not ready for aliasing. Fix
+ compability with sys-devel/gcc >= 4.7 wrt #419563 and #419971 by Ioannis
+ Galanomatis.
05 May 2012; Jeff Horelick <jdhore@gentoo.org> wvstreams-4.6.1-r1.ebuild:
dev-util/pkgconfig -> virtual/pkgconfig
diff --git a/net-libs/wvstreams/files/wvstreams-4.6.1-gcc47.patch b/net-libs/wvstreams/files/wvstreams-4.6.1-gcc47.patch
new file mode 100644
index 000000000000..b284da8f3e79
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.6.1-gcc47.patch
@@ -0,0 +1,50 @@
+http://bugs.gentoo.org/419563
+http://bugs.gentoo.org/419971
+
+See -gcc47-patch and -magic.patch in Fedora git:
+
+http://pkgs.fedoraproject.org/gitweb/?p=libwvstreams.git;a=tree
+
+--- include/wvtask.h
++++ include/wvtask.h
+@@ -45,7 +45,8 @@
+ typedef void TaskFunc(void *userdata);
+
+ static int taskcount, numtasks, numrunning;
+- int magic_number, *stack_magic;
++ int volatile magic_number;
++ int *stack_magic;
+ WvString name;
+ int tid;
+
+@@ -84,7 +85,7 @@
+ static WvTaskMan *singleton;
+ static int links;
+
+- static int magic_number;
++ static int volatile magic_number;
+ static WvTaskList all_tasks, free_tasks;
+
+ static void get_stack(WvTask &task, size_t size);
+--- include/wvuid.h
++++ include/wvuid.h
+@@ -7,6 +7,7 @@
+ #ifndef __WVUID_H
+ #define __WVUID_H
+
++#include <unistd.h>
+ #include "wvstring.h"
+
+ #if WIN32
+--- utils/wvtask.cc
++++ utils/wvtask.cc
+@@ -58,7 +58,8 @@
+ int WvTask::taskcount, WvTask::numtasks, WvTask::numrunning;
+
+ WvTaskMan *WvTaskMan::singleton;
+-int WvTaskMan::links, WvTaskMan::magic_number;
++int WvTaskMan::links;
++int volatile WvTaskMan::magic_number;
+ WvTaskList WvTaskMan::all_tasks, WvTaskMan::free_tasks;
+ ucontext_t WvTaskMan::stackmaster_task, WvTaskMan::get_stack_return,
+ WvTaskMan::toplevel;
diff --git a/net-libs/wvstreams/wvstreams-4.6.1-r1.ebuild b/net-libs/wvstreams/wvstreams-4.6.1-r1.ebuild
index e9aed8962a55..98887a3f3b81 100644
--- a/net-libs/wvstreams/wvstreams-4.6.1-r1.ebuild
+++ b/net-libs/wvstreams/wvstreams-4.6.1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.6.1-r1.ebuild,v 1.8 2012/05/05 02:54:29 jdhore Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.6.1-r1.ebuild,v 1.9 2012/06/06 20:33:49 ssuominen Exp $
EAPI=2
-inherit autotools toolchain-funcs versionator
+inherit autotools eutils toolchain-funcs versionator
DESCRIPTION="A network programming library in C++"
HOMEPAGE="http://alumnit.ca/wiki/?WvStreams"
diff --git a/net-libs/wvstreams/wvstreams-4.6.1-r2.ebuild b/net-libs/wvstreams/wvstreams-4.6.1-r2.ebuild
new file mode 100644
index 000000000000..c10e87366a52
--- /dev/null
+++ b/net-libs/wvstreams/wvstreams-4.6.1-r2.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/wvstreams/wvstreams-4.6.1-r2.ebuild,v 1.1 2012/06/06 20:33:49 ssuominen Exp $
+
+EAPI=4
+inherit autotools eutils flag-o-matic toolchain-funcs versionator
+
+DESCRIPTION="A network programming library in C++"
+HOMEPAGE="http://alumnit.ca/wiki/?WvStreams"
+SRC_URI="http://wvstreams.googlecode.com/files/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="pam doc +ssl +dbus debug"
+
+#Tests fail if openssl is not compiled with -DPURIFY. Gentoo's isn't. FAIL!
+RESTRICT="test"
+
+#QA Fail: xplc is compiled as a part of wvstreams.
+#It'll take a larger patching effort to get it extracted, since upstream integrated it
+#more tightly this time. Probably for the better since upstream xplc seems dead.
+
+RDEPEND="sys-libs/readline
+ sys-libs/zlib
+ dbus? ( >=sys-apps/dbus-1.4.20 )
+ dev-libs/openssl:0
+ pam? ( sys-libs/pam )
+ virtual/c++-tr1-functional"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )"
+
+DOCS="ChangeLog README*"
+
+pkg_setup() {
+ if has_version '>=sys-devel/gcc-4.1' && ! has_version '>=dev-libs/boost-1.34.1'
+ then
+ if ! version_is_at_least 4.1 "$(gcc-fullversion)"
+ then
+ eerror "This package requires the active gcc to be at least version 4.1"
+ eerror "or >=dev-libs/boost-1.34.1 must be installed."
+ die "Please activate >=sys-devel/gcc-4.1 with gcc-config."
+ fi
+ fi
+}
+
+src_prepare() {
+ epatch \
+ "${FILESDIR}"/${P}-parallel-make.patch \
+ "${FILESDIR}"/${P}-openssl-1.0.0.patch \
+ "${FILESDIR}"/${P}-glibc212.patch \
+ "${FILESDIR}"/${P}-gcc47.patch
+
+ eautoreconf
+ pushd argp >/dev/null
+ eautoreconf
+ popd >/dev/null
+}
+
+src_configure() {
+ append-flags -fno-strict-aliasing
+ tc-export CXX
+
+ econf \
+ --localstatedir=/var \
+ $(use_enable debug) \
+ --disable-optimization \
+ $(use_with dbus) \
+ --with-openssl \
+ $(use_with pam) \
+ --without-tcl \
+ --without-qt \
+ --with-zlib \
+ --without-valgrind
+}
+
+src_compile() {
+ default
+
+ if use doc; then
+ doxygen || die
+ fi
+}
+
+src_test() {
+ emake test
+}
+
+src_install() {
+ default
+
+ if use doc; then
+ #the list of files is too big for dohtml -r Docs/doxy-html/*
+ cd Docs/doxy-html
+ dohtml -r *
+ fi
+}