summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlin Năstac <mrness@gentoo.org>2007-02-08 19:07:02 +0000
committerAlin Năstac <mrness@gentoo.org>2007-02-08 19:07:02 +0000
commita5a21c851722e394464794ef429d831e92ab00c1 (patch)
tree878eb36233247eec46371a3122e2c5bee09b6aa4 /net-libs/wvstreams/files
parentDepends conditionally on dev-games/cegui (diff)
downloadgentoo-2-a5a21c851722e394464794ef429d831e92ab00c1.tar.gz
gentoo-2-a5a21c851722e394464794ef429d831e92ab00c1.tar.bz2
gentoo-2-a5a21c851722e394464794ef429d831e92ab00c1.zip
Don't add -g -O2 to the user selected CFLAGS. Sanitize the ebuild, thanks to Tiziano Müller <dev-zero@gentoo.org>. Use sys/sysctl.h for __user definition - linux/compiler.h has been removed from kernel 2.6.19 (#164829).
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-libs/wvstreams/files')
-rw-r--r--net-libs/wvstreams/files/digest-wvstreams-4.2.2-r33
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.2.2-sane-cflags.patch59
-rw-r--r--net-libs/wvstreams/files/wvstreams-4.2.2-wireless-user.patch2
3 files changed, 63 insertions, 1 deletions
diff --git a/net-libs/wvstreams/files/digest-wvstreams-4.2.2-r3 b/net-libs/wvstreams/files/digest-wvstreams-4.2.2-r3
new file mode 100644
index 000000000000..02e8894f22b4
--- /dev/null
+++ b/net-libs/wvstreams/files/digest-wvstreams-4.2.2-r3
@@ -0,0 +1,3 @@
+MD5 103230cb9926cb8f3f4d8dc8584f3b9c wvstreams-4.2.2.tar.gz 1269821
+RMD160 dece6092e847976d01568f20707701a8241d30d2 wvstreams-4.2.2.tar.gz 1269821
+SHA256 8fa45a6bfe4d6ac3d9a457543844873090d0c7da817991ac0cd547732f475a14 wvstreams-4.2.2.tar.gz 1269821
diff --git a/net-libs/wvstreams/files/wvstreams-4.2.2-sane-cflags.patch b/net-libs/wvstreams/files/wvstreams-4.2.2-sane-cflags.patch
new file mode 100644
index 000000000000..4435681ccb62
--- /dev/null
+++ b/net-libs/wvstreams/files/wvstreams-4.2.2-sane-cflags.patch
@@ -0,0 +1,59 @@
+diff -Nru wvstreams-4.2.2.orig/vars.mk wvstreams-4.2.2/vars.mk
+--- wvstreams-4.2.2.orig/vars.mk 2007-02-08 20:50:16.000000000 +0200
++++ wvstreams-4.2.2/vars.mk 2007-02-08 20:50:36.000000000 +0200
+@@ -66,10 +66,10 @@
+ CXXFLAGS+=-D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+ CFLAGS+=-D_GNU_SOURCE -D_LARGEFILE_SOURCE -D_FILE_OFFSET_BITS=64
+
+-ifeq ($(DEBUG),)
+-CXXFLAGS+=-g
+-CFLAGS+=-g
+-endif
++#ifeq ($(DEBUG),)
++#CXXFLAGS+=-g
++#CFLAGS+=-g
++#endif
+
+ ifneq ($(DEBUG),)
+ CXXFLAGS+=-ggdb -DDEBUG$(if $(filter-out yes,$(DEBUG)), -DDEBUG_$(DEBUG))
+@@ -91,9 +91,9 @@
+ endif
+
+ ifneq ("$(enable_optimization)", "no")
+-CXXFLAGS+=-O2
++#CXXFLAGS+=-O2
+ #CXXFLAGS+=-felide-constructors
+-CFLAGS+=-O2
++#CFLAGS+=-O2
+ endif
+
+ ifneq ("$(enable_warnings)", "no")
+diff -Nru wvstreams-4.2.2.orig/wvrules.mk wvstreams-4.2.2/wvrules.mk
+--- wvstreams-4.2.2.orig/wvrules.mk 2007-02-08 20:50:16.000000000 +0200
++++ wvstreams-4.2.2/wvrules.mk 2007-02-08 20:49:04.000000000 +0200
+@@ -82,9 +82,9 @@
+ endif
+
+ ifneq ("$(enable_optimization)", "no")
+- CXXFLAGS+=-O2
++ #CXXFLAGS+=-O2
+ #CXXFLAGS+=-felide-constructors
+- CFLAGS+=-O2
++ #CFLAGS+=-O2
+ endif
+
+ ifneq ("$(enable_warnings)", "no")
+@@ -177,11 +177,11 @@
+ C_AND_CXX_FLAGS += -ggdb -DDEBUG=1
+ LDFLAGS += -ggdb
+ else
+- C_AND_CXX_FLAGS += -g -DDEBUG=0
++ C_AND_CXX_FLAGS += -DDEBUG=0
+ #CFLAGS += -DNDEBUG # I don't like disabling assertions...
+ #CFLAGS += -fomit-frame-pointer # really evil
+ #CXXFLAGS += -fno-implement-inlines # causes trouble with egcs 1.0
+- LDFLAGS += -g
++ #LDFLAGS += -g
+ endif
+
+ ifeq ($(PROFILE),1)
diff --git a/net-libs/wvstreams/files/wvstreams-4.2.2-wireless-user.patch b/net-libs/wvstreams/files/wvstreams-4.2.2-wireless-user.patch
index cbb7f2db2c94..35092a93cf01 100644
--- a/net-libs/wvstreams/files/wvstreams-4.2.2-wireless-user.patch
+++ b/net-libs/wvstreams/files/wvstreams-4.2.2-wireless-user.patch
@@ -5,7 +5,7 @@ diff -Nur wvstreams-4.2.2.orig/linuxstreams/wvinterface.cc wvstreams-4.2.2/linux
#include <errno.h>
#include <linux/sockios.h>
-+#include <linux/compiler.h>
++#include <sys/sysctl.h>
#define _LINUX_IF_H /* Hack to prevent loading linux/if.h */
#include <linux/wireless.h>