summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabian Groffen <grobian@gentoo.org>2010-11-25 07:25:39 +0000
committerFabian Groffen <grobian@gentoo.org>2010-11-25 07:25:39 +0000
commite8f76379cf1d6f3e2c5b956c567ae9ccca132f0d (patch)
treee062f87831f7977c1653257d00ff9a483ca8a819 /net-libs/webkit-gtk
parentUse elog instead of einfo. Whitespace. (diff)
downloadgentoo-2-e8f76379cf1d6f3e2c5b956c567ae9ccca132f0d.tar.gz
gentoo-2-e8f76379cf1d6f3e2c5b956c567ae9ccca132f0d.tar.bz2
gentoo-2-e8f76379cf1d6f3e2c5b956c567ae9ccca132f0d.zip
Re-introduce USE=aqua, add necessary patches
(Portage version: 2.2.01.17168-prefix/cvs/Darwin powerpc)
Diffstat (limited to 'net-libs/webkit-gtk')
-rw-r--r--net-libs/webkit-gtk/ChangeLog7
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-1.2.5-darwin-quartz.patch79
-rw-r--r--net-libs/webkit-gtk/files/webkit-gtk-1.2.5-darwin8.patch33
-rw-r--r--net-libs/webkit-gtk/webkit-gtk-1.2.5.ebuild20
4 files changed, 128 insertions, 11 deletions
diff --git a/net-libs/webkit-gtk/ChangeLog b/net-libs/webkit-gtk/ChangeLog
index 12775560c1d2..98c2f97007ee 100644
--- a/net-libs/webkit-gtk/ChangeLog
+++ b/net-libs/webkit-gtk/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/webkit-gtk
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.84 2010/11/24 08:12:00 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/ChangeLog,v 1.85 2010/11/25 07:25:39 grobian Exp $
+
+ 25 Nov 2010; Fabian Groffen <grobian@gentoo.org> webkit-gtk-1.2.5.ebuild,
+ +files/webkit-gtk-1.2.5-darwin-quartz.patch,
+ +files/webkit-gtk-1.2.5-darwin8.patch:
+ Re-introduce USE=aqua, add necessary patches
24 Nov 2010; Fabian Groffen <grobian@gentoo.org> webkit-gtk-1.2.5.ebuild:
Fix double-prefix issue, bug #346595
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-1.2.5-darwin-quartz.patch b/net-libs/webkit-gtk/files/webkit-gtk-1.2.5-darwin-quartz.patch
new file mode 100644
index 000000000000..fe1ebc4d50a8
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-1.2.5-darwin-quartz.patch
@@ -0,0 +1,79 @@
+http://trac.macports.org/browser/trunk/dports/www/webkit-gtk/files/patch-quartz-WebCore-plugins-gtk-gtkxtbin.c.diff?format=txt
+http://trac.macports.org/browser/trunk/dports/www/webkit-gtk/files/patch-quartz-WebCore-plugins-gtk-PluginViewGtk.cpp.diff?format=txt
+
+--- WebCore/plugins/gtk/gtk2xtbin.c.orig 2010-09-10 06:20:33.000000000 -0700
++++ WebCore/plugins/gtk/gtk2xtbin.c 2010-10-06 09:45:37.000000000 -0700
+@@ -41,7 +41,7 @@
+ * The GtkXtBin widget allows for Xt toolkit code to be used
+ * inside a GTK application.
+ */
+-
++#if 0
+ #include "GtkVersioning.h"
+ #include "xembed.h"
+ #include "gtk2xtbin.h"
+@@ -951,3 +951,4 @@
+
+ return;
+ }
++#endif
+--- WebCore/plugins/gtk/PluginViewGtk.cpp.orig 2010-09-10 06:20:33.000000000 -0700
++++ WebCore/plugins/gtk/PluginViewGtk.cpp 2010-10-06 09:45:37.000000000 -0700
+@@ -60,10 +60,13 @@
+ #include "runtime_root.h"
+ #include <runtime/JSLock.h>
+ #include <runtime/JSValue.h>
++#include "NotImplemented.h"
+
+ #include <gdkconfig.h>
+ #include <gtk/gtk.h>
+
++#undef XP_UNIX
++
+ #if defined(XP_UNIX)
+ #include "gtk2xtbin.h"
+ #define Bool int // this got undefined somewhere
+@@ -441,9 +444,9 @@
+ event->setDefaultHandled();
+ }
+
+-#if defined(XP_UNIX)
+ void PluginView::handleFocusInEvent()
+ {
++#if defined(XP_UNIX)
+ XEvent npEvent;
+ initXEvent(&npEvent);
+
+@@ -453,10 +456,12 @@
+ event.detail = NotifyDetailNone;
+
+ dispatchNPEvent(npEvent);
++#endif
+ }
+
+ void PluginView::handleFocusOutEvent()
+ {
++#if defined(XP_UNIX)
+ XEvent npEvent;
+ initXEvent(&npEvent);
+
+@@ -466,8 +471,8 @@
+ event.detail = NotifyDetailNone;
+
+ dispatchNPEvent(npEvent);
+-}
+ #endif
++}
+
+ void PluginView::setParent(ScrollView* parent)
+ {
+@@ -797,8 +802,8 @@
+ }
+
+ if (m_isWindowed) {
+-#if defined(XP_UNIX)
+ GtkWidget* pageClient = m_parentFrame->view()->hostWindow()->platformPageClient();
++#if defined(XP_UNIX)
+
+ if (m_needsXEmbed) {
+ // If our parent is not anchored the startup process will
diff --git a/net-libs/webkit-gtk/files/webkit-gtk-1.2.5-darwin8.patch b/net-libs/webkit-gtk/files/webkit-gtk-1.2.5-darwin8.patch
new file mode 100644
index 000000000000..cf25b5dd57a9
--- /dev/null
+++ b/net-libs/webkit-gtk/files/webkit-gtk-1.2.5-darwin8.patch
@@ -0,0 +1,33 @@
+https://bugs.webkit.org/show_bug.cgi?id=39847
+
+additionally, also on Darwin8 glib stuff includes system headers that
+use isascii, so we can't have it die on that.
+
+--- JavaScriptCore/wtf/FastMalloc.cpp
++++ JavaScriptCore/wtf/FastMalloc.cpp
+@@ -1381,14 +1381,12 @@
+ // Bytes allocated from system
+ uint64_t system_bytes_;
+
+-#if USE_BACKGROUND_THREAD_TO_SCAVENGE_MEMORY
+ // Number of pages kept in free lists that are still committed.
+ Length free_committed_pages_;
+
+ // Minimum number of free committed pages since last scavenge. (Can be 0 if
+ // we've committed new pages since the last scavenge.)
+ Length min_free_committed_pages_since_last_scavenge_;
+-#endif
+
+ bool GrowHeap(Length n);
+
+--- WebCore/config.h
++++ WebCore/config.h
+@@ -125,7 +125,7 @@
+ // this breaks compilation of <QFontDatabase>, at least, so turn it off for now
+ // Also generates errors on wx on Windows, presumably because these functions
+ // are used from wx headers.
+-#if !PLATFORM(QT) && !PLATFORM(WX) && !PLATFORM(CHROMIUM)
++#if !PLATFORM(QT) && !PLATFORM(WX) && !PLATFORM(CHROMIUM) && !defined(BUILDING_ON_TIGER)
+ #include <wtf/DisallowCType.h>
+ #endif
+
diff --git a/net-libs/webkit-gtk/webkit-gtk-1.2.5.ebuild b/net-libs/webkit-gtk/webkit-gtk-1.2.5.ebuild
index 83ab654510e5..966a7557234b 100644
--- a/net-libs/webkit-gtk/webkit-gtk-1.2.5.ebuild
+++ b/net-libs/webkit-gtk/webkit-gtk-1.2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2010 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.2.5.ebuild,v 1.3 2010/11/24 08:12:00 grobian Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/webkit-gtk/webkit-gtk-1.2.5.ebuild,v 1.4 2010/11/25 07:25:39 grobian Exp $
EAPI="3"
@@ -15,19 +15,18 @@ LICENSE="LGPL-2 LGPL-2.1 BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~x86-macos"
# geoclue is missing
-IUSE="coverage debug doc +gstreamer introspection" # aqua
+IUSE="aqua coverage debug doc +gstreamer introspection"
# use sqlite, svg by default
# dependency on >=x11-libs/gtk+-2.13 for gail
# XXX: Quartz patch does not apply
-# >=x11-libs/gtk+-2.13[aqua=]
RDEPEND="
dev-libs/libxml2
dev-libs/libxslt
virtual/jpeg
>=media-libs/libpng-1.4
x11-libs/cairo
- >=x11-libs/gtk+-2.13
+ >=x11-libs/gtk+-2.13[aqua=]
>=dev-libs/glib-2.21.3
>=dev-libs/icu-3.8.1-r1
>=net-libs/libsoup-2.29.90
@@ -55,10 +54,12 @@ src_prepare() {
# https://bugs.webkit.org/show_bug.cgi?id=19775
use sparc && epatch "${FILESDIR}"/${PN}-1.2.3-fix-pool-sparc.patch
- # Darwin/Aqua build is broken, needs autoreconf
- # XXX: BROKEN. Patch does not apply anymore.
+ # intermediate MacPorts hack while upstream bug is not fixed properly
# https://bugs.webkit.org/show_bug.cgi?id=28727
- #epatch "${FILESDIR}"/${PN}-1.1.15.4-darwin-quartz.patch
+ use aqua && epatch "${FILESDIR}"/${P}-darwin-quartz.patch
+
+ # Fix build on Darwin8 (10.4 Tiger)
+ epatch "${FILESDIR}"/${P}-darwin8.patch
# Don't force -O2
sed -i 's/-O2//g' "${S}"/configure.ac || die "sed failed"
@@ -82,10 +83,9 @@ src_configure() {
$(use_enable coverage)
$(use_enable debug)
$(use_enable gstreamer video)
- $(use_enable introspection)"
+ $(use_enable introspection)
+ $(use aqua && echo "--with-font-backend=pango --with-target=quartz")"
# Disable web-sockets per bug #326547
- # quartz patch above does not apply anymore
- #$(use aqua && echo "--with-target=quartz")"
econf ${myconf}
}