summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2014-08-04 22:34:45 +0000
committerManuel Rüger <mrueg@gentoo.org>2014-08-04 22:34:45 +0000
commit8963809a2e0b35daa82ddffae3b06f315be803b5 (patch)
tree066aba54893af0e5e96b74575b306c8c11939cb7 /net-libs/txtorcon
parentUpdate udev rules so that they try power/control if it's present. This avoids... (diff)
downloadgentoo-2-8963809a2e0b35daa82ddffae3b06f315be803b5.tar.gz
gentoo-2-8963809a2e0b35daa82ddffae3b06f315be803b5.tar.bz2
gentoo-2-8963809a2e0b35daa82ddffae3b06f315be803b5.zip
Initial ebuild.
(Portage version: 2.2.11-r1/cvs/Linux x86_64, signed Manifest commit with key )
Diffstat (limited to 'net-libs/txtorcon')
-rw-r--r--net-libs/txtorcon/ChangeLog9
-rw-r--r--net-libs/txtorcon/metadata.xml8
-rw-r--r--net-libs/txtorcon/txtorcon-0.10.1.ebuild30
3 files changed, 47 insertions, 0 deletions
diff --git a/net-libs/txtorcon/ChangeLog b/net-libs/txtorcon/ChangeLog
new file mode 100644
index 000000000000..817c57a72ea1
--- /dev/null
+++ b/net-libs/txtorcon/ChangeLog
@@ -0,0 +1,9 @@
+# ChangeLog for net-libs/txtorcon
+# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/txtorcon/ChangeLog,v 1.1 2014/08/04 22:34:45 mrueg Exp $
+
+*txtorcon-0.10.1 (04 Aug 2014)
+
+ 04 Aug 2014; Manuel Rüger <mrueg@gentoo.org> +metadata.xml,
+ +txtorcon-0.10.1.ebuild:
+ Initial ebuild.
diff --git a/net-libs/txtorcon/metadata.xml b/net-libs/txtorcon/metadata.xml
new file mode 100644
index 000000000000..bfcb6974f1c4
--- /dev/null
+++ b/net-libs/txtorcon/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>mrueg@gentoo.org</email>
+ <name>Manuel Rüger</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/net-libs/txtorcon/txtorcon-0.10.1.ebuild b/net-libs/txtorcon/txtorcon-0.10.1.ebuild
new file mode 100644
index 000000000000..47bb067abaf9
--- /dev/null
+++ b/net-libs/txtorcon/txtorcon-0.10.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/txtorcon/txtorcon-0.10.1.ebuild,v 1.1 2014/08/04 22:34:45 mrueg Exp $
+
+EAPI=5
+PYTHON_COMPAT=(python2_7)
+
+inherit distutils-r1
+
+DESCRIPTION="Twisted-based Tor controller client, with state-tracking and configuration abstractions"
+HOMEPAGE="https://github.com/meejah/txtorcon https://pypi.python.org/pypi/txtorcon"
+SRC_URI="mirror://pypi/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+
+RDEPEND="dev-python/twisted-core[${PYTHON_USEDEP}]
+ dev-python/ipaddr[${PYTHON_USEDEP}]
+ net-misc/tor
+ net-zope/zope-interface[${PYTHON_USEDEP}]"
+
+DEPEND="${RDEPEND}
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ test? ( dev-python/mock[${PYTHON_USEDEP}] )"
+
+python_test() {
+ trial --reporter=text test || die
+}