summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-10-04 19:01:25 +0000
committerPacho Ramos <pacho@gentoo.org>2011-10-04 19:01:25 +0000
commit6a7e3699808a7c559b202b374f4ae638bda5022a (patch)
treed9517723500c3ff2f21c14612bae987d2fa8f67f /net-libs/telepathy-glib
parentStable for HPPA (bug #373639). (diff)
downloadgentoo-2-6a7e3699808a7c559b202b374f4ae638bda5022a.tar.gz
gentoo-2-6a7e3699808a7c559b202b374f4ae638bda5022a.tar.bz2
gentoo-2-6a7e3699808a7c559b202b374f4ae638bda5022a.zip
Version bump.
(Portage version: 2.1.10.20/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/telepathy-glib')
-rw-r--r--net-libs/telepathy-glib/ChangeLog7
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.14.10.ebuild63
2 files changed, 69 insertions, 1 deletions
diff --git a/net-libs/telepathy-glib/ChangeLog b/net-libs/telepathy-glib/ChangeLog
index bef272acc7dd..09d6674ad608 100644
--- a/net-libs/telepathy-glib/ChangeLog
+++ b/net-libs/telepathy-glib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/telepathy-glib
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.84 2011/08/13 18:12:08 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.85 2011/10/04 19:01:25 pacho Exp $
+
+*telepathy-glib-0.14.10 (04 Oct 2011)
+
+ 04 Oct 2011; Pacho Ramos <pacho@gentoo.org> +telepathy-glib-0.14.10.ebuild:
+ Version bump.
13 Aug 2011; Raúl Porcel <armin76@gentoo.org> telepathy-glib-0.14.7.ebuild:
alpha/ia64/sparc stable wrt #369909
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.14.10.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.14.10.ebuild
new file mode 100644
index 000000000000..97cbc318799a
--- /dev/null
+++ b/net-libs/telepathy-glib/telepathy-glib-0.14.10.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.14.10.ebuild,v 1.1 2011/10/04 19:01:25 pacho Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2:2.5"
+
+inherit python virtualx
+
+DESCRIPTION="GLib bindings for the Telepathy D-Bus protocol."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd ~x86-linux"
+IUSE="debug +introspection +vala"
+
+RDEPEND=">=dev-libs/glib-2.25.16:2
+ >=dev-libs/dbus-glib-0.82
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+ vala? (
+ dev-lang/vala:0.14[vapigen]
+ >=dev-libs/gobject-introspection-0.9.6 )"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/pkgconfig-0.21"
+
+src_prepare() {
+ python_convert_shebangs -r 2 examples tests tools
+ default_src_prepare
+}
+
+src_configure() {
+ local myconf
+
+ if use vala; then
+ myconf="--enable-introspection
+ VALAC=$(type -p valac-0.14)
+ VAPIGEN=$(type -p vapigen-0.14)"
+ fi
+
+ econf --disable-static \
+ PYTHON=$(PYTHON -2 -a) \
+ $(use_enable debug backtrace) \
+ $(use_enable debug handle-leak-debug) \
+ $(use_enable debug debug-cache) \
+ $(use_enable introspection) \
+ $(use_enable vala vala-bindings) \
+ ${myconf}
+}
+
+src_test() {
+ # Needs dbus for tests (auto-launched)
+ Xemake -j1 check || die
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+
+ find "${D}" -name '*.la' -exec rm -f '{}' + || die
+}