summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2010-09-21 21:22:28 +0000
committerGilles Dartiguelongue <eva@gentoo.org>2010-09-21 21:22:28 +0000
commit50ce048928c144157b4b039dc5020c11a0de2fb7 (patch)
treeb5dc5a10fbb7e6181979be85c9447aa16580e32e /net-libs/telepathy-glib
parentVersion bump. (diff)
downloadgentoo-2-50ce048928c144157b4b039dc5020c11a0de2fb7.tar.gz
gentoo-2-50ce048928c144157b4b039dc5020c11a0de2fb7.tar.bz2
gentoo-2-50ce048928c144157b4b039dc5020c11a0de2fb7.zip
Version bump. Leak fixes, doc updates, ...
(Portage version: 2.2_rc83/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/telepathy-glib')
-rw-r--r--net-libs/telepathy-glib/ChangeLog8
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.10.7.ebuild40
2 files changed, 47 insertions, 1 deletions
diff --git a/net-libs/telepathy-glib/ChangeLog b/net-libs/telepathy-glib/ChangeLog
index 2fbf9de011e2..f9bf2d6fd8a9 100644
--- a/net-libs/telepathy-glib/ChangeLog
+++ b/net-libs/telepathy-glib/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/telepathy-glib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.49 2010/09/11 09:02:25 nixnut Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.50 2010/09/21 21:22:28 eva Exp $
+
+*telepathy-glib-0.10.7 (21 Sep 2010)
+
+ 21 Sep 2010; Gilles Dartiguelongue <eva@gentoo.org>
+ +telepathy-glib-0.10.7.ebuild:
+ Version bump. Leak fixes, doc updates, ...
11 Sep 2010; <nixnut@gentoo.org> telepathy-glib-0.10.1.ebuild:
ppc stable #321591
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.10.7.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.10.7.ebuild
new file mode 100644
index 000000000000..3092518178ad
--- /dev/null
+++ b/net-libs/telepathy-glib/telepathy-glib-0.10.7.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.10.7.ebuild,v 1.1 2010/09/21 21:22:28 eva Exp $
+
+EAPI="2"
+
+DESCRIPTION="GLib bindings for the Telepathy D-Bus protocol."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/glib-2.16
+ >=dev-libs/dbus-glib-0.73
+ >=dev-lang/python-2.3"
+
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/pkgconfig-0.21"
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable debug backtrace) \
+ $(use_enable debug handle-leak-debug)
+}
+
+src_test() {
+ if ! dbus-launch emake -j1 check; then
+ die "Make check failed. See above for details."
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}