summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArun Raghavan <ford_prefect@gentoo.org>2010-11-03 21:07:34 +0000
committerArun Raghavan <ford_prefect@gentoo.org>2010-11-03 21:07:34 +0000
commit331c53960e90fbe0f08b63889d25d70b38f51289 (patch)
treeb3e0a831d6615a05715ea9f3bda3dffadd8e1c4e /net-libs/telepathy-glib
parentarm stable, bug #341755 (diff)
downloadgentoo-2-331c53960e90fbe0f08b63889d25d70b38f51289.tar.gz
gentoo-2-331c53960e90fbe0f08b63889d25d70b38f51289.tar.bz2
gentoo-2-331c53960e90fbe0f08b63889d25d70b38f51289.zip
Bump to 0.12.3 - small fixes and a bunch of bug fixese since 0.12.0. Also, don't let USE=debug control --enable-debug - this is only enables conditionally enabled code to get debugging output (which upstream needs to actually debug any issues remotely).
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/telepathy-glib')
-rw-r--r--net-libs/telepathy-glib/ChangeLog11
-rw-r--r--net-libs/telepathy-glib/telepathy-glib-0.12.3.ebuild61
2 files changed, 71 insertions, 1 deletions
diff --git a/net-libs/telepathy-glib/ChangeLog b/net-libs/telepathy-glib/ChangeLog
index a813ce213df9..7d29acefb945 100644
--- a/net-libs/telepathy-glib/ChangeLog
+++ b/net-libs/telepathy-glib/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-libs/telepathy-glib
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.54 2010/10/13 21:49:50 eva Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/ChangeLog,v 1.55 2010/11/03 21:07:34 ford_prefect Exp $
+
+*telepathy-glib-0.12.3 (03 Nov 2010)
+
+ 03 Nov 2010; Arun Raghavan <ford_prefect@gentoo.org>
+ +telepathy-glib-0.12.3.ebuild:
+ Bump to 0.12.3 - small fixes and a bunch of bug fixese since 0.12.0. Also,
+ don't let USE=debug control --enable-debug - this is only enables
+ conditionally enabled code to get debugging output (which upstream needs
+ to actually debug any issues remotely).
13 Oct 2010; Gilles Dartiguelongue <eva@gentoo.org>
telepathy-glib-0.12.0.ebuild, metadata.xml:
diff --git a/net-libs/telepathy-glib/telepathy-glib-0.12.3.ebuild b/net-libs/telepathy-glib/telepathy-glib-0.12.3.ebuild
new file mode 100644
index 000000000000..cbb3296b3c0a
--- /dev/null
+++ b/net-libs/telepathy-glib/telepathy-glib-0.12.3.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-glib/telepathy-glib-0.12.3.ebuild,v 1.1 2010/11/03 21:07:34 ford_prefect Exp $
+
+EAPI="2"
+PYTHON_DEPEND="2:2.5"
+
+inherit python
+
+DESCRIPTION="GLib bindings for the Telepathy D-Bus protocol."
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug +introspection vala"
+
+RDEPEND=">=dev-libs/glib-2.24
+ >=dev-libs/dbus-glib-0.82
+ introspection? ( >=dev-libs/gobject-introspection-0.6.14 )
+ vala? (
+ dev-lang/vala:0.10[vapigen]
+ >=dev-libs/gobject-introspection-0.9.6 )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxslt
+ >=dev-util/pkgconfig-0.21"
+
+pkg_setup() {
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_configure() {
+ local myconf
+
+ if use vala; then
+ myconf="--enable-introspection
+ VALAC=$(type -p valac-0.10)
+ VAPIGEN=$(type -p vapigen-0.10)"
+ fi
+
+ econf \
+ $(use_enable debug backtrace) \
+ $(use_enable debug handle-leak-debug) \
+ $(use_enable introspection) \
+ $(use_enable vala vala-bindings) \
+ ${myconf}
+}
+
+src_test() {
+ if ! dbus-launch emake -j1 check; then
+ die "Make check failed. See above for details."
+ fi
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die "emake install failed"
+ dodoc AUTHORS ChangeLog NEWS README || die "dodoc failed"
+}