summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2011-11-20 14:44:02 +0000
committerPacho Ramos <pacho@gentoo.org>2011-11-20 14:44:02 +0000
commitfced064c478d8de019651b5eb701e72cc57520a2 (patch)
treea4a4a32140cd625e9ac6f7c84f0d9fe875db4e84 /net-libs/telepathy-farstream
parentRestrict tests as they need network access (diff)
downloadgentoo-2-fced064c478d8de019651b5eb701e72cc57520a2.tar.gz
gentoo-2-fced064c478d8de019651b5eb701e72cc57520a2.tar.bz2
gentoo-2-fced064c478d8de019651b5eb701e72cc57520a2.zip
Version bump.
(Portage version: 2.1.10.36/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/telepathy-farstream')
-rw-r--r--net-libs/telepathy-farstream/ChangeLog7
-rw-r--r--net-libs/telepathy-farstream/telepathy-farstream-0.1.2.ebuild64
2 files changed, 70 insertions, 1 deletions
diff --git a/net-libs/telepathy-farstream/ChangeLog b/net-libs/telepathy-farstream/ChangeLog
index 72c0863e5d34..28445fdb2063 100644
--- a/net-libs/telepathy-farstream/ChangeLog
+++ b/net-libs/telepathy-farstream/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/telepathy-farstream
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farstream/ChangeLog,v 1.1 2011/10/30 03:26:26 tetromino Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farstream/ChangeLog,v 1.2 2011/11/20 14:44:02 pacho Exp $
+
+*telepathy-farstream-0.1.2 (20 Nov 2011)
+
+ 20 Nov 2011; Pacho Ramos <pacho@gentoo.org> +telepathy-farstream-0.1.2.ebuild:
+ Version bump.
*telepathy-farstream-0.1.1 (30 Oct 2011)
diff --git a/net-libs/telepathy-farstream/telepathy-farstream-0.1.2.ebuild b/net-libs/telepathy-farstream/telepathy-farstream-0.1.2.ebuild
new file mode 100644
index 000000000000..d4dceff33722
--- /dev/null
+++ b/net-libs/telepathy-farstream/telepathy-farstream-0.1.2.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farstream/telepathy-farstream-0.1.2.ebuild,v 1.1 2011/11/20 14:44:01 pacho Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? 2:2.5"
+PYTHON_USE_WITH="xml"
+PYTHON_USE_WITH_OPT="python"
+
+inherit python
+
+DESCRIPTION="Telepathy client library that uses Farsight2 to handle Call channels"
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples python"
+
+RDEPEND=">=dev-libs/glib-2.16:2
+ >=sys-apps/dbus-0.60
+ >=dev-libs/dbus-glib-0.60
+ >=net-libs/telepathy-glib-0.13.4
+ >=net-libs/farsight2-0.0.29
+ python? (
+ >=dev-python/pygobject-2.12.0:2
+ >=dev-python/gst-python-0.10.10 )"
+# python2 is needed at build time in all cases
+DEPEND="${RDEPEND}
+ !python? ( =dev-lang/python-2*[xml] )"
+
+pkg_setup() {
+ # Needed for xincludator.py at build time even if USE=-python
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ if use python; then
+ python_convert_shebangs -r 2 .
+ fi
+}
+
+src_configure() {
+ econf $(use_enable python) --disable-static
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # Remove .la files since static libs are disabled
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ if use python; then
+ insinto /usr/share/doc/${PF}/examples/python
+ doins python/examples/*.py
+ fi
+ fi
+}