summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorNirbheek Chauhan <nirbheek@gentoo.org>2012-03-26 05:28:39 +0000
committerNirbheek Chauhan <nirbheek@gentoo.org>2012-03-26 05:28:39 +0000
commit678f3adcf8cc9cbcfb596b5924ccb0a7f9f73a05 (patch)
tree86e6e7fde3d779d21d045c2c0a14f20e0956b69f /net-libs/telepathy-farstream
parentNew package farstream, rename of farsight2 (diff)
downloadgentoo-2-678f3adcf8cc9cbcfb596b5924ccb0a7f9f73a05.tar.gz
gentoo-2-678f3adcf8cc9cbcfb596b5924ccb0a7f9f73a05.tar.bz2
gentoo-2-678f3adcf8cc9cbcfb596b5924ccb0a7f9f73a05.zip
Bump, uses farstream instead of farsight2. Masked because it blocks farsight2 and everything hasn't been ported over yet.
(Portage version: 2.2.0_alpha95/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/telepathy-farstream')
-rw-r--r--net-libs/telepathy-farstream/ChangeLog9
-rw-r--r--net-libs/telepathy-farstream/telepathy-farstream-0.2.3.ebuild64
2 files changed, 72 insertions, 1 deletions
diff --git a/net-libs/telepathy-farstream/ChangeLog b/net-libs/telepathy-farstream/ChangeLog
index e101cccab937..8c053f73078d 100644
--- a/net-libs/telepathy-farstream/ChangeLog
+++ b/net-libs/telepathy-farstream/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/telepathy-farstream
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farstream/ChangeLog,v 1.4 2012/01/14 17:47:16 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farstream/ChangeLog,v 1.5 2012/03/26 05:28:39 nirbheek Exp $
+
+*telepathy-farstream-0.2.3 (26 Mar 2012)
+
+ 26 Mar 2012; Nirbheek Chauhan <nirbheek@gentoo.org>
+ +telepathy-farstream-0.2.3.ebuild:
+ Bump, uses farstream instead of farsight2. Masked because it blocks farsight2
+ and everything hasn't been ported over yet.
14 Jan 2012; Markus Meier <maekke@gentoo.org>
telepathy-farstream-0.1.2.ebuild:
diff --git a/net-libs/telepathy-farstream/telepathy-farstream-0.2.3.ebuild b/net-libs/telepathy-farstream/telepathy-farstream-0.2.3.ebuild
new file mode 100644
index 000000000000..60e82e2ff055
--- /dev/null
+++ b/net-libs/telepathy-farstream/telepathy-farstream-0.2.3.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/telepathy-farstream/telepathy-farstream-0.2.3.ebuild,v 1.1 2012/03/26 05:28:39 nirbheek Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? 2:2.5"
+PYTHON_USE_WITH="xml"
+PYTHON_USE_WITH_OPT="python"
+
+inherit python
+
+DESCRIPTION="Telepathy client library that uses Farstream to handle Call channels"
+HOMEPAGE="http://telepathy.freedesktop.org"
+SRC_URI="http://telepathy.freedesktop.org/releases/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="examples python"
+
+RDEPEND=">=dev-libs/glib-2.30:2
+ >=sys-apps/dbus-0.60
+ >=dev-libs/dbus-glib-0.60
+ >=net-libs/telepathy-glib-0.17.5
+ >=net-libs/farstream-0.1.0
+ python? (
+ >=dev-python/pygobject-2.12.0:2
+ >=dev-python/gst-python-0.10.10 )"
+# python2 is needed at build time in all cases
+DEPEND="${RDEPEND}
+ !python? ( =dev-lang/python-2*[xml] )"
+
+pkg_setup() {
+ # Needed for xincludator.py at build time even if USE=-python
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ if use python; then
+ python_convert_shebangs -r 2 .
+ fi
+}
+
+src_configure() {
+ econf $(use_enable python) --disable-static
+}
+
+src_install() {
+ emake install DESTDIR="${D}"
+ dodoc AUTHORS ChangeLog NEWS README
+
+ # Remove .la files since static libs are disabled
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins examples/*.c
+ if use python; then
+ insinto /usr/share/doc/${PF}/examples/python
+ doins python/examples/*.py
+ fi
+ fi
+}