summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-04-20 14:56:37 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-04-20 14:56:37 +0000
commitd8cff8b0ce5409e1138962cefd1dee072aaa3102 (patch)
tree10169acf61509d7127f22ab4715403c42efeae68 /net-libs/rb_libtorrent
parentFix threads USE-flag check if boost >1.33, bug 174714 (diff)
downloadgentoo-2-d8cff8b0ce5409e1138962cefd1dee072aaa3102.tar.gz
gentoo-2-d8cff8b0ce5409e1138962cefd1dee072aaa3102.tar.bz2
gentoo-2-d8cff8b0ce5409e1138962cefd1dee072aaa3102.zip
Fix threads USE-flag check if boost >1.33, bug 174714
(Portage version: 2.1.2.4)
Diffstat (limited to 'net-libs/rb_libtorrent')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog6
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.11.ebuild5
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.12_rc3.ebuild5
3 files changed, 11 insertions, 5 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index c1224ef3c6f0..de12c7644ed0 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.10 2007/04/13 21:12:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.11 2007/04/20 14:56:37 armin76 Exp $
+
+ 20 Apr 2007; Raúl Porcel <armin76@gentoo.org> rb_libtorrent-0.11.ebuild,
+ rb_libtorrent-0.12_rc3.ebuild:
+ Fix threads USE-flag check if boost >1.33, bug 174714
*rb_libtorrent-0.12_rc3 (13 Apr 2007)
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.11.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.11.ebuild
index a893b9d214ff..3bfcdf0c7102 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.11.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.11.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.11.ebuild,v 1.6 2007/03/18 22:19:52 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.11.ebuild,v 1.7 2007/04/20 14:56:37 armin76 Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -24,7 +24,8 @@ RDEPEND="${DEPEND}"
pkg_setup() {
# We need boost built with threads
- if ! built_with_use "dev-libs/boost" threads; then
+ if has_version "<dev-libs/boost-1.34" && \
+ ! built_with_use "dev-libs/boost" threads; then
eerror "${PN} needs dev-libs/boost built with threads USE flag"
die "dev-libs/boost is built without threads USE flag"
fi
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.12_rc3.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.12_rc3.ebuild
index 07fbf4a48fca..4bb71fff1af8 100644
--- a/net-libs/rb_libtorrent/rb_libtorrent-0.12_rc3.ebuild
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.12_rc3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.12_rc3.ebuild,v 1.1 2007/04/13 21:12:48 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.12_rc3.ebuild,v 1.2 2007/04/20 14:56:37 armin76 Exp $
WANT_AUTOCONF="latest"
WANT_AUTOMAKE="latest"
@@ -25,7 +25,8 @@ S="${WORKDIR}/${MY_P/_rc*/}"
pkg_setup() {
# We need boost built with threads
- if ! built_with_use "dev-libs/boost" threads; then
+ if has_version "<dev-libs/boost-1.34" && \
+ ! built_with_use "dev-libs/boost" threads; then
eerror "${PN} needs dev-libs/boost built with threads USE flag"
die "dev-libs/boost is built without threads USE flag"
fi