summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkos Chandras <hwoarang@gentoo.org>2013-01-22 20:47:41 +0000
committerMarkos Chandras <hwoarang@gentoo.org>2013-01-22 20:47:41 +0000
commit20505264615871cf9c4e6f1d0fb46f675b5d6193 (patch)
treed33c95939608fb215ae78e4a17f2e055a5c14307 /net-libs/rb_libtorrent
parentJust install the generated pdf docs, not the entire docs directory. (diff)
downloadgentoo-2-20505264615871cf9c4e6f1d0fb46f675b5d6193.tar.gz
gentoo-2-20505264615871cf9c4e6f1d0fb46f675b5d6193.tar.bz2
gentoo-2-20505264615871cf9c4e6f1d0fb46f675b5d6193.zip
Version bump
(Portage version: 2.1.11.47/cvs/Linux x86_64, signed Manifest commit with key B4AFF2C2)
Diffstat (limited to 'net-libs/rb_libtorrent')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog8
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.16.7.ebuild77
2 files changed, 84 insertions, 1 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index d339d920ee95..318aa5fc8743 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.149 2013/01/01 08:23:37 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.150 2013/01/22 20:47:41 hwoarang Exp $
+
+*rb_libtorrent-0.16.7 (22 Jan 2013)
+
+ 22 Jan 2013; Markos Chandras <hwoarang@gentoo.org>
+ +rb_libtorrent-0.16.7.ebuild:
+ Version bump
01 Jan 2013; Agostino Sarubbo <ago@gentoo.org> rb_libtorrent-0.16.5.ebuild:
Stable for arm, wrt bug #442314
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.16.7.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.16.7.ebuild
new file mode 100644
index 000000000000..c4f61b0496a9
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.16.7.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.16.7.ebuild,v 1.1 2013/01/22 20:47:41 hwoarang Exp $
+
+EAPI="4"
+PYTHON_DEPEND="python? 2:2.6"
+PYTHON_USE_WITH="threads"
+PYTHON_USE_WITH_OPT="python"
+
+inherit multilib python versionator
+
+MY_P=${P/rb_/}
+MY_P=${MY_P/torrent/torrent-rasterbar}
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="C++ BitTorrent implementation focusing on efficiency and scalability"
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="http://libtorrent.googlecode.com/files/${MY_P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug doc examples python ssl static-libs"
+RESTRICT="test"
+
+DEPEND=">=dev-libs/boost-1.48[python?,threads(+)]
+ >=sys-devel/libtool-2.2
+ sys-libs/zlib
+ examples? ( !net-p2p/mldonkey )
+ ssl? ( dev-libs/openssl )"
+RDEPEND="${DEPEND}"
+
+pkg_setup() {
+ if use python; then
+ python_set_active_version 2
+ python_pkg_setup
+ fi
+}
+
+src_prepare() {
+ use python && python_convert_shebangs -r 2 .
+}
+
+src_configure() {
+ local myconf
+
+ # bug 441842
+ myconf="--disable-silent-rules"
+
+ # use multi-threading versions of boost libs
+ if has_version '>=dev-libs/boost-1.52.0-r1'; then
+ myconf+=" --with-boost-python=boost_python-${PYTHON_ABI}"
+ else
+ myconf+=" --with-boost-system=boost_system-mt \
+ --with-boost-python=boost_python-${PYTHON_ABI}-mt"
+ fi
+
+ local LOGGING
+ use debug && myconf+=" --enable-logging=verbose"
+
+ econf $(use_enable debug) \
+ $(use_enable test tests) \
+ $(use_enable examples) \
+ $(use_enable python python-binding) \
+ $(use_enable ssl encryption) \
+ $(use_enable static-libs static) \
+ ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ use static-libs || find "${D}" -name '*.la' -exec rm -f {} +
+ dodoc ChangeLog AUTHORS NEWS README
+ if use doc; then
+ dohtml docs/*
+ fi
+}