summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRaúl Porcel <armin76@gentoo.org>2007-04-03 16:43:55 +0000
committerRaúl Porcel <armin76@gentoo.org>2007-04-03 16:43:55 +0000
commit11eed20d5ad04a8c9edee6d4bec68b522f6dd224 (patch)
tree8e6452423a9173600557c4ecb2e7bec7993fe21a /net-libs/rb_libtorrent
parentStable on sparc wrt security #173070 (diff)
downloadgentoo-2-11eed20d5ad04a8c9edee6d4bec68b522f6dd224.tar.gz
gentoo-2-11eed20d5ad04a8c9edee6d4bec68b522f6dd224.tar.bz2
gentoo-2-11eed20d5ad04a8c9edee6d4bec68b522f6dd224.zip
Version bump
(Portage version: 2.1.2.3)
Diffstat (limited to 'net-libs/rb_libtorrent')
-rw-r--r--net-libs/rb_libtorrent/ChangeLog8
-rw-r--r--net-libs/rb_libtorrent/files/digest-rb_libtorrent-0.12_rc23
-rw-r--r--net-libs/rb_libtorrent/rb_libtorrent-0.12_rc2.ebuild51
3 files changed, 61 insertions, 1 deletions
diff --git a/net-libs/rb_libtorrent/ChangeLog b/net-libs/rb_libtorrent/ChangeLog
index 96cc28858996..84d2ae555ae5 100644
--- a/net-libs/rb_libtorrent/ChangeLog
+++ b/net-libs/rb_libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/rb_libtorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.7 2007/03/18 22:19:52 welp Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/ChangeLog,v 1.8 2007/04/03 16:43:55 armin76 Exp $
+
+*rb_libtorrent-0.12_rc2 (03 Apr 2007)
+
+ 03 Apr 2007; Raúl Porcel <armin76@gentoo.org>
+ +rb_libtorrent-0.12_rc2.ebuild:
+ Version bump
18 Mar 2007; Peter Weller <welp@gentoo.org> rb_libtorrent-0.11.ebuild:
Stable on amd64, keyworded ~x86-fbsd
diff --git a/net-libs/rb_libtorrent/files/digest-rb_libtorrent-0.12_rc2 b/net-libs/rb_libtorrent/files/digest-rb_libtorrent-0.12_rc2
new file mode 100644
index 000000000000..8476c1ef181e
--- /dev/null
+++ b/net-libs/rb_libtorrent/files/digest-rb_libtorrent-0.12_rc2
@@ -0,0 +1,3 @@
+MD5 4c41307c268ed139d21b2db01cfa5f14 libtorrent-0.12rc2.tar.gz 1180061
+RMD160 7517525a960333a6be281ef6e8b35cd6c494bab6 libtorrent-0.12rc2.tar.gz 1180061
+SHA256 066be0a2b4e9e89152a1cd1bba4c672f2b1b0b4735e448644061606e1fd1f64e libtorrent-0.12rc2.tar.gz 1180061
diff --git a/net-libs/rb_libtorrent/rb_libtorrent-0.12_rc2.ebuild b/net-libs/rb_libtorrent/rb_libtorrent-0.12_rc2.ebuild
new file mode 100644
index 000000000000..d0e6941203d6
--- /dev/null
+++ b/net-libs/rb_libtorrent/rb_libtorrent-0.12_rc2.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/rb_libtorrent/rb_libtorrent-0.12_rc2.ebuild,v 1.1 2007/04/03 16:43:55 armin76 Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+inherit eutils autotools
+
+MY_P="${P/rb_/}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://www.rasterbar.com/products/libtorrent/"
+SRC_URI="http://www.libtorrent.org/${MY_P/_/}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd"
+IUSE="debug"
+
+DEPEND="dev-libs/boost
+ !net-libs/libtorrent"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P/_rc2/}"
+
+pkg_setup() {
+ # We need boost built with threads
+ if ! built_with_use "dev-libs/boost" threads; then
+ eerror "${PN} needs dev-libs/boost built with threads USE flag"
+ die "dev-libs/boost is built without threads USE flag"
+ fi
+}
+
+src_compile() {
+ BOOST_LIBS="--with-boost-date-time=boost_date_time-mt \
+ --with-boost-filesystem=boost_filesystem-mt \
+ --with-boost-thread=boost_thread-mt \
+ --with-boost-regex=boost_regex-mt \
+ --with-boost-program_options=boost_program_options-mt"
+
+ econf $(use_enable debug) \
+ ${BOOST_LIBS} \
+ LDFLAGS="${LDFLAGS} -pthread" || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc ChangeLog AUTHORS NEWS README
+}