summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-04-20 16:54:30 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-04-20 16:54:30 +0000
commitecde181fb36c3d3aa31c367cd9765fba78f48575 (patch)
treed53ba384aab18f2d093e6769e0772afd8ae61910 /net-libs/osptoolkit
parentFix bug #266002 (diff)
downloadgentoo-2-ecde181fb36c3d3aa31c367cd9765fba78f48575.tar.gz
gentoo-2-ecde181fb36c3d3aa31c367cd9765fba78f48575.tar.bz2
gentoo-2-ecde181fb36c3d3aa31c367cd9765fba78f48575.zip
version bump to 3.5.0, bug 259311
(Portage version: 2.1.6.7/cvs/Linux ppc)
Diffstat (limited to 'net-libs/osptoolkit')
-rw-r--r--net-libs/osptoolkit/ChangeLog7
-rw-r--r--net-libs/osptoolkit/osptoolkit-3.5.0.ebuild94
2 files changed, 100 insertions, 1 deletions
diff --git a/net-libs/osptoolkit/ChangeLog b/net-libs/osptoolkit/ChangeLog
index 8e8287bc75ff..0ba2f9cb8678 100644
--- a/net-libs/osptoolkit/ChangeLog
+++ b/net-libs/osptoolkit/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/osptoolkit
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/osptoolkit/ChangeLog,v 1.12 2009/04/20 04:01:42 volkmar Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/osptoolkit/ChangeLog,v 1.13 2009/04/20 16:54:30 volkmar Exp $
+
+*osptoolkit-3.5.0 (20 Apr 2009)
+
+ 20 Apr 2009; Mounir Lamouri <volkmar@gentoo.org> +osptoolkit-3.5.0.ebuild:
+ Version bump to 3.5.0 with LDFLAGS fix. See bug 259311.
*osptoolkit-3.4.2 (20 Apr 2009)
diff --git a/net-libs/osptoolkit/osptoolkit-3.5.0.ebuild b/net-libs/osptoolkit/osptoolkit-3.5.0.ebuild
new file mode 100644
index 000000000000..ef0f3d770eed
--- /dev/null
+++ b/net-libs/osptoolkit/osptoolkit-3.5.0.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/osptoolkit/osptoolkit-3.5.0.ebuild,v 1.1 2009/04/20 16:54:30 volkmar Exp $
+
+EAPI="2"
+
+inherit eutils multilib toolchain-funcs
+
+S_DATE="20090302"
+
+DESCRIPTION="Open Settlement Protocol development kit"
+HOMEPAGE="http://www.transnexus.com/OSP%20Toolkit/OSP%20Toolkit%20Documents/OSP%20Toolkit%20Documents.htm"
+SRC_URI="mirror://sourceforge/osp-toolkit/OSPToolkit-${PV}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~x86"
+IUSE=""
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}"
+
+S="${WORKDIR}"/TK-${PV//./_}-${S_DATE}
+
+# TODO:
+# generate a shared lib
+
+# NOTES:
+# osptest isn't a test that can be used for src_test, it's part of the toolkit
+
+src_prepare() {
+ # remove -O and use users CFLAGS, see bug 241034
+ sed -i -e "s/ -O//" -e "s/^CFLAGS =/CFLAGS +=/" src/Makefile test/Makefile \
+ enroll/Makefile || die "patching Makefiles failed"
+
+ # use users LDFLAGS
+ sed -i -e "s:LFLAGS:LDFLAGS:" test/Makefile \
+ || die "patching test/Makefile failed"
+ sed -i -e "s:\(\$(LIBS\):\$(LDFLAGS) \1:" enroll/Makefile \
+ || die "patching enroll/Makefile failed"
+
+ # change lib dir to $(get_libdir)
+ sed -i -e "s:\$(INSTALL_PATH)/lib:\$(INSTALL_PATH)/$(get_libdir):" \
+ src/Makefile || die "patching src/Makefile failed"
+
+ # test.cfg is located in /etc/${PN}/test.cfg
+ sed -i -e \
+ "s:\(^#define CONFIG_FILENAME.*\"\).*\(test.cfg\"\):\1/etc/${PN}/\2:" \
+ test/test_app.c || die "patching test/test_app.c failed"
+
+ # configure enroll.sh
+ sed -i -e "s:^\(OPENSSL_CONF\).*:\1=/etc/${PN}/openssl.cnf:" \
+ -e "s:^\(RANDFILE\).*:\1=\/etc/${PN}/.rnd:" \
+ bin/enroll.sh || die "patching bin/enroll.sh failed"
+
+ # change enroll path
+ sed -i -e "s:^\(enroll\):/usr/lib/${PN}/\1:" \
+ bin/enroll.sh || die "patching bin/enroll.sh failed"
+}
+
+src_compile() {
+ local my_cc=$(tc-getCC)
+
+ emake -C src CC="${my_cc}" build || die "emake libosp failed"
+ emake -C enroll CC="${my_cc}" linux || die "emake enroll failed"
+ emake -C test CC="${my_cc}" linux || die "emake test failed"
+}
+
+src_install() {
+ local ospdir="/usr/$(get_libdir)/${PN}"
+
+ emake -C src INSTALL_PATH="${D}"/usr install || die "emake install failed"
+
+ insinto /etc/${PN}
+ doins bin/test.cfg bin/.rnd bin/openssl.cnf || die "doins failed"
+
+ # install enroll and enroll.sh in lib dir to prevent executing them
+ dodir ${ospdir}
+ exeinto ${ospdir}
+ doexe bin/enroll bin/enroll.sh || die "doexe failed"
+
+ # use the symlink to execute enroll.sh
+ dosym ${ospdir}/enroll.sh /usr/bin/ospenroll || die "dosym failed"
+
+ newbin bin/test_app osptest || die "newbin failed"
+
+ dodoc README.txt RELNOTES.txt || die "dodoc failed"
+}
+
+pkg_postinst() {
+ elog "OSP test application is now available with 'osptest' command"
+ elog "OSP enroll application is now available with 'ospenroll' command"
+ elog "ospenroll is using /etc/${PN}/openssl.cnf as an openssl configuration"
+}