summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMounir Lamouri <volkmar@gentoo.org>2009-04-24 03:30:35 +0000
committerMounir Lamouri <volkmar@gentoo.org>2009-04-24 03:30:35 +0000
commit15c013f6c8c3d9acf59bf436f89e5f2ed8e92fa2 (patch)
tree745c77741d614ec9740b9e9dbeb06d50fa5fd8c9 /net-libs/ortp
parent Bumped amarok-2.0.2 to include a lastfm patch. Thanks to Gustavo Henrique Ni... (diff)
downloadgentoo-2-15c013f6c8c3d9acf59bf436f89e5f2ed8e92fa2.tar.gz
gentoo-2-15c013f6c8c3d9acf59bf436f89e5f2ed8e92fa2.tar.bz2
gentoo-2-15c013f6c8c3d9acf59bf436f89e5f2ed8e92fa2.zip
add _p1 ebuild for 0.15.0, patch comes from linphone-3.1.0 bundled ortp
(Portage version: 2.1.6.7/cvs/Linux ppc)
Diffstat (limited to 'net-libs/ortp')
-rw-r--r--net-libs/ortp/ChangeLog7
-rw-r--r--net-libs/ortp/ortp-0.15.0_p1.ebuild89
2 files changed, 95 insertions, 1 deletions
diff --git a/net-libs/ortp/ChangeLog b/net-libs/ortp/ChangeLog
index f72be8887636..c7205967043e 100644
--- a/net-libs/ortp/ChangeLog
+++ b/net-libs/ortp/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/ortp
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/ortp/ChangeLog,v 1.38 2009/04/23 20:01:58 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ortp/ChangeLog,v 1.39 2009/04/24 03:30:35 volkmar Exp $
+
+*ortp-0.15.0_p1 (24 Apr 2009)
+
+ 24 Apr 2009; Mounir Lamouri <volkmar@gentoo.org> +ortp-0.15.0_p1.ebuild:
+ Add ortp-0.15.0 with patch from linphone-3.1.0 to make it working with it.
23 Apr 2009; Markus Meier <maekke@gentoo.org> ortp-0.15.0:
add ~amd64, bug #266193
diff --git a/net-libs/ortp/ortp-0.15.0_p1.ebuild b/net-libs/ortp/ortp-0.15.0_p1.ebuild
new file mode 100644
index 000000000000..49577021b7c0
--- /dev/null
+++ b/net-libs/ortp/ortp-0.15.0_p1.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ortp/ortp-0.15.0_p1.ebuild,v 1.1 2009/04/24 03:30:35 volkmar Exp $
+
+EAPI="2"
+
+inherit eutils
+
+MY_P=${P/_p1/}
+
+DESCRIPTION="Open Real-time Transport Protocol (RTP, RFC3550) stack"
+HOMEPAGE="http://www.linphone.org/index.php/eng/code_review/ortp/"
+SRC_URI="http://download.savannah.nongnu.org/releases/linphone/${PN}/sources/${MY_P}.tar.gz
+ mirror://gentoo/${P}-linphone-3.1.0.patch.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ppc ~ppc64 ~x86"
+IUSE="debug doc examples ipv6 minimal srtp ssl"
+
+RDEPEND="srtp? ( net-libs/libsrtp )
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ # diff patch from linphone-3.1.0 bundled ortp
+ epatch "${WORKDIR}"/${P}-linphone-3.1.0.patch
+
+ # to be sure doc is not builded nor installed w/ -doc and doxygen installed
+ if ! use doc; then
+ sed -i -e 's/test $DOXYGEN != //' configure \
+ || die "patching configure failed"
+ fi
+
+ # to authorize -srtp even with libsrtp installed
+ if ! use srtp; then
+ sed -i -e 's/$have_srtp_headers$have_srtp_lib//' configure \
+ || die "patching configure failed"
+ fi
+
+ # to authorize -ssl even with openssl installed
+ if ! use ssl; then
+ sed -i -e 's/SSL_LIBS=".*"/SSL_LIBS=""/' \
+ -e 's/openssl\/.*.h/poll.h/' configure \
+ || die "patching configure failed"
+ fi
+
+ # do not build examples programs, see bug 226247
+ sed -i -e 's/SUBDIRS = . tests/SUBDIRS = ./' src/Makefile.in \
+ || die "patching src/Makefile.in failed"
+
+ # ${P} is added after ${docdir}
+ if use doc; then
+ sed -i -e 's/$(docdir)\/$(PACKAGE)-$(VERSION)/$(docdir)/' Makefile.in \
+ || die "patching Makefile.in failed"
+ fi
+}
+
+src_configure() {
+ # force docdir to standard Gentoo doc directory
+ # memcheck is for HP-UX only
+ # mode64bit adds +DA2.0W +DS2.0 CFLAGS wich are needed for HP-UX
+ # strict adds -Werror, don't want it
+ econf \
+ --docdir=/usr/share/doc/${PF} \
+ --disable-memcheck \
+ --disable-mode64bit \
+ --disable-strict \
+ --disable-dependency-tracking \
+ --enable-fast-install \
+ --enable-libtool-lock \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable minimal perf)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+
+ dodoc AUTHORS ChangeLog NEWS README TODO || die "dodoc failed"
+
+ if use examples; then
+ insinto /usr/share/doc/${PF}/examples
+ doins src/tests/*.c || die "doins failed"
+ fi
+}