summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGustavo Felisberto <humpback@gentoo.org>2005-09-18 19:25:14 +0000
committerGustavo Felisberto <humpback@gentoo.org>2005-09-18 19:25:14 +0000
commit7c724d7479f74d35ac1c9dd52c2840dd0ab50bd4 (patch)
tree8ae3ec1e9d7b0bda9fc85743f57db41367100319 /net-libs/obby/obby-0.2.1.ebuild
parentstable on amd64 (diff)
downloadgentoo-2-7c724d7479f74d35ac1c9dd52c2840dd0ab50bd4.tar.gz
gentoo-2-7c724d7479f74d35ac1c9dd52c2840dd0ab50bd4.tar.bz2
gentoo-2-7c724d7479f74d35ac1c9dd52c2840dd0ab50bd4.zip
stable on x86 and amd64
(Portage version: 2.0.52-r1)
Diffstat (limited to 'net-libs/obby/obby-0.2.1.ebuild')
-rw-r--r--net-libs/obby/obby-0.2.1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-libs/obby/obby-0.2.1.ebuild b/net-libs/obby/obby-0.2.1.ebuild
new file mode 100644
index 000000000000..b5823dd3702f
--- /dev/null
+++ b/net-libs/obby/obby-0.2.1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/obby/obby-0.2.1.ebuild,v 1.1 2005/09/18 19:25:14 humpback Exp $
+
+DESCRIPTION="Library for collaborative text editing"
+HOMEPAGE="http://darcs.0x539.de/libobby"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~amd64"
+IUSE="howl"
+SRC_URI="http://releases.0x539.de/${PN}/${P}.tar.gz"
+
+DEPEND=">=net-libs/net6-1.1.0
+ >=dev-libs/libsigc++-2.0
+ >=dev-libs/gmp-4.1.4
+ howl? ( >=net-misc/howl-0.9.8 )"
+
+RDEPEND=""
+
+src_compile() {
+ local myconf
+ myconf="${myconf} --disable-tests"
+ use howl && myconf="${myconf} --with-howl"
+ econf ${myconf} || die "./configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ make DESTDIR=${D} install || die
+}