summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Sterrett <mr_bones_@gentoo.org>2012-04-04 15:32:15 +0000
committerMichael Sterrett <mr_bones_@gentoo.org>2012-04-04 15:32:15 +0000
commitc2a02fe034ddd251522c914a03d596a96a0d4b0e (patch)
tree6906853c8c9f9e703bf1c11db64aec72267aee48 /net-libs/nodejs
parentVersion bump. Linux patch 3.3.1 (diff)
downloadgentoo-2-c2a02fe034ddd251522c914a03d596a96a0d4b0e.tar.gz
gentoo-2-c2a02fe034ddd251522c914a03d596a96a0d4b0e.tar.bz2
gentoo-2-c2a02fe034ddd251522c914a03d596a96a0d4b0e.zip
whitespace
(Portage version: 2.1.10.49/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/nodejs-0.7.7.ebuild6
1 files changed, 3 insertions, 3 deletions
diff --git a/net-libs/nodejs/nodejs-0.7.7.ebuild b/net-libs/nodejs/nodejs-0.7.7.ebuild
index d265cd6ad258..171e052bde8f 100644
--- a/net-libs/nodejs/nodejs-0.7.7.ebuild
+++ b/net-libs/nodejs/nodejs-0.7.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.7.7.ebuild,v 1.1 2012/04/04 10:21:57 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.7.7.ebuild,v 1.2 2012/04/04 15:32:15 mr_bones_ Exp $
EAPI=3
@@ -49,7 +49,7 @@ src_install() {
# NOT using make but a JavaScript thingy to try to install things ... to the wrong place
# WHY U NO MAEK SENSE?!
#emake DESTDIR="${D}" install || die
-
+
mkdir -p "${D}"/usr/include/node
mkdir -p "${D}"/bin
mkdir -p "${D}"/lib/node_modules/npm
@@ -57,7 +57,7 @@ src_install() {
cp 'deps/uv/include/ares.h' 'deps/uv/include/ares_version.h' "${D}"/usr/include/node || die "Failed to copy stuff"
cp 'out/Release/node' ${D}/bin/node || die "Failed to copy stuff"
cp -R deps/npm/* ${D}/lib/node_modules/npm || die "Failed to copy stuff"
-
+
# now add some extra stupid just because we can
# needs to be a symlink because of hardcoded paths ... no es bueno!
dosym /lib/node_modules/npm/bin/npm-cli.js /bin/npm