summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrick Lauer <patrick@gentoo.org>2013-11-14 04:11:30 +0000
committerPatrick Lauer <patrick@gentoo.org>2013-11-14 04:11:30 +0000
commit1c94dab1b4decb8750c08f326641624627b794cf (patch)
tree07373ff97b83dc21d9a11d10c76693ce1cea45af /net-libs/nodejs
parentalpha stable, bug 490534. (diff)
downloadgentoo-2-1c94dab1b4decb8750c08f326641624627b794cf.tar.gz
gentoo-2-1c94dab1b4decb8750c08f326641624627b794cf.tar.bz2
gentoo-2-1c94dab1b4decb8750c08f326641624627b794cf.zip
Bump for #490596
(Portage version: 2.2.7/cvs/Linux x86_64, unsigned Manifest commit)
Diffstat (limited to 'net-libs/nodejs')
-rw-r--r--net-libs/nodejs/ChangeLog9
-rw-r--r--net-libs/nodejs/nodejs-0.10.22.ebuild68
-rw-r--r--net-libs/nodejs/nodejs-0.11.8.ebuild84
3 files changed, 160 insertions, 1 deletions
diff --git a/net-libs/nodejs/ChangeLog b/net-libs/nodejs/ChangeLog
index 29a4cb691305..b4207ce30bca 100644
--- a/net-libs/nodejs/ChangeLog
+++ b/net-libs/nodejs/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/nodejs
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.110 2013/10/21 17:49:08 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/ChangeLog,v 1.111 2013/11/14 04:11:30 patrick Exp $
+
+*nodejs-0.10.22 (14 Nov 2013)
+*nodejs-0.11.8 (14 Nov 2013)
+
+ 14 Nov 2013; Patrick Lauer <patrick@gentoo.org> +nodejs-0.10.22.ebuild,
+ +nodejs-0.11.8.ebuild:
+ Bump for #490596
21 Oct 2013; Agostino Sarubbo <ago@gentoo.org> nodejs-0.10.21.ebuild:
Stable for x86, wrt bug #488624
diff --git a/net-libs/nodejs/nodejs-0.10.22.ebuild b/net-libs/nodejs/nodejs-0.10.22.ebuild
new file mode 100644
index 000000000000..81791c241ce5
--- /dev/null
+++ b/net-libs/nodejs/nodejs-0.10.22.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.10.22.ebuild,v 1.1 2013/11/14 04:11:30 patrick Exp $
+
+EAPI=5
+
+# has known failures. sigh.
+RESTRICT="test"
+
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit python-any-r1 pax-utils
+
+DESCRIPTION="Evented IO for V8 Javascript"
+HOMEPAGE="http://nodejs.org/"
+SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="+npm +snapshot"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/node-v${PV}
+
+src_prepare() {
+ # fix compilation on Darwin
+ # http://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+}
+
+src_configure() {
+ local myconf=""
+ ! use npm && myconf="--without-npm"
+ ! use snapshot && myconf="${myconf} --without-snapshot"
+
+ "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
+ --openssl-use-sys --shared-zlib --without-dtrace ${myconf} || die
+}
+
+src_compile() {
+ emake out/Makefile
+ emake -C out mksnapshot
+ pax-mark m out/Release/mksnapshot
+ emake
+}
+
+src_install() {
+ "${PYTHON}" tools/install.py install "${D}"
+
+ use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
+ rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
+ rm -rf "${ED}"/usr/lib/dtrace
+
+ pax-mark -m "${ED}"/usr/bin/node
+}
+
+src_test() {
+ "${PYTHON}" tools/test.py --mode=release simple message || die
+}
diff --git a/net-libs/nodejs/nodejs-0.11.8.ebuild b/net-libs/nodejs/nodejs-0.11.8.ebuild
new file mode 100644
index 000000000000..4043f8007e9b
--- /dev/null
+++ b/net-libs/nodejs/nodejs-0.11.8.ebuild
@@ -0,0 +1,84 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/nodejs/nodejs-0.11.8.ebuild,v 1.1 2013/11/14 04:11:30 patrick Exp $
+
+EAPI=5
+
+# has known failures. sigh.
+RESTRICT="test"
+
+PYTHON_COMPAT=( python2_{6,7} )
+
+inherit python-any-r1 pax-utils
+
+DESCRIPTION="Evented IO for V8 Javascript"
+HOMEPAGE="http://nodejs.org/"
+SRC_URI="http://nodejs.org/dist/v${PV}/node-v${PV}.tar.gz"
+
+LICENSE="Apache-1.1 Apache-2.0 BSD BSD-2 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86 ~x64-macos"
+IUSE="+npm"
+
+RDEPEND="dev-libs/openssl"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/node-v${PV}
+
+src_prepare() {
+ # fix compilation on Darwin
+ # http://code.google.com/p/gyp/issues/detail?id=260
+ sed -i -e "/append('-arch/d" tools/gyp/pylib/gyp/xcode_emulation.py || die
+
+ # make sure we use python2.* while using gyp
+ sed -i -e "s/python/python2/" deps/npm/node_modules/node-gyp/gyp/gyp || die
+
+ # less verbose install output (stating the same as portage, basically)
+ sed -i -e "/print/d" tools/install.py || die
+}
+
+src_configure() {
+ local myconf=""
+ ! use npm && myconf="--without-npm"
+
+ # Use target arch detection logic, see v8-3.18 ebuilds
+ case ${CHOST} in
+ i?86-*)
+ myarch="ia32"
+ myconf+=" -Dv8_target_arch=ia32" ;;
+ x86_64-*)
+ if [[ $ABI = x86 ]] ; then
+ myarch="ia32"
+ else
+ myarch="x64"
+ fi ;;
+ arm*-*)
+ myarch="arm"
+ ;;
+ *) die "Unrecognized CHOST: ${CHOST}"
+ esac
+
+ "${PYTHON}" configure --prefix="${EPREFIX}"/usr \
+ --openssl-use-sys --shared-zlib --without-dtrace ${myconf} || die
+}
+
+src_compile() {
+ emake out/Makefile
+ emake -C out "mksnapshot.${myarch}"
+ pax-mark m "out/Release/mksnapshot.${myarch}"
+ emake
+}
+
+src_install() {
+ "${PYTHON}" tools/install.py install "${D}" /usr
+
+ use npm && dohtml -r "${ED}"/usr/lib/node_modules/npm/html/*
+ rm -rf "${ED}"/usr/lib/node_modules/npm/doc "${ED}"/usr/lib/node_modules/npm/html
+ rm -rf "${ED}"/usr/lib/dtrace
+
+ pax-mark -m "${ED}"/usr/bin/node
+}
+
+src_test() {
+ "${PYTHON}" tools/test.py --mode=release simple message || die
+}