summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-10-15 01:52:03 +0000
committerJeroen Roovers <jer@gentoo.org>2010-10-15 01:52:03 +0000
commit234aaf5c0f0e09fd638fc6e578b785f9c646f49f (patch)
treeb9e3da9b4d86a551a44bbeaa9eb658a00f15610d /net-libs/netwib
parentunused #341041 by jalan (diff)
downloadgentoo-2-234aaf5c0f0e09fd638fc6e578b785f9c646f49f.tar.gz
gentoo-2-234aaf5c0f0e09fd638fc6e578b785f9c646f49f.tar.bz2
gentoo-2-234aaf5c0f0e09fd638fc6e578b785f9c646f49f.zip
Version bump. Update license. Unconditionally install certain docs.
(Portage version: 2.2_rc96/cvs/Linux i686)
Diffstat (limited to 'net-libs/netwib')
-rw-r--r--net-libs/netwib/ChangeLog9
-rw-r--r--net-libs/netwib/netwib-5.38.0.ebuild58
2 files changed, 65 insertions, 2 deletions
diff --git a/net-libs/netwib/ChangeLog b/net-libs/netwib/ChangeLog
index 02174564c386..0cf2356adb40 100644
--- a/net-libs/netwib/ChangeLog
+++ b/net-libs/netwib/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/netwib
-# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/netwib/ChangeLog,v 1.34 2009/11/22 23:35:31 jer Exp $
+# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/netwib/ChangeLog,v 1.35 2010/10/15 01:52:02 jer Exp $
+
+*netwib-5.38.0 (15 Oct 2010)
+
+ 15 Oct 2010; Jeroen Roovers <jer@gentoo.org> +netwib-5.38.0.ebuild:
+ Version bump. Update license. Unconditionally install certain docs.
22 Nov 2009; Jeroen Roovers <jer@gentoo.org> -netwib-5.32.0.ebuild:
Remove old.
diff --git a/net-libs/netwib/netwib-5.38.0.ebuild b/net-libs/netwib/netwib-5.38.0.ebuild
new file mode 100644
index 000000000000..c7803c3f03b3
--- /dev/null
+++ b/net-libs/netwib/netwib-5.38.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/netwib/netwib-5.38.0.ebuild,v 1.1 2010/10/15 01:52:03 jer Exp $
+
+# NOTE: netwib, netwox and netwag go together, bump all or bump none
+
+EAPI="2"
+
+inherit toolchain-funcs multilib
+
+DESCRIPTION="Library of Ethernet, IP, UDP, TCP, ICMP, ARP and RARP protocols"
+HOMEPAGE="http://www.laurentconstantin.com/en/netw/netwib/"
+
+BASEURI="http://www.laurentconstantin.com/common/netw/${PN}/download/"
+SRC_URI="
+ ${BASEURI}v${PV/.*}/${P}-src.tgz
+ doc? ( ${BASEURI}v${PV/.*}/${P}-doc_html.tgz )
+"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~sparc ~x86"
+IUSE="doc"
+
+DEPEND="net-libs/libpcap
+ >=net-libs/libnet-1.1.1"
+
+S="${WORKDIR}/${P}-src/src"
+
+src_prepare() {
+ sed -i \
+ -e 's:/man$:/share/man:g' \
+ -e "s:/lib:/$(get_libdir):" \
+ -e "s:/usr/local:/usr:" \
+ -e "s:=ar:=$(tc-getAR):" \
+ -e "s:=ranlib:=$(tc-getRANLIB):" \
+ -e "s:=gcc:=$(tc-getCC):" \
+ -e "s:-O2:${CFLAGS}:" \
+ config.dat
+}
+
+src_configure() {
+ sh genemake || die "problem creating Makefile"
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc ../README.TXT
+ if use doc; then
+ mkdir "${D}"/usr/share/doc/${PF}/html
+ mv "${WORKDIR}"/${P}-doc_html/{index.html,${PN}} \
+ "${D}"/usr/share/doc/${PF}/html
+ fi
+
+ cd "${S}"/..
+ dodoc doc/{changelog.txt,credits.txt,integration.txt} \
+ doc/{problemreport.txt,problemusageunix.txt,todo.txt}
+}