summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-09-05 19:43:54 +0000
committerMike Gilbert <floppym@gentoo.org>2012-09-05 19:43:54 +0000
commit15527a7b902e0c91f5f0468c54dc9639a39e8765 (patch)
tree3f838c9a1db30cd229132f05e1e55af529bd56b3 /net-libs/neon
parentfix bug #251063 (diff)
downloadgentoo-2-15527a7b902e0c91f5f0468c54dc9639a39e8765.tar.gz
gentoo-2-15527a7b902e0c91f5f0468c54dc9639a39e8765.tar.bz2
gentoo-2-15527a7b902e0c91f5f0468c54dc9639a39e8765.zip
Fix handling of EPREFIX with whitespace. Patch by Arfrever.
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/neon')
-rw-r--r--net-libs/neon/ChangeLog5
-rw-r--r--net-libs/neon/neon-0.29.6-r1.ebuild16
2 files changed, 12 insertions, 9 deletions
diff --git a/net-libs/neon/ChangeLog b/net-libs/neon/ChangeLog
index f5c4197c0087..0c44ca99beb2 100644
--- a/net-libs/neon/ChangeLog
+++ b/net-libs/neon/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-libs/neon
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/neon/ChangeLog,v 1.43 2012/09/05 19:18:27 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/neon/ChangeLog,v 1.44 2012/09/05 19:43:54 floppym Exp $
+
+ 05 Sep 2012; Mike Gilbert <floppym@gentoo.org> neon-0.29.6-r1.ebuild:
+ Fix handling of EPREFIX with whitespace. Patch by Arfrever.
05 Sep 2012; Mike Gilbert <floppym@gentoo.org> neon-0.29.6-r1.ebuild:
Do not inherit versionator.eclass. Patch by Arfrever.
diff --git a/net-libs/neon/neon-0.29.6-r1.ebuild b/net-libs/neon/neon-0.29.6-r1.ebuild
index 86ca73863e2a..e4e9a90495fe 100644
--- a/net-libs/neon/neon-0.29.6-r1.ebuild
+++ b/net-libs/neon/neon-0.29.6-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/neon/neon-0.29.6-r1.ebuild,v 1.13 2012/09/05 19:18:27 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/neon/neon-0.29.6-r1.ebuild,v 1.14 2012/09/05 19:43:54 floppym Exp $
EAPI="4"
@@ -53,23 +53,23 @@ src_prepare() {
}
src_configure() {
- local myconf
+ local myconf=()
if has_version sys-libs/glibc; then
einfo "Enabling SSL library thread-safety using POSIX threads..."
- myconf+=" --enable-threadsafe-ssl=posix"
+ myconf+=(--enable-threadsafe-ssl=posix)
fi
if use expat; then
- myconf+=" --with-expat"
+ myconf+=(--with-expat)
else
- myconf+=" --with-libxml2"
+ myconf+=(--with-libxml2)
fi
if use gnutls; then
- myconf+=" --with-ssl=gnutls --with-ca-bundle=${EPREFIX}/etc/ssl/certs/ca-certificates.crt"
+ myconf+=(--with-ssl=gnutls --with-ca-bundle="${EPREFIX}/etc/ssl/certs/ca-certificates.crt")
elif use ssl; then
- myconf+=" --with-ssl=openssl"
+ myconf+=(--with-ssl=openssl)
fi
# work around broken check, we really need -lintl on Solaris
@@ -83,7 +83,7 @@ src_configure() {
$(use_with pkcs11 pakchois) \
$(use_enable static-libs static) \
$(use_with zlib) \
- ${myconf}
+ "${myconf[@]}"
}
src_install() {