summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2011-01-05 14:53:54 +0000
committerMichał Górny <mgorny@gentoo.org>2011-01-05 14:53:54 +0000
commitb5fb803beb2ec6558fe11e2248a2e3f464f3c951 (patch)
treea01a3f5e56c93ab78ed4e50675524f7949385ddb /net-libs/miniupnpc
parentCorrected HOMEPAGE, #350561, thanks Martin Walch digging that out (diff)
downloadgentoo-2-b5fb803beb2ec6558fe11e2248a2e3f464f3c951.tar.gz
gentoo-2-b5fb803beb2ec6558fe11e2248a2e3f464f3c951.tar.bz2
gentoo-2-b5fb803beb2ec6558fe11e2248a2e3f464f3c951.zip
Version bump.
(Portage version: 2.2.0_alpha12_p8/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/miniupnpc')
-rw-r--r--net-libs/miniupnpc/ChangeLog9
-rw-r--r--net-libs/miniupnpc/miniupnpc-1.5.ebuild63
2 files changed, 70 insertions, 2 deletions
diff --git a/net-libs/miniupnpc/ChangeLog b/net-libs/miniupnpc/ChangeLog
index c5be875d5f61..c1eb54bb302b 100644
--- a/net-libs/miniupnpc/ChangeLog
+++ b/net-libs/miniupnpc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/miniupnpc
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/miniupnpc/ChangeLog,v 1.6 2010/12/21 08:49:16 pva Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/miniupnpc/ChangeLog,v 1.7 2011/01/05 14:53:54 mgorny Exp $
+
+*miniupnpc-1.5 (05 Jan 2011)
+
+ 05 Jan 2011; Michał Górny <mgorny@gentoo.org> +miniupnpc-1.5.ebuild:
+ Version bump.
21 Dec 2010; Peter Volkov <pva@gentoo.org> -miniupnpc-1.4.20100609.ebuild,
miniupnpc-1.4.20100609-r1.ebuild:
diff --git a/net-libs/miniupnpc/miniupnpc-1.5.ebuild b/net-libs/miniupnpc/miniupnpc-1.5.ebuild
new file mode 100644
index 000000000000..18858c9e2ffe
--- /dev/null
+++ b/net-libs/miniupnpc/miniupnpc-1.5.ebuild
@@ -0,0 +1,63 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/miniupnpc/miniupnpc-1.5.ebuild,v 1.1 2011/01/05 14:53:54 mgorny Exp $
+
+EAPI=3
+SUPPORT_PYTHON_ABIS=1
+PYTHON_DEPEND="python? 2"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils toolchain-funcs
+
+DESCRIPTION="UPnP client library and a simple UPnP client"
+HOMEPAGE="http://miniupnp.free.fr/"
+SRC_URI="http://miniupnp.free.fr/files/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="python static-libs"
+
+DEPEND="sys-apps/lsb-release"
+RDEPEND=""
+
+src_prepare() {
+ sed \
+ -e 's/^CFLAGS ?= -O -Wall /CFLAGS += /' \
+ -i Makefile || die
+
+ if use !static-libs; then
+ sed \
+ -e '/FILESTOINSTALL =/s/ $(LIBRARY)//' \
+ -e '/$(INSTALL) -m 644 $(LIBRARY) $(INSTALLDIRLIB)/d' \
+ -i Makefile || die
+ fi
+
+ use python && distutils_src_prepare
+}
+
+src_compile() {
+ emake CC=$(tc-getCC) || die
+
+ use python && distutils_src_compile
+}
+
+src_install() {
+ emake \
+ PREFIX="${D}" \
+ INSTALLDIRLIB="${D}usr/$(get_libdir)" \
+ install || die
+
+ dodoc README Changelog.txt || die
+ doman man3/* || die
+
+ use python && distutils_src_install
+}
+
+pkg_postinst() {
+ use python && distutils_pkg_postinst
+}
+
+pkg_postrm() {
+ use python && distutils_pkg_postrm
+}