summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVictor Ostorga <vostorga@gentoo.org>2009-08-18 20:55:51 +0000
committerVictor Ostorga <vostorga@gentoo.org>2009-08-18 20:55:51 +0000
commit34a5f511afadfe18d01abb3d9963aa893892826a (patch)
tree9d1d6dc26f8670d96a9760bde4d9895ca0d42d20 /net-libs/meanwhile/meanwhile-1.0.2.ebuild
parentVersion bump (diff)
downloadgentoo-2-34a5f511afadfe18d01abb3d9963aa893892826a.tar.gz
gentoo-2-34a5f511afadfe18d01abb3d9963aa893892826a.tar.bz2
gentoo-2-34a5f511afadfe18d01abb3d9963aa893892826a.zip
Fixing buddy list status #239144 , documentation path, bug #241298
(Portage version: 2.1.6.13/cvs/Linux i686)
Diffstat (limited to 'net-libs/meanwhile/meanwhile-1.0.2.ebuild')
-rw-r--r--net-libs/meanwhile/meanwhile-1.0.2.ebuild15
1 files changed, 13 insertions, 2 deletions
diff --git a/net-libs/meanwhile/meanwhile-1.0.2.ebuild b/net-libs/meanwhile/meanwhile-1.0.2.ebuild
index eae492c073e2..087c1bee3893 100644
--- a/net-libs/meanwhile/meanwhile-1.0.2.ebuild
+++ b/net-libs/meanwhile/meanwhile-1.0.2.ebuild
@@ -1,6 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/meanwhile/meanwhile-1.0.2.ebuild,v 1.15 2007/07/13 07:18:13 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/meanwhile/meanwhile-1.0.2.ebuild,v 1.16 2009/08/18 20:55:51 vostorga Exp $
+
+inherit eutils
DESCRIPTION="Meanwhile (Sametime protocol) library"
HOMEPAGE="http://meanwhile.sourceforge.net/"
@@ -18,6 +20,15 @@ DEPEND="${RDEPEND}
dev-util/pkgconfig
doc? ( app-doc/doxygen )"
+src_unpack(){
+ unpack "${A}"
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-presence.patch" #239144
+
+ #241298
+ sed -i -e "/sampledir/ s:-doc::" samples/Makefile.in
+}
+
src_compile() {
local myconf
use doc || myconf="${myconf} --enable-doxygen=no"