summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorD.M.D. Ljungmark <spider@gentoo.org>2002-07-29 02:14:39 +0000
committerD.M.D. Ljungmark <spider@gentoo.org>2002-07-29 02:14:39 +0000
commita30b5cc990c647a5366a563ebdb6cb7b93e35feb (patch)
tree01b88dadde393cbd1535d8ac8893a477e8de701b /net-libs/linc
parentAdded ppc to KEYWORDS. Added RDEPEND and S=. (diff)
downloadgentoo-2-a30b5cc990c647a5366a563ebdb6cb7b93e35feb.tar.gz
gentoo-2-a30b5cc990c647a5366a563ebdb6cb7b93e35feb.tar.bz2
gentoo-2-a30b5cc990c647a5366a563ebdb6cb7b93e35feb.zip
new version of linc was released. needed for other updates
Diffstat (limited to 'net-libs/linc')
-rw-r--r--net-libs/linc/ChangeLog6
-rw-r--r--net-libs/linc/files/digest-linc-0.5.11
-rw-r--r--net-libs/linc/linc-0.5.1.ebuild49
3 files changed, 55 insertions, 1 deletions
diff --git a/net-libs/linc/ChangeLog b/net-libs/linc/ChangeLog
index 064253e79dac..bb2a843f7654 100644
--- a/net-libs/linc/ChangeLog
+++ b/net-libs/linc/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/linc
# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/ChangeLog,v 1.5 2002/06/28 08:25:59 spider Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/ChangeLog,v 1.6 2002/07/29 02:14:39 spider Exp $
+
+*linc-0.5.1 (29 Jul 2002)
+ 29 Jul 2002; Spider <spider@gentoo.org> linc-0.5.1.ebuild :
+ New version
linc-0.5.0-r2 (27 Jun 2002)
28 Jun 2002; Spider <spider@gentoo.org> linc-0.5.0-r2.ebuild :
diff --git a/net-libs/linc/files/digest-linc-0.5.1 b/net-libs/linc/files/digest-linc-0.5.1
new file mode 100644
index 000000000000..9172c7ccb5e7
--- /dev/null
+++ b/net-libs/linc/files/digest-linc-0.5.1
@@ -0,0 +1 @@
+MD5 ddef2cc516388e5db356914fdea00d84 linc-0.5.1.tar.bz2 179545
diff --git a/net-libs/linc/linc-0.5.1.ebuild b/net-libs/linc/linc-0.5.1.ebuild
new file mode 100644
index 000000000000..5f1d9c371c1c
--- /dev/null
+++ b/net-libs/linc/linc-0.5.1.ebuild
@@ -0,0 +1,49 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/net-libs/linc/linc-0.5.1.ebuild,v 1.1 2002/07/29 02:14:39 spider Exp $
+inherit debug
+inherit libtool
+
+
+S=${WORKDIR}/${P}
+DESCRIPTION="A library to ease the writing of networked applications"
+SRC_URI="mirror://gnome/sources/${PN}/${P}.tar.bz2"
+HOMEPAGE="http://www.gnome.org/"
+
+SLOT="0"
+LICENSE="LGPL-2.1"
+KEYWORDS="x86 ppc"
+
+RDEPEND=">=dev-libs/glib-2.0.4-r1
+ >=dev-libs/openssl-0.9.6"
+
+DEPEND="${RDEPEND}
+ doc? ( >=dev-util/gtk-doc-0.9-r2 )
+ >=dev-util/pkgconfig-0.12.0"
+
+src_compile() {
+ elibtoolize
+ local myconf
+ use doc && myconf="${myconf} --enable-gtk-doc" || myconf="${myconf} --disable-gtk-doc"
+
+ # if this is disabled (use) ORBit2 will fail to build. Just force it on
+ myconf="${myconf} --with-openssl"
+ ./configure --host=${CHOST} \
+ --prefix=/usr \
+ --sysconfdir=/etc \
+ --infodir=/usr/share/info \
+ --mandir=/usr/share/man \
+ ${myconf} \
+ --enable-debug=yes || die
+ emake || die
+}
+
+src_install() {
+ make prefix=${D}/usr \
+ sysconfdir=${D}/etc \
+ infodir=${D}/usr/share/info \
+ mandir=${D}/usr/share/man \
+ install || die
+
+ dodoc AUTHORS ChangeLog COPYING HACKING MAINTAINERS README* INSTALL NEWS TODO
+}