summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Alfredsen <loki_val@gentoo.org>2008-06-05 06:41:55 +0000
committerPeter Alfredsen <loki_val@gentoo.org>2008-06-05 06:41:55 +0000
commitfd8292b2240cd1860d624b9735b16c8ddf00e024 (patch)
treeebc9a14dcd1816b5ab905170c0dd44dd9a4ddd4b /net-libs/libtorrent
parentStable on ppc64; bug #197752 (diff)
downloadgentoo-2-fd8292b2240cd1860d624b9735b16c8ddf00e024.tar.gz
gentoo-2-fd8292b2240cd1860d624b9735b16c8ddf00e024.tar.bz2
gentoo-2-fd8292b2240cd1860d624b9735b16c8ddf00e024.zip
Adding bugfix patches recommended by upstream.
(Portage version: 2.1.5.3)
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/ChangeLog14
-rw-r--r--net-libs/libtorrent/files/libtorrent-0.12.2-dht_bounds_fix.patch21
-rw-r--r--net-libs/libtorrent/files/libtorrent-0.12.2-fix_cull.patch13
-rw-r--r--net-libs/libtorrent/files/libtorrent-0.12.2-fix_dht_target.patch44
-rw-r--r--net-libs/libtorrent/files/libtorrent-0.12.2-fix_start_stop_filter.patch19
-rw-r--r--net-libs/libtorrent/files/libtorrent-0.12.2-lt-ver.patch15
-rw-r--r--net-libs/libtorrent/libtorrent-0.12.0.ebuild51
-rw-r--r--net-libs/libtorrent/libtorrent-0.12.2-r2.ebuild (renamed from net-libs/libtorrent/libtorrent-0.12.2-r1.ebuild)11
-rw-r--r--net-libs/libtorrent/metadata.xml9
9 files changed, 140 insertions, 57 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index 4ea6b11ab999..98a8a439b03d 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,18 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.115 2008/06/04 11:52:36 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.116 2008/06/05 06:41:55 loki_val Exp $
+
+*libtorrent-0.12.2-r2 (05 Jun 2008)
+
+ 05 Jun 2008; Peter Alfredsen <loki_val@gentoo.org>
+ +files/libtorrent-0.12.2-dht_bounds_fix.patch,
+ +files/libtorrent-0.12.2-fix_cull.patch,
+ +files/libtorrent-0.12.2-fix_dht_target.patch,
+ +files/libtorrent-0.12.2-fix_start_stop_filter.patch,
+ +files/libtorrent-0.12.2-lt-ver.patch, metadata.xml,
+ -libtorrent-0.12.0.ebuild, -libtorrent-0.12.2-r1.ebuild,
+ +libtorrent-0.12.2-r2.ebuild:
+ Adding bugfix patches recommended by upstream.
*libtorrent-0.12.2-r1 (04 Jun 2008)
diff --git a/net-libs/libtorrent/files/libtorrent-0.12.2-dht_bounds_fix.patch b/net-libs/libtorrent/files/libtorrent-0.12.2-dht_bounds_fix.patch
new file mode 100644
index 000000000000..f1f8cf91552a
--- /dev/null
+++ b/net-libs/libtorrent/files/libtorrent-0.12.2-dht_bounds_fix.patch
@@ -0,0 +1,21 @@
+Index: libtorrent/src/dht/dht_router.cc
+===================================================================
+--- libtorrent/src/dht/dht_router.cc (revision 1060)
++++ libtorrent/src/dht/dht_router.cc (working copy)
+@@ -200,14 +200,14 @@
+
+ DhtRouter::DhtBucketList::iterator
+ DhtRouter::find_bucket(const HashString& id) {
+- DhtBucketList::iterator itr = m_routingTable.upper_bound(id);
++ DhtBucketList::iterator itr = m_routingTable.lower_bound(id);
+
+ #ifdef USE_EXTRA_DEBUG
+ if (itr == m_routingTable.end())
+ throw internal_error("DHT Buckets not covering entire ID space.");
+
+ if (!itr->second->is_in_range(id))
+- throw internal_error("DhtRouter::find_bucket, m_routingTable.upper_bound did not find correct bucket.");
++ throw internal_error("DhtRouter::find_bucket, m_routingTable.lower_bound did not find correct bucket.");
+ #endif
+
+ return itr;
diff --git a/net-libs/libtorrent/files/libtorrent-0.12.2-fix_cull.patch b/net-libs/libtorrent/files/libtorrent-0.12.2-fix_cull.patch
new file mode 100644
index 000000000000..7a6c8499b5ab
--- /dev/null
+++ b/net-libs/libtorrent/files/libtorrent-0.12.2-fix_cull.patch
@@ -0,0 +1,13 @@
+Index: libtorrent/src/download/download_wrapper.cc
+===================================================================
+--- libtorrent/src/download/download_wrapper.cc (revision 1060)
++++ libtorrent/src/download/download_wrapper.cc (working copy)
+@@ -263,7 +263,7 @@
+ // their memory usage.
+ if (ticks % 120 == 0)
+ // if (ticks % 1 == 0)
+- m_main.peer_list()->cull_peers(PeerList::cull_old || PeerList::cull_keep_interesting);
++ m_main.peer_list()->cull_peers(PeerList::cull_old | PeerList::cull_keep_interesting);
+
+ if (!info()->is_open())
+ return;
diff --git a/net-libs/libtorrent/files/libtorrent-0.12.2-fix_dht_target.patch b/net-libs/libtorrent/files/libtorrent-0.12.2-fix_dht_target.patch
new file mode 100644
index 000000000000..88a281bf3eab
--- /dev/null
+++ b/net-libs/libtorrent/files/libtorrent-0.12.2-fix_dht_target.patch
@@ -0,0 +1,44 @@
+Index: libtorrent/src/dht/dht_transaction.cc
+===================================================================
+--- libtorrent/src/dht/dht_transaction.cc (revision 1060)
++++ libtorrent/src/dht/dht_transaction.cc (working copy)
+@@ -46,7 +46,7 @@
+ namespace torrent {
+
+ DhtSearch::DhtSearch(const HashString& target, const DhtBucket& contacts)
+- : base_type(dht_compare_closer(target)),
++ : base_type(dht_compare_closer(m_target = target)),
+ m_pending(0),
+ m_contacted(0),
+ m_replied(0),
+Index: libtorrent/src/dht/dht_transaction.h
+===================================================================
+--- libtorrent/src/dht/dht_transaction.h (revision 1060)
++++ libtorrent/src/dht/dht_transaction.h (working copy)
+@@ -77,7 +77,7 @@
+ const HashString& target() const { return m_target; }
+
+ private:
+- HashString m_target;
++ const HashString& m_target;
+ };
+
+ // DhtSearch contains a list of nodes sorted by closeness to the given target,
+@@ -126,7 +126,7 @@
+ bool start() { m_started = true; return m_pending; }
+ bool complete() const { return m_started && !m_pending; }
+
+- const HashString& target() const { return key_comp().target(); }
++ const HashString& target() const { return m_target; }
+
+ virtual bool is_announce() const { return false; }
+
+@@ -158,6 +158,8 @@
+ DhtSearch(const DhtSearch& s);
+
+ bool node_uncontacted(const DhtNode* node) const;
++
++ HashString m_target;
+ };
+
+ class DhtAnnounce : public DhtSearch {
diff --git a/net-libs/libtorrent/files/libtorrent-0.12.2-fix_start_stop_filter.patch b/net-libs/libtorrent/files/libtorrent-0.12.2-fix_start_stop_filter.patch
new file mode 100644
index 000000000000..2f9267821104
--- /dev/null
+++ b/net-libs/libtorrent/files/libtorrent-0.12.2-fix_start_stop_filter.patch
@@ -0,0 +1,19 @@
+Index: rtorrent/src/main.cc
+===================================================================
+--- rtorrent/src/main.cc (revision 1060)
++++ rtorrent/src/main.cc (working copy)
+@@ -187,12 +187,12 @@
+ "view_filter = active,false=\n"
+
+ "view_add = started\n"
+- "view_filter = started,false=\n"
++ "view_filter = started,d.get_state=\n"
+ "view.event_added = started,scheduler.simple.added=\n"
+ "view.event_removed = started,scheduler.simple.removed=\n"
+
+ "view_add = stopped\n"
+- "view_filter = stopped,false=\n"
++ "view_filter = stopped,not=$d.get_state=\n"
+
+ "view_add = complete\n"
+ "view_filter = complete,d.get_complete=\n"
diff --git a/net-libs/libtorrent/files/libtorrent-0.12.2-lt-ver.patch b/net-libs/libtorrent/files/libtorrent-0.12.2-lt-ver.patch
new file mode 100644
index 000000000000..6408095965dd
--- /dev/null
+++ b/net-libs/libtorrent/files/libtorrent-0.12.2-lt-ver.patch
@@ -0,0 +1,15 @@
+Index: libtorrent/configure.ac
+===================================================================
+--- libtorrent/configure.ac (revision 1060)
++++ libtorrent/configure.ac (working copy)
+@@ -5,8 +5,8 @@
+ AC_DEFINE(PEER_VERSION, "lt\x0C\x20", 4 byte client and version identifier for DHT)
+
+ LIBTORRENT_CURRENT=11
+-LIBTORRENT_REVISION=0
+-LIBTORRENT_AGE=2
++LIBTORRENT_REVISION=2
++LIBTORRENT_AGE=0
+
+ LIBTORRENT_INTERFACE_VERSION_INFO=$LIBTORRENT_CURRENT:$LIBTORRENT_REVISION:$LIBTORRENT_AGE
+ LIBTORRENT_INTERFACE_VERSION_NO=$LIBTORRENT_CURRENT.$LIBTORRENT_AGE.$LIBTORRENT_REVISION
diff --git a/net-libs/libtorrent/libtorrent-0.12.0.ebuild b/net-libs/libtorrent/libtorrent-0.12.0.ebuild
deleted file mode 100644
index 0bdcea74eae2..000000000000
--- a/net-libs/libtorrent/libtorrent-0.12.0.ebuild
+++ /dev/null
@@ -1,51 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.0.ebuild,v 1.2 2008/04/21 14:33:39 flameeyes Exp $
-
-inherit eutils toolchain-funcs flag-o-matic libtool
-
-DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
-HOMEPAGE="http://libtorrent.rakshasa.no/"
-SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-
-IUSE="debug ipv6"
-
-RDEPEND=">=dev-libs/libsigc++-2"
-
-DEPEND="${RDEPEND}
- >=dev-util/pkgconfig-0.11"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
-
- # Patch taken from Debian.
- epatch "${FILESDIR}/${PN}-0.11.9+gcc-4.3.patch"
-}
-
-src_compile() {
- replace-flags -Os -O2
-
- if [[ $(tc-arch) = "x86" ]]; then
- filter-flags -fomit-frame-pointer -fforce-addr
- fi
-
- elibtoolize
- econf \
- $(use_enable debug) \
- $(use_enable ipv6) \
- --enable-static \
- --enable-shared \
- --disable-dependency-tracking \
- || die "econf failed"
-
- emake || die "emake failed"
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "make install failed"
- dodoc AUTHORS ChangeLog NEWS README TODO
-}
diff --git a/net-libs/libtorrent/libtorrent-0.12.2-r1.ebuild b/net-libs/libtorrent/libtorrent-0.12.2-r2.ebuild
index b4c58237b70f..f6193d03f5d2 100644
--- a/net-libs/libtorrent/libtorrent-0.12.2-r1.ebuild
+++ b/net-libs/libtorrent/libtorrent-0.12.2-r2.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.2-r1.ebuild,v 1.1 2008/06/04 11:52:36 loki_val Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.2-r2.ebuild,v 1.1 2008/06/05 06:41:55 loki_val Exp $
-inherit eutils toolchain-funcs flag-o-matic libtool
+inherit autotools eutils toolchain-funcs flag-o-matic libtool
DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
HOMEPAGE="http://libtorrent.rakshasa.no/"
@@ -20,9 +20,14 @@ DEPEND="${RDEPEND}
src_unpack() {
unpack ${A}
cd "${S}"
- elibtoolize
epatch "${FILESDIR}"/${PN}-0.11.9+gcc-4.3.patch
+ epatch "${FILESDIR}"/${P}-dht_bounds_fix.patch
+ epatch "${FILESDIR}"/${P}-fix_cull.patch
+ epatch "${FILESDIR}"/${P}-fix_dht_target.patch
+ epatch "${FILESDIR}"/${P}-lt-ver.patch
epatch "${FILESDIR}"/${P}-tracker_timer_fix.patch
+ elibtoolize #Don't remove
+ eautoreconf
}
src_compile() {
diff --git a/net-libs/libtorrent/metadata.xml b/net-libs/libtorrent/metadata.xml
index a5a65c96ed84..53838cd37dcb 100644
--- a/net-libs/libtorrent/metadata.xml
+++ b/net-libs/libtorrent/metadata.xml
@@ -3,7 +3,12 @@
<pkgmetadata>
<herd>net-p2p</herd>
<maintainer>
- <email>drizzt@gentoo.org</email>
- <description>Secondary Maintainer</description>
+ <email>loki_val@gentoo.org</email>
+ <name>Peter Alfredsen</name>
+ <description>I've changed too much to avoid adding myself</description>
+</maintainer>
+<maintainer>
+ <email>drizzt@gentoo.org</email>
+ <description>Secondary Maintainer</description>
</maintainer>
</pkgmetadata>