summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTimothy Redaelli <drizzt@gentoo.org>2007-09-08 14:36:57 +0000
committerTimothy Redaelli <drizzt@gentoo.org>2007-09-08 14:36:57 +0000
commitbe0ee17a5d0d091f5d3df3c9ad92be84e7ff74f6 (patch)
treea58a6cf9936f040a1275a8fd34461cb4a91df413 /net-libs/libtorrent
parentVersion bump wrt bug #182816. (diff)
downloadgentoo-2-be0ee17a5d0d091f5d3df3c9ad92be84e7ff74f6.tar.gz
gentoo-2-be0ee17a5d0d091f5d3df3c9ad92be84e7ff74f6.tar.bz2
gentoo-2-be0ee17a5d0d091f5d3df3c9ad92be84e7ff74f6.zip
Version bump wrt bug #182816.
(Portage version: 2.1.3.7)
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/ChangeLog8
-rw-r--r--net-libs/libtorrent/files/digest-libtorrent-0.11.83
-rw-r--r--net-libs/libtorrent/libtorrent-0.11.8.ebuild40
3 files changed, 50 insertions, 1 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index d0de2cc63a66..f74500f13afe 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.97 2007/05/24 15:44:46 drizzt Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.98 2007/09/08 14:36:56 drizzt Exp $
+
+*libtorrent-0.11.8 (08 Sep 2007)
+
+ 08 Sep 2007; Timothy Redaelli <drizzt@gentoo.org>
+ +libtorrent-0.11.8.ebuild:
+ Version bump wrt bug #182816.
24 May 2007; Timothy Redaelli <drizzt@gentoo.org>
libtorrent-0.11.4.ebuild:
diff --git a/net-libs/libtorrent/files/digest-libtorrent-0.11.8 b/net-libs/libtorrent/files/digest-libtorrent-0.11.8
new file mode 100644
index 000000000000..e76cb9cc76cd
--- /dev/null
+++ b/net-libs/libtorrent/files/digest-libtorrent-0.11.8
@@ -0,0 +1,3 @@
+MD5 1e50de4a4f0ee6d9c643993aea9bdbf0 libtorrent-0.11.8.tar.gz 541982
+RMD160 ece6dacd4fc10302395a98b9fb8e7147fa91273a libtorrent-0.11.8.tar.gz 541982
+SHA256 077d6c8b1116df33f9b4cbc0581e56540801562c6e98fb1f9a76d33687cf802a libtorrent-0.11.8.tar.gz 541982
diff --git a/net-libs/libtorrent/libtorrent-0.11.8.ebuild b/net-libs/libtorrent/libtorrent-0.11.8.ebuild
new file mode 100644
index 000000000000..db7adc635318
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.11.8.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.11.8.ebuild,v 1.1 2007/09/08 14:36:56 drizzt Exp $
+
+inherit eutils toolchain-funcs flag-o-matic libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+
+IUSE="debug"
+
+RDEPEND=">=dev-libs/libsigc++-2"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.11"
+
+src_compile() {
+ replace-flags -Os -O2
+
+ if [[ $(tc-arch) = "x86" ]]; then
+ filter-flags -fomit-frame-pointer -fforce-addr
+ fi
+
+ elibtoolize
+ econf \
+ $(use_enable debug) \
+ --disable-dependency-tracking \
+ || die "econf failed"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog NEWS README TODO
+}