summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorStanislav Ochotnicky <sochotnicky@gentoo.org>2011-04-13 19:40:47 +0000
committerStanislav Ochotnicky <sochotnicky@gentoo.org>2011-04-13 19:40:47 +0000
commit28bfc8eb45c48b0925364cd3d58771f4b19435fe (patch)
tree65cae0b427cceb7629eb1283994de8b5ca17c926 /net-libs/libtorrent
parentversion bump (diff)
downloadgentoo-2-28bfc8eb45c48b0925364cd3d58771f4b19435fe.tar.gz
gentoo-2-28bfc8eb45c48b0925364cd3d58771f4b19435fe.tar.bz2
gentoo-2-28bfc8eb45c48b0925364cd3d58771f4b19435fe.zip
Add patch to fix tests (thanks to AlphatPC@gmail.com)
(Portage version: 2.1.9.42/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libtorrent')
-rw-r--r--net-libs/libtorrent/ChangeLog6
-rw-r--r--net-libs/libtorrent/files/libtorrent-0.12.7-test.patch13
-rw-r--r--net-libs/libtorrent/libtorrent-0.12.7.ebuild3
3 files changed, 20 insertions, 2 deletions
diff --git a/net-libs/libtorrent/ChangeLog b/net-libs/libtorrent/ChangeLog
index f40efa20c106..1ac8aa6b842c 100644
--- a/net-libs/libtorrent/ChangeLog
+++ b/net-libs/libtorrent/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for net-libs/libtorrent
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.155 2011/04/03 16:04:20 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/ChangeLog,v 1.156 2011/04/13 19:40:46 sochotnicky Exp $
+
+ 13 Apr 2011; Stanislav Ochotnicky <sochotnicky@gentoo.org>
+ libtorrent-0.12.7.ebuild, +files/libtorrent-0.12.7-test.patch:
+ Add patch to fix tests (thanks to AlphatPC@gmail.com)
*libtorrent-0.12.7 (03 Apr 2011)
diff --git a/net-libs/libtorrent/files/libtorrent-0.12.7-test.patch b/net-libs/libtorrent/files/libtorrent-0.12.7-test.patch
new file mode 100644
index 000000000000..b2e3edf786e0
--- /dev/null
+++ b/net-libs/libtorrent/files/libtorrent-0.12.7-test.patch
@@ -0,0 +1,13 @@
+diff --git a/test/rak/allocators_test.cc b/test/rak/allocators_test.cc
+index c607833..249af9a 100644
+--- a/test/rak/allocators_test.cc
++++ b/test/rak/allocators_test.cc
+@@ -6,7 +6,7 @@ CPPUNIT_TEST_SUITE_REGISTRATION(AllocatorsTest);
+
+ template <typename T>
+ bool is_aligned(const T& t) {
+- return t.empty() || (reinterpret_cast<int>(&t[0]) & (LT_SMP_CACHE_BYTES - 1)) == 0x0;
++ return t.empty() || (reinterpret_cast<long>(&t[0]) & (LT_SMP_CACHE_BYTES - 1)) == 0x0;
+ }
+
+ void
diff --git a/net-libs/libtorrent/libtorrent-0.12.7.ebuild b/net-libs/libtorrent/libtorrent-0.12.7.ebuild
index 880c8f03476d..b55a918139cd 100644
--- a/net-libs/libtorrent/libtorrent-0.12.7.ebuild
+++ b/net-libs/libtorrent/libtorrent-0.12.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.7.ebuild,v 1.1 2011/04/03 16:04:20 patrick Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.7.ebuild,v 1.2 2011/04/13 19:40:46 sochotnicky Exp $
EAPI=2
inherit eutils libtool toolchain-funcs
@@ -21,6 +21,7 @@ DEPEND="${RDEPEND}
src_prepare() {
epatch "${FILESDIR}"/${PN}-0.12.6-gcc44.patch
+ epatch "${FILESDIR}"/${P}-test.patch
epatch "${FILESDIR}"/download_constructor.diff
elibtoolize
}