summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSamuli Suominen <ssuominen@gentoo.org>2009-12-22 20:07:40 +0000
committerSamuli Suominen <ssuominen@gentoo.org>2009-12-22 20:07:40 +0000
commit8d489d8f259cf6e9b063ceeb2fcb3c6029cd647f (patch)
tree777782d7b71cf1485433e594c98e82cf6026f4eb /net-libs/libtorrent/libtorrent-0.12.6.ebuild
parentVersion bump and ebuild overhaul. Respect CC, CFLAGS and LDFLAGS. Fix bugs 24... (diff)
downloadgentoo-2-8d489d8f259cf6e9b063ceeb2fcb3c6029cd647f.tar.gz
gentoo-2-8d489d8f259cf6e9b063ceeb2fcb3c6029cd647f.tar.bz2
gentoo-2-8d489d8f259cf6e9b063ceeb2fcb3c6029cd647f.zip
Version bump.
(Portage version: 2.2_rc60/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libtorrent/libtorrent-0.12.6.ebuild')
-rw-r--r--net-libs/libtorrent/libtorrent-0.12.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/net-libs/libtorrent/libtorrent-0.12.6.ebuild b/net-libs/libtorrent/libtorrent-0.12.6.ebuild
new file mode 100644
index 000000000000..484fe9fb27e5
--- /dev/null
+++ b/net-libs/libtorrent/libtorrent-0.12.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libtorrent/libtorrent-0.12.6.ebuild,v 1.1 2009/12/22 20:07:40 ssuominen Exp $
+
+EAPI=2
+inherit eutils libtool
+
+DESCRIPTION="LibTorrent is a BitTorrent library written in C++ for *nix."
+HOMEPAGE="http://libtorrent.rakshasa.no/"
+SRC_URI="http://libtorrent.rakshasa.no/downloads/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="debug ipv6 ssl"
+
+RDEPEND=">=dev-libs/libsigc++-2.2.2:2
+ ssl? ( dev-libs/openssl )"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc44.patch
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ --enable-aligned \
+ $(use_enable debug) \
+ $(use_enable ipv6) \
+ $(use_enable ssl openssl) \
+ --with-posix-fallocate
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS NEWS README
+}