summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-05-26 17:12:09 +0000
committerJeroen Roovers <jer@gentoo.org>2010-05-26 17:12:09 +0000
commit3eb4fbf6725129d43552a5b059e1d4b21c5f099d (patch)
tree197c939361b75b63756f79d62f81fa1aac7dbb81 /net-libs/libssh2
parentBump to EAPI=3, add prefix keywords, clean up ebuild (diff)
downloadgentoo-2-3eb4fbf6725129d43552a5b059e1d4b21c5f099d.tar.gz
gentoo-2-3eb4fbf6725129d43552a5b059e1d4b21c5f099d.tar.bz2
gentoo-2-3eb4fbf6725129d43552a5b059e1d4b21c5f099d.zip
Version bump thanks to Emmanuel Andry (bug #321567).
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'net-libs/libssh2')
-rw-r--r--net-libs/libssh2/ChangeLog7
-rw-r--r--net-libs/libssh2/libssh2-1.2.5.ebuild47
2 files changed, 53 insertions, 1 deletions
diff --git a/net-libs/libssh2/ChangeLog b/net-libs/libssh2/ChangeLog
index 9aa5fc37570d..1203ccee1592 100644
--- a/net-libs/libssh2/ChangeLog
+++ b/net-libs/libssh2/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libssh2
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.31 2010/03/28 17:57:18 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/ChangeLog,v 1.32 2010/05/26 17:12:09 jer Exp $
+
+*libssh2-1.2.5 (26 May 2010)
+
+ 26 May 2010; Jeroen Roovers <jer@gentoo.org> +libssh2-1.2.5.ebuild:
+ Version bump thanks to Emmanuel Andry (bug #321567).
28 Mar 2010; Raúl Porcel <armin76@gentoo.org> libssh2-1.2.2.ebuild:
alpha/ia64/s390/sh stable wrt #298456
diff --git a/net-libs/libssh2/libssh2-1.2.5.ebuild b/net-libs/libssh2/libssh2-1.2.5.ebuild
new file mode 100644
index 000000000000..a1664ae629b5
--- /dev/null
+++ b/net-libs/libssh2/libssh2-1.2.5.ebuild
@@ -0,0 +1,47 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/libssh2-1.2.5.ebuild,v 1.1 2010/05/26 17:12:09 jer Exp $
+
+EAPI="2"
+
+DESCRIPTION="Library implementing the SSH2 protocol"
+HOMEPAGE="http://www.libssh2.org/"
+SRC_URI="http://www.${PN}.org/download/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="gcrypt zlib"
+
+DEPEND="!gcrypt? ( dev-libs/openssl )
+ gcrypt? ( dev-libs/libgcrypt )
+ zlib? ( sys-libs/zlib )"
+RDEPEND="${DEPEND}"
+
+src_configure() {
+ local myconf
+
+ if use gcrypt; then
+ myconf="--with-libgcrypt"
+ else
+ myconf="--with-openssl"
+ fi
+
+ econf \
+ $(use_with zlib libz) \
+ ${myconf}
+}
+
+src_test() {
+ if [[ ${EUID} -ne 0 ]]; then #286741
+ ewarn "Some tests require real user that is allowed to login."
+ ewarn "ssh2.sh test disabled."
+ sed -e 's:ssh2.sh::' -i tests/Makefile
+ fi
+ emake check || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc README
+}