summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-20 06:36:15 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-04-20 06:36:15 +0000
commit2e2d0c89c8597ed15f273a32725ef5a3a31917d6 (patch)
tree37494ffaf43ef18de81059cf2b6331d264f18f97 /net-libs/libsoup
parentVersion bump with various bugfixes. (diff)
downloadgentoo-2-2e2d0c89c8597ed15f273a32725ef5a3a31917d6.tar.gz
gentoo-2-2e2d0c89c8597ed15f273a32725ef5a3a31917d6.tar.bz2
gentoo-2-2e2d0c89c8597ed15f273a32725ef5a3a31917d6.zip
Version bump, fixes crashes and leaks.
(Portage version: 2.2.0_alpha100/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libsoup')
-rw-r--r--net-libs/libsoup/ChangeLog8
-rw-r--r--net-libs/libsoup/libsoup-2.38.1.ebuild69
2 files changed, 76 insertions, 1 deletions
diff --git a/net-libs/libsoup/ChangeLog b/net-libs/libsoup/ChangeLog
index 64685fe2520c..88631df8c3b1 100644
--- a/net-libs/libsoup/ChangeLog
+++ b/net-libs/libsoup/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libsoup
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.276 2012/04/19 20:42:52 ranger Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/ChangeLog,v 1.277 2012/04/20 06:36:15 tetromino Exp $
+
+*libsoup-2.38.1 (20 Apr 2012)
+
+ 20 Apr 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ +libsoup-2.38.1.ebuild:
+ Version bump, fixes crashes and leaks.
19 Apr 2012; Brent Baude <ranger@gentoo.org> libsoup-2.36.1-r1.ebuild:
Marking libsoup-2.36.1-r1 ppc64 stable for bug 410611
diff --git a/net-libs/libsoup/libsoup-2.38.1.ebuild b/net-libs/libsoup/libsoup-2.38.1.ebuild
new file mode 100644
index 000000000000..dff072c8e8c8
--- /dev/null
+++ b/net-libs/libsoup/libsoup-2.38.1.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsoup/libsoup-2.38.1.ebuild,v 1.1 2012/04/20 06:36:15 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="yes"
+GNOME2_LA_PUNT="yes"
+
+inherit autotools eutils gnome2
+
+DESCRIPTION="An HTTP library implementation in C"
+HOMEPAGE="http://live.gnome.org/LibSoup"
+
+LICENSE="LGPL-2"
+SLOT="2.4"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd ~x86-freebsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="debug doc +introspection samba ssl test"
+
+RDEPEND=">=dev-libs/glib-2.31.7:2
+ >=dev-libs/libxml2-2:2
+ >=net-libs/glib-networking-2.30.0[ssl?]
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5 )
+ samba? ( net-fs/samba )"
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.9
+ >=dev-util/gtk-doc-am-1.10
+ doc? ( >=dev-util/gtk-doc-1.10 )"
+# test? ( www-servers/apache[ssl,apache2_modules_auth_digest,apache2_modules_alias,apache2_modules_auth_basic,
+# apache2_modules_authn_file,apache2_modules_authz_host,apache2_modules_authz_user,apache2_modules_dir,
+# apache2_modules_mime,apache2_modules_proxy,apache2_modules_proxy_http,apache2_modules_proxy_connect]
+# dev-lang/php[apache2,xmlrpc]
+# net-misc/curl
+# net-libs/glib-networking[ssl])"
+
+pkg_setup() {
+ # Set invalid apache module dir until apache tests are ready, bug #326957
+ DOCS="AUTHORS NEWS README"
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-tls-check
+ --without-gnome
+ --with-apache-module-dir="${T}"
+ $(use_enable introspection)
+ $(use_with samba ntlm-auth ${EPREFIX}/usr/bin/ntlm_auth)"
+}
+
+src_configure() {
+ # FIXME: we need addpredict to workaround bug #324779 until
+ # root cause (bug #249496) is solved
+ addpredict /usr/share/snmp/mibs/.index
+ gnome2_src_configure
+}
+
+src_prepare() {
+ if ! use test; then
+ # don't waste time building tests (bug #226271)
+ sed 's/^\(SUBDIRS =.*\)tests\(.*\)$/\1\2/' -i Makefile.am Makefile.in \
+ || die "sed failed"
+ fi
+
+ # Patch *must* be applied conditionally (see patch for details)
+ if use doc; then
+ # Fix bug 268592 (upstream #573685) (build fails without gnome && doc)
+ epatch "${FILESDIR}/${PN}-2.34.2-fix-build-without-gnome-with-doc.patch"
+ eautoreconf
+ fi
+
+ gnome2_src_prepare
+}