summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexandre Rostovtsev <tetromino@gentoo.org>2012-10-20 03:01:33 +0000
committerAlexandre Rostovtsev <tetromino@gentoo.org>2012-10-20 03:01:33 +0000
commit1ca8e2a6465e4e8737b37628f6e7af2b935c7407 (patch)
tree971565fdb4ed5e0553211ad1eb9f715bbef8f587 /net-libs/libsocialweb
parentAdd packages.build for hardened/linux/uclibc profiles (diff)
downloadgentoo-2-1ca8e2a6465e4e8737b37628f6e7af2b935c7407.tar.gz
gentoo-2-1ca8e2a6465e4e8737b37628f6e7af2b935c7407.tar.bz2
gentoo-2-1ca8e2a6465e4e8737b37628f6e7af2b935c7407.zip
Version bump, no longer connects to Flickr without permission (bug #438722, CVE-2012-4511, thanks to Agostino Sarubbo). Drop useless USE=doc, it only regenerated documentation. Use vala.eclass.
(Portage version: 2.2.0_alpha137/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libsocialweb')
-rw-r--r--net-libs/libsocialweb/ChangeLog11
-rw-r--r--net-libs/libsocialweb/files/libsocialweb-0.25.21-gmodule.patch48
-rw-r--r--net-libs/libsocialweb/libsocialweb-0.25.20.ebuild7
-rw-r--r--net-libs/libsocialweb/libsocialweb-0.25.21.ebuild83
4 files changed, 143 insertions, 6 deletions
diff --git a/net-libs/libsocialweb/ChangeLog b/net-libs/libsocialweb/ChangeLog
index b91dc6bd4636..c84a89abd01d 100644
--- a/net-libs/libsocialweb/ChangeLog
+++ b/net-libs/libsocialweb/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for net-libs/libsocialweb
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsocialweb/ChangeLog,v 1.12 2012/09/23 06:14:45 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsocialweb/ChangeLog,v 1.13 2012/10/20 03:01:33 tetromino Exp $
+
+*libsocialweb-0.25.21 (20 Oct 2012)
+
+ 20 Oct 2012; Alexandre Rostovtsev <tetromino@gentoo.org>
+ libsocialweb-0.25.20.ebuild, +libsocialweb-0.25.21.ebuild,
+ +files/libsocialweb-0.25.21-gmodule.patch:
+ Version bump, no longer connects to Flickr without permission (bug #438722,
+ CVE-2012-4511, thanks to Agostino Sarubbo). Drop useless USE=doc, it only
+ regenerated documentation. Use vala.eclass.
23 Sep 2012; Anthony G. Basile <blueness@gentoo.org>
libsocialweb-0.25.20.ebuild:
diff --git a/net-libs/libsocialweb/files/libsocialweb-0.25.21-gmodule.patch b/net-libs/libsocialweb/files/libsocialweb-0.25.21-gmodule.patch
new file mode 100644
index 000000000000..e30d66f48f43
--- /dev/null
+++ b/net-libs/libsocialweb/files/libsocialweb-0.25.21-gmodule.patch
@@ -0,0 +1,48 @@
+From 29d049bf2ea710fde880f23a9613d1071de83e7e Mon Sep 17 00:00:00 2001
+From: Alexandre Rostovtsev <tetromino@gentoo.org>
+Date: Fri, 19 Oct 2012 21:46:28 -0400
+Subject: [PATCH] build: explicitly check for and link to gmodule
+
+Needed to prevent underlinking failure with ld.gold and recent versions
+of libsocialweb's dependencies.
+
+https://bugzilla.gnome.org/show_bug.cgi?id=686503
+---
+ configure.ac | 1 +
+ libsocialweb/Makefile.am | 4 ++--
+ 2 files changed, 3 insertions(+), 2 deletions(-)
+
+diff --git a/configure.ac b/configure.ac
+index af23ac2..b9a8f74 100644
+--- a/configure.ac
++++ b/configure.ac
+@@ -65,6 +65,7 @@ GOBJECT_INTROSPECTION_CHECK([0.9.6])
+ PKG_CHECK_MODULES(GLIB, glib-2.0 >= 2.14)
+ PKG_CHECK_MODULES(GIO, gio-2.0)
+ PKG_CHECK_MODULES(GOBJECT, gobject-2.0 >= 2.14)
++PKG_CHECK_MODULES(GMODULE, gmodule-2.0)
+ PKG_CHECK_MODULES(GCONF, gconf-2.0)
+ PKG_CHECK_MODULES(SOUP, libsoup-2.4 gthread-2.0)
+ PKG_CHECK_MODULES(DBUS_GLIB, dbus-glib-1)
+diff --git a/libsocialweb/Makefile.am b/libsocialweb/Makefile.am
+index fa7d88b..57d0d34 100644
+--- a/libsocialweb/Makefile.am
++++ b/libsocialweb/Makefile.am
+@@ -10,12 +10,12 @@ libsocialweb_ladir = $(pkgincludedir)/libsocialweb
+ libsocialweb_la_CFLAGS = -I$(top_srcdir) -I$(top_srcdir)/interfaces \
+ $(DBUS_GLIB_CFLAGS) $(SOUP_CFLAGS) $(SOUP_GNOME_CFLAGS) \
+ $(NM_CFLAGS) $(GTK_CFLAGS) $(REST_CFLAGS) \
+- $(GCOV_CFLAGS) \
++ $(GMODULE_CFLAGS) $(GCOV_CFLAGS) \
+ -DSOCIALWEB_SERVICES_MODULES_DIR=\"$(servicesdir)\"
+
+ libsocialweb_la_LIBADD = $(DBUS_GLIB_LIBS) $(SOUP_LIBS) $(SOUP_GNOME_LIBS) \
+ $(NM_LIBS) $(GTK_LIBS) $(REST_LIBS) \
+- $(GCOV_LDFLAGS) \
++ $(GMODULE_LIBS) $(GCOV_LDFLAGS) \
+ $(top_builddir)/interfaces/libsocialweb-ginterfaces.la
+
+ libsocialweb_la_SOURCES = sw-types.h \
+--
+1.7.12.3
+
diff --git a/net-libs/libsocialweb/libsocialweb-0.25.20.ebuild b/net-libs/libsocialweb/libsocialweb-0.25.20.ebuild
index 1549262c4c5d..71e9398ea59b 100644
--- a/net-libs/libsocialweb/libsocialweb-0.25.20.ebuild
+++ b/net-libs/libsocialweb/libsocialweb-0.25.20.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libsocialweb/libsocialweb-0.25.20.ebuild,v 1.8 2012/09/23 06:14:45 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsocialweb/libsocialweb-0.25.20.ebuild,v 1.9 2012/10/20 03:01:33 tetromino Exp $
EAPI="4"
GCONF_DEBUG="no"
@@ -15,7 +15,7 @@ HOMEPAGE="http://git.gnome.org/browse/libsocialweb"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="amd64 ~ppc ~ppc64 x86"
-IUSE="doc connman +gnome +introspection +networkmanager vala"
+IUSE="connman +gnome +introspection +networkmanager vala"
# NOTE: coverage testing should not be enabled
RDEPEND=">=dev-libs/glib-2.14:2
@@ -36,9 +36,6 @@ DEPEND="${RDEPEND}
>=dev-util/intltool-0.40
virtual/pkgconfig
sys-devel/gettext
- doc? (
- dev-libs/libxslt
- >=dev-util/gtk-doc-1.15 )
vala? (
>=dev-lang/vala-0.10.0:0.12[vapigen]
>=dev-libs/gobject-introspection-0.9.6 )"
diff --git a/net-libs/libsocialweb/libsocialweb-0.25.21.ebuild b/net-libs/libsocialweb/libsocialweb-0.25.21.ebuild
new file mode 100644
index 000000000000..9c76155137a8
--- /dev/null
+++ b/net-libs/libsocialweb/libsocialweb-0.25.21.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libsocialweb/libsocialweb-0.25.21.ebuild,v 1.1 2012/10/20 03:01:33 tetromino Exp $
+
+EAPI="4"
+GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
+PYTHON_DEPEND="2"
+VALA_MIN_API_VERSION="0.12"
+VALA_USE_DEPEND="vapigen"
+
+inherit autotools eutils gnome2 python vala
+
+DESCRIPTION="Social web services integration framework"
+HOMEPAGE="http://git.gnome.org/browse/libsocialweb"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="connman +gnome +introspection +networkmanager vala"
+
+# NOTE: coverage testing should not be enabled
+RDEPEND=">=dev-libs/glib-2.14:2
+ >=net-libs/rest-0.7.10
+
+ gnome-base/gconf:2
+ gnome-base/libgnome-keyring
+ dev-libs/dbus-glib
+ dev-libs/json-glib
+ net-libs/libsoup:2.4
+
+ gnome? ( >=net-libs/libsoup-gnome-2.25.1:2.4 )
+ introspection? ( >=dev-libs/gobject-introspection-0.9.6 )
+ networkmanager? ( net-misc/networkmanager )
+ !networkmanager? ( connman? ( net-misc/connman ) )"
+DEPEND="${RDEPEND}
+ >=dev-util/gtk-doc-am-1.15
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+# Introspection is needed for vala bindings
+REQUIRED_USE="vala? ( introspection )"
+
+pkg_setup() {
+ # TODO: enable sys-apps/keyutils support (--without-kernel-keyring)
+ G2CONF="${G2CONF}
+ --disable-static
+ --disable-gcov
+ --without-kernel-keyring
+ --enable-all-services
+ $(use_enable introspection)
+ $(use_enable vala vala-bindings)
+ $(use_with gnome)
+ --with-online=always"
+
+ # NetworkManager always overrides connman support
+ use connman && G2CONF="${G2CONF} --with-online=connman"
+ use networkmanager && G2CONF="${G2CONF} --with-online=networkmanager"
+
+ DOCS="AUTHORS README TODO"
+
+ python_set_active_version 2
+ python_pkg_setup
+}
+
+src_prepare() {
+ # Sent upstream, gnome bug 677445
+ epatch "${FILESDIR}"/${PN}-0.25.20-gold.patch
+ # https://bugzilla.gnome.org/show_bug.cgi?id=686503
+ epatch "${FILESDIR}"/${PN}-0.25.21-gmodule.patch
+
+ # Fix namespacing of introspection annotations, bug #426984
+ epatch "${FILESDIR}"/${PN}-0.25.20-introspection-annotations.patch
+
+ eautoreconf
+
+ gnome2_src_prepare
+ use vala && vala_src_prepare
+
+ python_convert_shebangs 2 "${S}/tools/glib-ginterface-gen.py"
+}