summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-27 10:02:30 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2010-07-27 10:02:30 +0000
commit7ea2fa6121eb2de1591c56b2c0f174d4c5074779 (patch)
tree064506804cb16cc4619d2e49de3816c60c9a1bfb /net-libs/librpcsecgss/librpcsecgss-0.19-r1.ebuild
parentDisable building of static library and remove .la file. (diff)
downloadgentoo-2-7ea2fa6121eb2de1591c56b2c0f174d4c5074779.tar.gz
gentoo-2-7ea2fa6121eb2de1591c56b2c0f174d4c5074779.tar.bz2
gentoo-2-7ea2fa6121eb2de1591c56b2c0f174d4c5074779.zip
Cleanup old versions; add new version without static or .la libraries.
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/librpcsecgss/librpcsecgss-0.19-r1.ebuild')
-rw-r--r--net-libs/librpcsecgss/librpcsecgss-0.19-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-libs/librpcsecgss/librpcsecgss-0.19-r1.ebuild b/net-libs/librpcsecgss/librpcsecgss-0.19-r1.ebuild
new file mode 100644
index 000000000000..f8a3b8547633
--- /dev/null
+++ b/net-libs/librpcsecgss/librpcsecgss-0.19-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/librpcsecgss/librpcsecgss-0.19-r1.ebuild,v 1.1 2010/07/27 10:02:30 flameeyes Exp $
+
+EAPI=2
+
+DESCRIPTION="implementation of rpcsec_gss (RFC 2203) for secure rpc communication"
+HOMEPAGE="http://www.citi.umich.edu/projects/nfsv4/linux/"
+SRC_URI="http://www.citi.umich.edu/projects/nfsv4/linux/${PN}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+RDEPEND="net-libs/libgssglue"
+DEPEND="${RDEPEND}
+ dev-util/pkgconfig"
+
+src_configure() {
+ # No need to install static libraries, as it uses non-static dependencies
+ econf --disable-static
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ find "${D}" -name '*.la' -delete || die
+
+ dodoc AUTHORS ChangeLog NEWS README
+}