summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2009-06-29 19:26:14 +0000
committerMart Raudsepp <leio@gentoo.org>2009-06-29 19:26:14 +0000
commite82d6c5eb3a64b8d9cd9207e4798e23f4273cd14 (patch)
treed44929676b7a6ae06ca8d6652def983a84260968 /net-libs/libproxy
parentVersion bump (diff)
downloadgentoo-2-e82d6c5eb3a64b8d9cd9207e4798e23f4273cd14.tar.gz
gentoo-2-e82d6c5eb3a64b8d9cd9207e4798e23f4273cd14.tar.bz2
gentoo-2-e82d6c5eb3a64b8d9cd9207e4798e23f4273cd14.zip
Fix automagic mozilla-js provider picking, so that with USE=xulrunner xulrunner-1.9 is always picked, and with USE="seamonkey -xulrunner" seamonkey-js is always picked. Depend on a xulrunner:1.9 that has its mozilla-js pkgconfig file usable for us while building to fix bug 275318 once and for all
(Portage version: 2.2_rc22/cvs/Linux 2.6.30-gentoo-r1 x86_64, RepoMan options: --force)
Diffstat (limited to 'net-libs/libproxy')
-rw-r--r--net-libs/libproxy/ChangeLog10
-rw-r--r--net-libs/libproxy/files/libproxy-0.2.3-fix-automagic-mozjs.patch60
-rw-r--r--net-libs/libproxy/libproxy-0.2.3-r2.ebuild (renamed from net-libs/libproxy/libproxy-0.2.3-r1.ebuild)29
3 files changed, 89 insertions, 10 deletions
diff --git a/net-libs/libproxy/ChangeLog b/net-libs/libproxy/ChangeLog
index 3e9cfc2c833d..3eea3e7dbc6a 100644
--- a/net-libs/libproxy/ChangeLog
+++ b/net-libs/libproxy/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/libproxy
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.15 2009/06/25 20:53:37 mrpouet Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/ChangeLog,v 1.16 2009/06/29 19:26:13 leio Exp $
+
+ 29 Jun 2009; Mart Raudsepp <leio@gentoo.org>
+ +files/libproxy-0.2.3-fix-automagic-mozjs.patch:
+ Fix automagic mozilla-js provider picking, so that with USE=xulrunner
+ xulrunner-1.9 is always picked, and with USE="seamonkey -xulrunner"
+ seamonkey-js is always picked. Depend on a xulrunner:1.9 that has its
+ mozilla-js pkgconfig file usable for us while building to fix bug 275318
+ once and for all
25 Jun 2009; Romain Perier <mrpouet@gentoo.org>
files/libproxy-0.2.3-fix-mozjs-cflags.patch:
diff --git a/net-libs/libproxy/files/libproxy-0.2.3-fix-automagic-mozjs.patch b/net-libs/libproxy/files/libproxy-0.2.3-fix-automagic-mozjs.patch
new file mode 100644
index 000000000000..779591487bd0
--- /dev/null
+++ b/net-libs/libproxy/files/libproxy-0.2.3-fix-automagic-mozjs.patch
@@ -0,0 +1,60 @@
+--- configure.ac.orig 2009-06-29 11:15:29.169464423 +0300
++++ configure.ac 2009-06-29 11:16:03.963593002 +0300
+@@ -17,9 +17,6 @@
+ PKG_CHECK_MODULES(xmu, xmu, have_xmu=yes, have_xmu=no)
+ PKG_CHECK_MODULES(gconf, gconf-2.0, have_gconf=yes, have_gconf=no)
+ PKG_CHECK_MODULES(webkit, webkit-1.0, have_webkit=yes, have_webkit=no)
+-PKG_CHECK_MODULES(mozjs, xulrunner-js, have_mozjs=yes,
+- [PKG_CHECK_MODULES(mozjs, firefox-js, have_mozjs=yes,
+- [PKG_CHECK_MODULES(mozjs, mozilla-js, have_mozjs=yes, have_mozjs=no)])])
+ PKG_CHECK_MODULES(NetworkManager, NetworkManager,
+ have_networkmanager=yes, have_networkmanager=no)
+ PKG_CHECK_MODULES(dbus, dbus-1, have_dbus=yes, have_dbus=no)
+@@ -111,24 +108,32 @@
+
+ # Mozilla Javascript
+ AC_ARG_WITH([mozjs],
+- [AS_HELP_STRING([--with-mozjs],
+- [build Mozilla JavaScript PAC runner plugin @<:@automatic@:>@])],
++ [AS_HELP_STRING([--with-mozjs@<:@=xulrunner|firefox|mozilla|seamonkey|no@:>@],
++ [build Mozilla JavaScript PAC runner plugin (autodetected by default)])],
+ [],
+- [test x$have_mozjs == xyes && with_mozjs=yes])
+-if test x$with_mozjs = xyes; then
+- if test x$have_mozjs == xyes; then
+- MOZJS_CFLAGS="$mozjs_CFLAGS"
+- MOZJS_LIBS="$mozjs_LIBS"
+- AC_SUBST(MOZJS_CFLAGS)
+- AC_SUBST(MOZJS_LIBS)
+- else
+- echo "Mozilla JavaScript plugin requires: mozjs!"
+- exit 1
+- fi
++ [with_mozjs=auto])
++
++if (test x$with_mozjs = xauto || test x$with_mozjs = xyes); then
++ PKG_CHECK_MODULES(mozjs, xulrunner-js, with_mozjs=xulrunner,
++ [PKG_CHECK_MODULES(mozjs, firefox-js, with_mozjs=firefox,
++ [PKG_CHECK_MODULES(mozjs, mozilla-js, with_mozjs=mozilla,
++ [PKG_CHECK_MODULES(mozjs, seamonkey-js, with_mozjs=seamonkey,
++ [test x$with_mozjs = xauto && with_mozjs = no || with_mozjs = error])])])])
++elif test x$with_mozjs != xno; then
++ PKG_CHECK_MODULES(mozjs, [$with_mozjs[]-js])
++fi
++
++if test x$with_mozjs = xerror; then
++ AC_MSG_ERROR([cannot find any mozjs provider])
+ else
+- with_mozjs=no
++ AC_MSG_RESULT([$with_mozjs])
++ MOZJS_CFLAGS="$mozjs_CFLAGS"
++ MOZJS_LIBS="$mozjs_LIBS"
++ AC_SUBST(MOZJS_CFLAGS)
++ AC_SUBST(MOZJS_LIBS)
+ fi
+-AM_CONDITIONAL([WITH_MOZJS], [test x$with_mozjs = xyes])
++
++AM_CONDITIONAL([WITH_MOZJS], [test x$with_mozjs != xno])
+
+ # NetworkManager
+ AC_ARG_WITH([networkmanager],
diff --git a/net-libs/libproxy/libproxy-0.2.3-r1.ebuild b/net-libs/libproxy/libproxy-0.2.3-r2.ebuild
index 579d0535e034..82fbea40dc7e 100644
--- a/net-libs/libproxy/libproxy-0.2.3-r1.ebuild
+++ b/net-libs/libproxy/libproxy-0.2.3-r2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.2.3-r1.ebuild,v 1.2 2009/06/24 15:43:08 nirbheek Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libproxy/libproxy-0.2.3-r2.ebuild,v 1.1 2009/06/29 19:26:13 leio Exp $
EAPI="2"
@@ -13,7 +13,7 @@ SRC_URI="http://${PN}.googlecode.com/files/${P}.tar.gz"
LICENSE="LGPL-2.1"
SLOT="0"
KEYWORDS="alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86 ~x86-fbsd"
-IUSE="gnome kde networkmanager python webkit xulrunner"
+IUSE="gnome kde networkmanager python seamonkey webkit xulrunner"
RDEPEND="
gnome? (
@@ -26,10 +26,11 @@ RDEPEND="
networkmanager? ( net-misc/networkmanager )
python? ( >=dev-lang/python-2.5 )
webkit? ( net-libs/webkit-gtk )
- xulrunner? (
- || ( >=net-libs/xulrunner-1.9
- www-client/seamonkey ) )
+ xulrunner? ( >=net-libs/xulrunner-1.9.0.11-r1:1.9 )
+ !xulrunner? ( seamonkey? ( www-client/seamonkey ) )
"
+# Since xulrunner-1.9.0.11-r1 its shipped mozilla-js.pc is fixed so we can use it
+
DEPEND="${RDEPEND}
>=dev-util/pkgconfig-0.19"
@@ -43,28 +44,38 @@ src_prepare() {
# http://code.google.com/p/libproxy/issues/detail?id=25
epatch "${FILESDIR}/${P}-fix-as-needed-problem.patch"
- # http://bugs.gentoo.org/show_bug.cgi?id=275127
- epatch "${FILESDIR}/${P}-fix-mozjs-cflags.patch"
+ # Bug 275127 and 275318
+ epatch "${FILESDIR}/${P}-fix-automagic-mozjs.patch"
# Fix implicit declaration QA, bug #268546
epatch "${FILESDIR}/${P}-implicit-declaration.patch"
epatch "${FILESDIR}/${P}-fbsd.patch" # drop at next bump
- # Fix test to follow POSIX (for x86-fbsd)
+ # Fix test to follow POSIX (for x86-fbsd).
+ # FIXME: This doesn't actually fix all == instances when two are on the same line
sed -e 's/\(test.*\)==/\1=/g' -i configure.ac configure || die "sed failed"
eautoreconf
}
src_configure() {
+ local myconf
+
+ # xulrunner:1.9 => mozilla; seamonkey => seamonkey;
+ # xulrunner:1.8 => xulrunner; (firefox => mozilla-firefox[-xulrunner] ?)
+ if use xulrunner; then myconf="--with-mozjs=mozilla"
+ elif use seamonkey; then myconf="--with-mozjs=seamonkey"
+ else myconf="--without-mozjs"
+ fi
+
econf --with-envvar \
--with-file \
--disable-static \
$(use_with gnome) \
$(use_with kde) \
$(use_with webkit) \
- $(use_with xulrunner mozjs) \
+ ${myconf} \
$(use_with networkmanager) \
$(use_with python)
}