summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPeter Volkov <pva@gentoo.org>2008-12-08 13:27:23 +0000
committerPeter Volkov <pva@gentoo.org>2008-12-08 13:27:23 +0000
commite909b69490a0228c4a60916a3ef46324503c2a47 (patch)
tree21b7da6c37df7d2d3ac805540a69fe431a5982b3 /net-libs/libpri
parentVersion bump for stable and beta branches, fixes security bug #249878 (thanks... (diff)
downloadgentoo-2-e909b69490a0228c4a60916a3ef46324503c2a47.tar.gz
gentoo-2-e909b69490a0228c4a60916a3ef46324503c2a47.tar.bz2
gentoo-2-e909b69490a0228c4a60916a3ef46324503c2a47.zip
Fixed gcc-4.3 build failure, bug #205468, thank Evil Compile Person for report and Chi-Thanh Christopher Nguyen for the fix. Small cleanup of ebuild to shut up repoman.
(Portage version: 2.2_rc17/cvs/Linux 2.6.26-openvz.git-89451f9 i686)
Diffstat (limited to 'net-libs/libpri')
-rw-r--r--net-libs/libpri/ChangeLog8
-rw-r--r--net-libs/libpri/files/libpri-1.2.5-gcc42.patch11
-rw-r--r--net-libs/libpri/libpri-1.2.5.ebuild19
3 files changed, 27 insertions, 11 deletions
diff --git a/net-libs/libpri/ChangeLog b/net-libs/libpri/ChangeLog
index 39536d2af0a3..74215598edca 100644
--- a/net-libs/libpri/ChangeLog
+++ b/net-libs/libpri/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libpri
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpri/ChangeLog,v 1.69 2008/08/16 15:56:55 tove Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpri/ChangeLog,v 1.70 2008/12/08 13:27:14 pva Exp $
+
+ 08 Dec 2008; Peter Volkov <pva@gentoo.org>
+ +files/libpri-1.2.5-gcc42.patch, libpri-1.2.5.ebuild:
+ Fixed gcc-4.3 build failure, bug #205468, thank Evil Compile Person for
+ report and Chi-Thanh Christopher Nguyen for the fix. Small cleanup of
+ ebuild to shut up repoman.
16 Aug 2008; Torsten Veller <tove@gentoo.org> metadata.xml:
Remove stkn from metadata.xml (#27693)
diff --git a/net-libs/libpri/files/libpri-1.2.5-gcc42.patch b/net-libs/libpri/files/libpri-1.2.5-gcc42.patch
new file mode 100644
index 000000000000..a7b9b0e8a3b9
--- /dev/null
+++ b/net-libs/libpri/files/libpri-1.2.5-gcc42.patch
@@ -0,0 +1,11 @@
+diff -u a/pri_internal.h b/pri_internal.h
+--- a/pri_internal.h 2005-11-29 19:39:18.000000000 +0100
++++ b/pri_internal.h 2008-01-18 16:12:05.200685051 +0100
+@@ -25,6 +25,7 @@
+ #ifndef _PRI_INTERNAL_H
+ #define _PRI_INTERNAL_H
+
++#include <stddef.h>
+ #include <sys/time.h>
+
+ struct pri_sched {
diff --git a/net-libs/libpri/libpri-1.2.5.ebuild b/net-libs/libpri/libpri-1.2.5.ebuild
index b857ae538c1f..c401f35e4cd3 100644
--- a/net-libs/libpri/libpri-1.2.5.ebuild
+++ b/net-libs/libpri/libpri-1.2.5.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpri/libpri-1.2.5.ebuild,v 1.4 2007/08/06 20:20:22 angelos Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpri/libpri-1.2.5.ebuild,v 1.5 2008/12/08 13:27:14 pva Exp $
inherit eutils
@@ -12,7 +12,7 @@ BRI_VERSION="0.3.0-PRE-1y-h"
DESCRIPTION="Primary Rate ISDN (PRI) library"
HOMEPAGE="http://www.asterisk.org/"
-SRC_URI="http://ftp.digium.com/pub/libpri/${MY_P}.tar.gz
+SRC_URI="http://ftp.digium.com/pub/libpri/releases/${MY_P}.tar.gz
bri? ( http://www.junghanns.net/downloads/bristuff-${BRI_VERSION}.tar.gz )"
# bri? ( http://www.netdomination.org/pub/asterisk/libpri-${PV}-bristuff-${BRI_VERSION}.diff.gz )"
@@ -24,14 +24,13 @@ SLOT="0"
LICENSE="GPL-2"
KEYWORDS="amd64 ~ppc sparc x86"
-DEPEND="virtual/libc"
-
src_unpack() {
unpack ${A}
- cd ${S}
- epatch ${FILESDIR}/${PN}-1.2.5-gentoo.diff
- epatch ${FILESDIR}/${P}-multilib.patch
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.2.5-gentoo.diff"
+ epatch "${FILESDIR}/${P}-multilib.patch"
+ epatch "${FILESDIR}/${P}-gcc42.patch"
if use bri; then
einfo "Patching libpri w/ BRI stuff (${BRI_VERSION})"
@@ -51,7 +50,7 @@ src_compile() {
}
src_install() {
- make INSTALL_PREFIX=${D} LIBDIR="${D}/usr/$(get_libdir)" install || die
+ make INSTALL_PREFIX="${D}" LIBDIR="${D}/usr/$(get_libdir)" install || die
- dodoc ChangeLog README TODO LICENSE
+ dodoc ChangeLog README TODO
}