summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTony Vroon <chainsaw@gentoo.org>2011-07-27 09:46:10 +0000
committerTony Vroon <chainsaw@gentoo.org>2011-07-27 09:46:10 +0000
commitb8c1ed181e7841a5811c194395a2c128d0191b14 (patch)
treec139217d647e9755727e689f34eef83c5fea2ff6 /net-libs/libpri
parentversion bump - bug #346835 (diff)
downloadgentoo-2-b8c1ed181e7841a5811c194395a2c128d0191b14.tar.gz
gentoo-2-b8c1ed181e7841a5811c194395a2c128d0191b14.tar.bz2
gentoo-2-b8c1ed181e7841a5811c194395a2c128d0191b14.zip
Consolidate flag respect patching and take care to remove spurious -g. As per arch test report by Agostino "ago" Sarubbo in bug #376573.
(Portage version: 2.1.10.7/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libpri')
-rw-r--r--net-libs/libpri/ChangeLog9
-rw-r--r--net-libs/libpri/files/libpri-1.4.12-respect-user-flags.patch47
-rw-r--r--net-libs/libpri/libpri-1.4.12-r1.ebuild31
3 files changed, 86 insertions, 1 deletions
diff --git a/net-libs/libpri/ChangeLog b/net-libs/libpri/ChangeLog
index c86e5f9f9a46..28c6ee398575 100644
--- a/net-libs/libpri/ChangeLog
+++ b/net-libs/libpri/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for net-libs/libpri
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpri/ChangeLog,v 1.91 2011/07/27 09:04:41 xarthisius Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpri/ChangeLog,v 1.92 2011/07/27 09:46:10 chainsaw Exp $
+
+*libpri-1.4.12-r1 (27 Jul 2011)
+
+ 27 Jul 2011; Tony Vroon <chainsaw@gentoo.org> +libpri-1.4.12-r1.ebuild,
+ +files/libpri-1.4.12-respect-user-flags.patch:
+ Consolidate flag respect patching and take care to remove spurious -g. As per
+ arch test report by Agostino "ago" Sarubbo in bug #376573.
27 Jul 2011; Kacper Kowalik <xarthisius@gentoo.org> libpri-1.4.11.4.ebuild,
libpri-1.4.11.5.ebuild, libpri-1.4.12_beta2.ebuild,
diff --git a/net-libs/libpri/files/libpri-1.4.12-respect-user-flags.patch b/net-libs/libpri/files/libpri-1.4.12-respect-user-flags.patch
new file mode 100644
index 000000000000..dd5b28587db9
--- /dev/null
+++ b/net-libs/libpri/files/libpri-1.4.12-respect-user-flags.patch
@@ -0,0 +1,47 @@
+diff -uNr libpri-1.4.12.ORIG//Makefile libpri-1.4.12/Makefile
+--- libpri-1.4.12.ORIG//Makefile 2011-07-27 10:37:34.247793740 +0100
++++ libpri-1.4.12/Makefile 2011-07-27 10:38:54.183790788 +0100
+@@ -90,7 +90,7 @@
+ rose_qsig_mwi.lo \
+ rose_qsig_name.lo \
+ version.lo
+-CFLAGS=-Wall -Werror -Wstrict-prototypes -Wmissing-prototypes -g -fPIC $(ALERTING) $(LIBPRI_OPT) $(COVERAGE_CFLAGS)
++CFLAGS+=-Wall -Wstrict-prototypes -Wmissing-prototypes -fPIC $(ALERTING) $(LIBPRI_OPT) $(COVERAGE_CFLAGS)
+ INSTALL_PREFIX=$(DESTDIR)
+ INSTALL_BASE=/usr
+ LIBDIR=$(INSTALL_PREFIX)$(INSTALL_BASE)/lib
+@@ -124,20 +124,12 @@
+
+ PRIVERSION:=$(shell GREP=$(GREP) AWK=$(AWK) build_tools/make_version .)
+
+-#The problem with sparc is the best stuff is in newer versions of gcc (post 3.0) only.
+-#This works for even old (2.96) versions of gcc and provides a small boost either way.
+-#A ultrasparc cpu is really v9 but the stock debian stable 3.0 gcc doesnt support it.
+-ifeq ($(PROC),sparc64)
+-PROC=ultrasparc
+-LIBPRI_OPT = -mtune=$(PROC) -O3 -pipe -fomit-frame-pointer -mcpu=v8
++ifneq ($(CODE_COVERAGE),)
++ LIBPRI_OPT=
++ COVERAGE_CFLAGS=-ftest-coverage -fprofile-arcs
++ COVERAGE_LDFLAGS=-ftest-coverage -fprofile-arcs
+ else
+- ifneq ($(CODE_COVERAGE),)
+- LIBPRI_OPT=
+- COVERAGE_CFLAGS=-ftest-coverage -fprofile-arcs
+- COVERAGE_LDFLAGS=-ftest-coverage -fprofile-arcs
+- else
+- LIBPRI_OPT=-O2
+- endif
++ LIBPRI_OPT=
+ endif
+
+ ifeq ($(CPUARCH),i686)
+@@ -216,7 +208,7 @@
+ ranlib $(STATIC_LIBRARY)
+
+ $(DYNAMIC_LIBRARY): $(DYNAMIC_OBJS)
+- $(CC) $(SOFLAGS) -o $@ $(DYNAMIC_OBJS)
++ $(CC) $(SOFLAGS) $(LDFLAGS) -o $@ $(DYNAMIC_OBJS)
+ $(LDCONFIG) $(LDCONFIG_FLAGS) .
+ ln -sf libpri.so.$(SONAME) libpri.so
+
diff --git a/net-libs/libpri/libpri-1.4.12-r1.ebuild b/net-libs/libpri/libpri-1.4.12-r1.ebuild
new file mode 100644
index 000000000000..858853a8ebc5
--- /dev/null
+++ b/net-libs/libpri/libpri-1.4.12-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpri/libpri-1.4.12-r1.ebuild,v 1.1 2011/07/27 09:46:10 chainsaw Exp $
+
+EAPI="3"
+
+inherit base
+
+MY_P="${P/_/-}"
+S="${WORKDIR}/${MY_P}"
+
+DESCRIPTION="Primary Rate ISDN (PRI) library"
+HOMEPAGE="http://www.asterisk.org/"
+SRC_URI="http://downloads.asterisk.org/pub/telephony/${PN}/releases/${MY_P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~sparc ~x86"
+IUSE=""
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.4.12-multilib.patch"
+ "${FILESDIR}/${PN}-1.4.12-respect-user-flags.patch"
+)
+
+src_install() {
+ emake INSTALL_PREFIX="${D}" LIBDIR="${D}/usr/$(get_libdir)" install \
+ || die "emake install failed"
+
+ dodoc ChangeLog README TODO || die "dodoc failed"
+}