summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2011-11-22 19:02:26 +0000
committerJeroen Roovers <jer@gentoo.org>2011-11-22 19:02:26 +0000
commita82b3e7ee0bcf2f2c4c94ce64f189fe625d31b92 (patch)
tree0c9197be7582d673510e65f75992f3e7cd66fd1e /net-libs/libpcap/libpcap-1.1.1-r1.ebuild
parentQA: fix handling of LDFLAGS. (diff)
downloadgentoo-2-a82b3e7ee0bcf2f2c4c94ce64f189fe625d31b92.tar.gz
gentoo-2-a82b3e7ee0bcf2f2c4c94ce64f189fe625d31b92.tar.bz2
gentoo-2-a82b3e7ee0bcf2f2c4c94ce64f189fe625d31b92.zip
Add IUSE=static-libs thanks to Piotr Karbowski (bug #391375).
(Portage version: 2.2.0_alpha77/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libpcap/libpcap-1.1.1-r1.ebuild')
-rw-r--r--net-libs/libpcap/libpcap-1.1.1-r1.ebuild8
1 files changed, 5 insertions, 3 deletions
diff --git a/net-libs/libpcap/libpcap-1.1.1-r1.ebuild b/net-libs/libpcap/libpcap-1.1.1-r1.ebuild
index 35146a25a351..5c90f2cf484e 100644
--- a/net-libs/libpcap/libpcap-1.1.1-r1.ebuild
+++ b/net-libs/libpcap/libpcap-1.1.1-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.1.1-r1.ebuild,v 1.5 2011/09/10 08:26:04 scarabeus Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libpcap/libpcap-1.1.1-r1.ebuild,v 1.6 2011/11/22 19:02:26 jer Exp $
EAPI=4
inherit autotools eutils multilib toolchain-funcs
@@ -13,7 +13,7 @@ SRC_URI="http://www.tcpdump.org/release/${P}.tar.gz
LICENSE="BSD"
SLOT="0"
KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
-IUSE="bluetooth ipv6 libnl"
+IUSE="bluetooth ipv6 libnl static-libs"
RDEPEND="bluetooth? ( net-wireless/bluez )
libnl? ( dev-libs/libnl )"
@@ -47,7 +47,9 @@ src_install() {
default
# remove static libraries (--disable-static does not work)
- find "${ED}" -name '*.a' -exec rm -f {} +
+ if ! use static-libs; then
+ find "${ED}" -name '*.a' -exec rm {} + || die
+ fi
# We need this to build pppd on G/FBSD systems
if [[ "${USERLAND}" == "BSD" ]]; then