summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2011-09-02 18:34:41 +0000
committerMike Frysinger <vapier@gentoo.org>2011-09-02 18:34:41 +0000
commitf4b90a3913240bf7e43ab99a75b0819ffcec1a7d (patch)
tree26a7b9e8bfa90de0b90f7b7a30777e0eb4a1979c /net-libs/libnfsidmap
parentMarked ~x64-macos, bug #358985 (diff)
downloadgentoo-2-f4b90a3913240bf7e43ab99a75b0819ffcec1a7d.tar.gz
gentoo-2-f4b90a3913240bf7e43ab99a75b0819ffcec1a7d.tar.bz2
gentoo-2-f4b90a3913240bf7e43ab99a75b0819ffcec1a7d.zip
Version bump and USE=static-libs support.
(Portage version: 2.2.0_alpha51/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libnfsidmap')
-rw-r--r--net-libs/libnfsidmap/ChangeLog9
-rw-r--r--net-libs/libnfsidmap/libnfsidmap-0.24.ebuild46
2 files changed, 53 insertions, 2 deletions
diff --git a/net-libs/libnfsidmap/ChangeLog b/net-libs/libnfsidmap/ChangeLog
index c92b7e0cd374..82445405d15b 100644
--- a/net-libs/libnfsidmap/ChangeLog
+++ b/net-libs/libnfsidmap/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libnfsidmap
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfsidmap/ChangeLog,v 1.34 2010/09/14 12:32:22 vapier Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfsidmap/ChangeLog,v 1.35 2011/09/02 18:34:41 vapier Exp $
+
+*libnfsidmap-0.24 (02 Sep 2011)
+
+ 02 Sep 2011; Mike Frysinger <vapier@gentoo.org> +libnfsidmap-0.24.ebuild:
+ Version bump and USE=static-libs support.
*libnfsidmap-0.23-r1 (14 Sep 2010)
diff --git a/net-libs/libnfsidmap/libnfsidmap-0.24.ebuild b/net-libs/libnfsidmap/libnfsidmap-0.24.ebuild
new file mode 100644
index 000000000000..a0ae2e364092
--- /dev/null
+++ b/net-libs/libnfsidmap/libnfsidmap-0.24.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfsidmap/libnfsidmap-0.24.ebuild,v 1.1 2011/09/02 18:34:41 vapier Exp $
+
+EAPI="2"
+
+inherit autotools
+
+DESCRIPTION="NFSv4 ID <-> name mapping library"
+HOMEPAGE="http://www.citi.umich.edu/projects/nfsv4/linux/"
+SRC_URI="http://www.citi.umich.edu/projects/nfsv4/linux/libnfsidmap/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE="ldap static-libs"
+
+DEPEND="ldap? ( net-nds/openldap )"
+RDEPEND="${DEPEND}
+ !<net-fs/nfs-utils-1.2.2
+ !net-fs/idmapd"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-0.19-getgrouplist.patch #169909
+ epatch "${FILESDIR}"/${PN}-0.21-headers.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --disable-dependency-tracking \
+ $(use_enable static-libs static) \
+ $(use_enable ldap)
+}
+
+src_install() {
+ emake install DESTDIR="${D}" || die
+ dodoc AUTHORS ChangeLog NEWS README
+
+ insinto /etc
+ doins idmapd.conf || die
+
+ # remove useless files
+ rm -f "${D}"/usr/lib*/libnfsidmap/*.{a,la}
+ use static-libs || rm -f "${D}"/usr/lib*/*.la
+}