summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2013-02-08 06:44:16 +0000
committerMike Frysinger <vapier@gentoo.org>2013-02-08 06:44:16 +0000
commit0431897d8d16ea7f63bc671c38ae826ae13db846 (patch)
tree161dbee4c240d2045ff018732df4e1875b29f099 /net-libs/libnfnetlink
parentChange from die to ewarn as the former can trigger in many wrong instances, a... (diff)
downloadgentoo-2-0431897d8d16ea7f63bc671c38ae826ae13db846.tar.gz
gentoo-2-0431897d8d16ea7f63bc671c38ae826ae13db846.tar.bz2
gentoo-2-0431897d8d16ea7f63bc671c38ae826ae13db846.zip
Change from die to ewarn as the former can trigger in many wrong instances, and <2.6.14 is not a scenario we need to really care about anymore.
(Portage version: 2.2.0_alpha161/cvs/Linux x86_64, signed Manifest commit with key FB7C4156)
Diffstat (limited to 'net-libs/libnfnetlink')
-rw-r--r--net-libs/libnfnetlink/ChangeLog9
-rw-r--r--net-libs/libnfnetlink/libnfnetlink-1.0.0-r1.ebuild10
-rw-r--r--net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild6
3 files changed, 14 insertions, 11 deletions
diff --git a/net-libs/libnfnetlink/ChangeLog b/net-libs/libnfnetlink/ChangeLog
index 9bd40b15a78f..14f631182ea7 100644
--- a/net-libs/libnfnetlink/ChangeLog
+++ b/net-libs/libnfnetlink/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libnfnetlink
-# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/ChangeLog,v 1.58 2012/12/16 19:43:05 armin76 Exp $
+# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/ChangeLog,v 1.59 2013/02/08 06:44:16 vapier Exp $
+
+ 08 Feb 2013; Mike Frysinger <vapier@gentoo.org> libnfnetlink-1.0.0-r1.ebuild,
+ libnfnetlink-1.0.1.ebuild:
+ Change from die to ewarn as the former can trigger in many wrong instances,
+ and <2.6.14 is not a scenario we need to really care about anymore.
16 Dec 2012; Raúl Porcel <armin76@gentoo.org> libnfnetlink-1.0.1.ebuild:
alpha/ia64/m68k/s390/sh/sparc stable wrt #442872
diff --git a/net-libs/libnfnetlink/libnfnetlink-1.0.0-r1.ebuild b/net-libs/libnfnetlink/libnfnetlink-1.0.0-r1.ebuild
index 0072a5c6bb12..f70b4a1039e9 100644
--- a/net-libs/libnfnetlink/libnfnetlink-1.0.0-r1.ebuild
+++ b/net-libs/libnfnetlink/libnfnetlink-1.0.0-r1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/libnfnetlink-1.0.0-r1.ebuild,v 1.7 2012/09/02 18:51:43 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/libnfnetlink-1.0.0-r1.ebuild,v 1.8 2013/02/08 06:44:16 vapier Exp $
EAPI=4
inherit linux-info
@@ -20,7 +20,7 @@ pkg_setup() {
linux-info_pkg_setup
if kernel_is lt 2 6 18 ; then
- die "${PN} requires at least 2.6.18 kernel version"
+ ewarn "${PN} requires at least 2.6.18 kernel version"
fi
#netfilter core team has changed some option names with kernel 2.6.20
@@ -42,7 +42,5 @@ src_configure() {
src_install() {
default
- if ! use static-libs; then
- rm -f "${D}"/usr/lib*/*.la || die
- fi
+ use static-libs || find "${ED}"/usr -name '*.la' -delete
}
diff --git a/net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild b/net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild
index af7d7eb473ae..b20ded22acdf 100644
--- a/net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild
+++ b/net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2012 Gentoo Foundation
+# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild,v 1.7 2012/12/16 19:43:05 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnfnetlink/libnfnetlink-1.0.1.ebuild,v 1.8 2013/02/08 06:44:16 vapier Exp $
EAPI=4
inherit linux-info eutils
@@ -20,7 +20,7 @@ pkg_setup() {
linux-info_pkg_setup
if kernel_is lt 2 6 18 ; then
- die "${PN} requires at least 2.6.18 kernel version"
+ ewarn "${PN} requires at least 2.6.18 kernel version"
fi
#netfilter core team has changed some option names with kernel 2.6.20