summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2013-03-27 20:28:17 +0000
committerJeroen Roovers <jer@gentoo.org>2013-03-27 20:28:17 +0000
commitf5c83e2eecae7964b7cb825a86caab9407eb38e4 (patch)
tree22351473c4018e37a8698bc753ad0c3455148e1c /net-libs/libnet
parentRemove old (diff)
downloadgentoo-2-f5c83e2eecae7964b7cb825a86caab9407eb38e4.tar.gz
gentoo-2-f5c83e2eecae7964b7cb825a86caab9407eb38e4.tar.bz2
gentoo-2-f5c83e2eecae7964b7cb825a86caab9407eb38e4.zip
Fix LIBNET_VERSION string (bug #463528).
(Portage version: 2.2.0_alpha169/cvs/Linux x86_64, signed Manifest commit with key A792A613)
Diffstat (limited to 'net-libs/libnet')
-rw-r--r--net-libs/libnet/ChangeLog8
-rw-r--r--net-libs/libnet/files/libnet-1.2-rc.patch11
-rw-r--r--net-libs/libnet/libnet-1.2_rc1-r1.ebuild (renamed from net-libs/libnet/libnet-1.2_rc1.ebuild)8
3 files changed, 24 insertions, 3 deletions
diff --git a/net-libs/libnet/ChangeLog b/net-libs/libnet/ChangeLog
index 849879e758b1..2207ce06ec43 100644
--- a/net-libs/libnet/ChangeLog
+++ b/net-libs/libnet/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libnet
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/ChangeLog,v 1.100 2013/03/15 17:58:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/ChangeLog,v 1.101 2013/03/27 20:28:17 jer Exp $
+
+*libnet-1.2_rc1-r1 (27 Mar 2013)
+
+ 27 Mar 2013; Jeroen Roovers <jer@gentoo.org> -libnet-1.2_rc1.ebuild,
+ +libnet-1.2_rc1-r1.ebuild, +files/libnet-1.2-rc.patch:
+ Fix LIBNET_VERSION string (bug #463528).
*libnet-1.2_rc1 (15 Mar 2013)
diff --git a/net-libs/libnet/files/libnet-1.2-rc.patch b/net-libs/libnet/files/libnet-1.2-rc.patch
new file mode 100644
index 000000000000..c6babe06c758
--- /dev/null
+++ b/net-libs/libnet/files/libnet-1.2-rc.patch
@@ -0,0 +1,11 @@
+--- a/configure.ac
++++ b/configure.ac
+@@ -4,7 +4,7 @@
+ dnl
+ dnl Process this file with autoconf to produce a configure script.
+
+-AC_INIT([libnet],[1.2-rc1])
++AC_INIT([libnet],[1.2])
+ AC_MSG_RESULT(beginning autoconfiguration process for libnet-${PACKAGE_VERSION} ...)
+ AC_CANONICAL_TARGET
+ AC_CONFIG_SRCDIR([src/libnet_build_ip.c])
diff --git a/net-libs/libnet/libnet-1.2_rc1.ebuild b/net-libs/libnet/libnet-1.2_rc1-r1.ebuild
index a22bb8b2c631..de1fbf7aadb3 100644
--- a/net-libs/libnet/libnet-1.2_rc1.ebuild
+++ b/net-libs/libnet/libnet-1.2_rc1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/libnet-1.2_rc1.ebuild,v 1.1 2013/03/15 17:58:17 jer Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/libnet-1.2_rc1-r1.ebuild,v 1.1 2013/03/27 20:28:17 jer Exp $
EAPI=5
-inherit eutils
+inherit autotools eutils
DESCRIPTION="library to provide an API for commonly used low-level network functions (mainly packet injection)"
HOMEPAGE="http://libnet-dev.sourceforge.net/"
@@ -24,6 +24,10 @@ DOCS=(
S=${WORKDIR}/${P/_/-}
+src_prepare() {
+ epatch "${FILESDIR}"/${PN}-1.2-rc.patch
+ eautoreconf
+}
src_configure() {
econf $(use_enable static-libs static)
}