summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2009-05-25 23:41:56 +0000
committerJeroen Roovers <jer@gentoo.org>2009-05-25 23:41:56 +0000
commitc766509d12379c841a354ea383dda46e27ec4447 (patch)
treef894b91a21c4ae4fc855c06be66c897f5bfb1df9 /net-libs/libnet
parentFixed dependency, bug #271098. (diff)
downloadgentoo-2-c766509d12379c841a354ea383dda46e27ec4447.tar.gz
gentoo-2-c766509d12379c841a354ea383dda46e27ec4447.tar.bz2
gentoo-2-c766509d12379c841a354ea383dda46e27ec4447.zip
Do not call autoconf directly in 1.0.2a-r2, but call eautoconf (bug #226599). Apply cq_end_loop patch to new 1.1.2.1 revision to build net-analyzer/dhcp_probe against.
(Portage version: 2.2_rc33/cvs/Linux i686)
Diffstat (limited to 'net-libs/libnet')
-rw-r--r--net-libs/libnet/ChangeLog12
-rw-r--r--net-libs/libnet/files/libnet-1.1.2.1-cq_end_loop.patch32
-rw-r--r--net-libs/libnet/libnet-1.0.2a-r3.ebuild8
-rw-r--r--net-libs/libnet/libnet-1.1.2.1-r2.ebuild42
4 files changed, 88 insertions, 6 deletions
diff --git a/net-libs/libnet/ChangeLog b/net-libs/libnet/ChangeLog
index e4c7ca409c0b..50b543cb3af6 100644
--- a/net-libs/libnet/ChangeLog
+++ b/net-libs/libnet/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for net-libs/libnet
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/ChangeLog,v 1.44 2007/05/08 22:53:37 genone Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/ChangeLog,v 1.45 2009/05/25 23:41:56 jer Exp $
+
+*libnet-1.1.2.1-r2 (25 May 2009)
+
+ 25 May 2009; Jeroen Roovers <jer@gentoo.org> libnet-1.0.2a-r3.ebuild,
+ +libnet-1.1.2.1-r2.ebuild, +files/libnet-1.1.2.1-cq_end_loop.patch:
+ Do not call autoconf directly in 1.0.2a-r2, but call eautoconf (bug
+ #226599). Apply cq_end_loop patch to new 1.1.2.1 revision to build
+ net-analyzer/dhcp_probe against.
08 May 2007; Marius Mauch <genone@gentoo.org> libnet-1.0.2a-r3.ebuild:
Replacing einfo with elog
diff --git a/net-libs/libnet/files/libnet-1.1.2.1-cq_end_loop.patch b/net-libs/libnet/files/libnet-1.1.2.1-cq_end_loop.patch
new file mode 100644
index 000000000000..6da82c0b83a6
--- /dev/null
+++ b/net-libs/libnet/files/libnet-1.1.2.1-cq_end_loop.patch
@@ -0,0 +1,32 @@
+Patch needed for net-analyzer/dhcp_probe -JeR (see [1])
+
+[1] http://www.net.princeton.edu/software/dhcp_probe/INSTALL.dhcp_probe.txt
+
+--- libnet/src/libnet_cq.c.orig 2004-01-28 20:45:00.000000000 +0100
++++ libnet/src/libnet_cq.c 2008-10-27 22:51:10.000000000 +0100
+@@ -393,3 +393,15 @@
+ {
+ return (l_cqd.node);
+ }
++
++u_int32_t
++libnet_cq_end_loop()
++{
++
++ if (! clear_cq_lock(CQ_LOCK_WRITE))
++ {
++ return (0);
++ }
++ l_cqd.current = l_cq;
++ return (1);
++}
+--- libnet/include/libnet/libnet-functions.h.orig 2004-03-25 19:50:48.000000000 +0100
++++ libnet/include/libnet/libnet-functions.h 2008-10-27 22:52:14.000000000 +0100
+@@ -2148,4 +2148,7 @@
+ #endif
+ #endif /* __LIBNET_FUNCTIONS_H */
+
++u_int32_t
++libnet_cq_end_loop();
++
+ /* EOF */
diff --git a/net-libs/libnet/libnet-1.0.2a-r3.ebuild b/net-libs/libnet/libnet-1.0.2a-r3.ebuild
index 89ba81d1623e..3c4a43486d20 100644
--- a/net-libs/libnet/libnet-1.0.2a-r3.ebuild
+++ b/net-libs/libnet/libnet-1.0.2a-r3.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/libnet-1.0.2a-r3.ebuild,v 1.17 2007/05/08 22:53:37 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/libnet-1.0.2a-r3.ebuild,v 1.18 2009/05/25 23:41:56 jer Exp $
-inherit eutils
+inherit eutils autotools
DESCRIPTION="library to provide an API for commonly used low-level network functions (mainly packet injection)"
HOMEPAGE="http://www.packetfactory.net/libnet/"
@@ -30,7 +30,7 @@ src_unpack() {
cd "${S}"/doc
ln -s libnet.3 libnet-${SLOT}.3 || die "linking manpage"
cd "${S}"
- autoconf || die
+ eautoconf || die
}
src_compile() {
diff --git a/net-libs/libnet/libnet-1.1.2.1-r2.ebuild b/net-libs/libnet/libnet-1.1.2.1-r2.ebuild
new file mode 100644
index 000000000000..c65c4af693b3
--- /dev/null
+++ b/net-libs/libnet/libnet-1.1.2.1-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnet/libnet-1.1.2.1-r2.ebuild,v 1.1 2009/05/25 23:41:56 jer Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+inherit eutils autotools
+
+DESCRIPTION="library to provide an API for commonly used low-level network functions (mainly packet injection)"
+HOMEPAGE="http://www.packetfactory.net/libnet/"
+SRC_URI="http://www.packetfactory.net/libnet/dist/${P}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="1.1"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DEPEND="sys-devel/autoconf"
+RDEPEND=""
+
+S=${WORKDIR}/libnet
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${P}-fix-chksum.patch
+ epatch "${FILESDIR}"/${P}-cq_end_loop.patch
+ epatch "${FILESDIR}"/${P}-autotools.patch
+ eautoreconf
+}
+
+src_install(){
+ emake DESTDIR="${D}" install || die "Failed to install"
+
+ doman doc/man/man3/*.3
+ dodoc VERSION README doc/*
+ if use doc ; then
+ dohtml -r doc/html/*
+ docinto sample
+ dodoc sample/*.[ch]
+ fi
+}