summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-09-13 11:06:31 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-09-13 11:06:31 +0000
commit9ad7ea139135c9ff59ffbbc4f770db1397e1ab2a (patch)
tree39c1e83753215e02c72ed0cb63c022ed3e11eaa8 /net-libs/libnatpmp
parentVersion bump. (diff)
downloadgentoo-2-9ad7ea139135c9ff59ffbbc4f770db1397e1ab2a.tar.gz
gentoo-2-9ad7ea139135c9ff59ffbbc4f770db1397e1ab2a.tar.bz2
gentoo-2-9ad7ea139135c9ff59ffbbc4f770db1397e1ab2a.zip
Fix USE=-static-libs, bug #484692
(Portage version: 2.2.1/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-libs/libnatpmp')
-rw-r--r--net-libs/libnatpmp/ChangeLog4
-rw-r--r--net-libs/libnatpmp/files/remove-static-lib-20130911.patch74
-rw-r--r--net-libs/libnatpmp/libnatpmp-20130911.ebuild4
3 files changed, 80 insertions, 2 deletions
diff --git a/net-libs/libnatpmp/ChangeLog b/net-libs/libnatpmp/ChangeLog
index c942566c41ce..4d453488e73a 100644
--- a/net-libs/libnatpmp/ChangeLog
+++ b/net-libs/libnatpmp/ChangeLog
@@ -1,4 +1,8 @@
+ 13 Sep 2013; Anthony G. Basile <blueness@gentoo.org>
+ +files/remove-static-lib-20130911.patch, libnatpmp-20130911.ebuild:
+ Fix USE=-static-libs, bug #484692
+
*libnatpmp-20130911 (12 Sep 2013)
12 Sep 2013; Anthony G. Basile <blueness@gentoo.org>
diff --git a/net-libs/libnatpmp/files/remove-static-lib-20130911.patch b/net-libs/libnatpmp/files/remove-static-lib-20130911.patch
new file mode 100644
index 000000000000..a2c1f516c363
--- /dev/null
+++ b/net-libs/libnatpmp/files/remove-static-lib-20130911.patch
@@ -0,0 +1,74 @@
+diff -Naur libnatpmp-20130911.orig/Makefile libnatpmp-20130911/Makefile
+--- libnatpmp-20130911.orig/Makefile 2013-09-13 07:00:55.874343916 -0400
++++ libnatpmp-20130911/Makefile 2013-09-13 07:03:33.733351101 -0400
+@@ -35,7 +35,6 @@
+
+ OBJS = $(LIBOBJS) testgetgateway.o natpmpc.o natpmp-jni.o
+
+-STATICLIB = libnatpmp.a
+ ifeq ($(OS), Darwin)
+ SHAREDLIB = libnatpmp.dylib
+ JNISHAREDLIB = libjninatpmp.dylib
+@@ -58,7 +57,7 @@
+
+ HEADERS = natpmp.h
+
+-EXECUTABLES = testgetgateway natpmpc-shared natpmpc-static
++EXECUTABLES = testgetgateway natpmpc-shared
+
+ INSTALLPREFIX ?= $(PREFIX)/usr
+ INSTALLDIRINC = $(INSTALLPREFIX)/include
+@@ -72,9 +71,9 @@
+
+ .PHONY: all clean depend install cleaninstall installpythonmodule
+
+-all: $(STATICLIB) $(SHAREDLIB) $(EXECUTABLES)
++all: $(SHAREDLIB) $(EXECUTABLES)
+
+-pythonmodule: $(STATICLIB) libnatpmpmodule.c setup.py
++pythonmodule: libnatpmpmodule.c setup.py
+ python setup.py build
+ touch $@
+
+@@ -82,18 +81,17 @@
+ python setup.py install
+
+ clean:
+- $(RM) $(OBJS) $(EXECUTABLES) $(STATICLIB) $(SHAREDLIB) $(JAVACLASSES) $(JNISHAREDLIB)
++ $(RM) $(OBJS) $(EXECUTABLES) $(SHAREDLIB) $(JAVACLASSES) $(JNISHAREDLIB)
+ $(RM) pythonmodule
+ $(RM) -r build/ dist/ libraries/
+
+ depend:
+ makedepend -f$(MAKEFILE_LIST) -Y $(OBJS:.o=.c) 2>/dev/null
+
+-install: $(HEADERS) $(STATICLIB) $(SHAREDLIB) natpmpc-shared
++install: $(HEADERS) $(SHAREDLIB) natpmpc-shared
+ $(INSTALL) -d $(INSTALLDIRINC)
+ $(INSTALL) -m 644 $(HEADERS) $(INSTALLDIRINC)
+ $(INSTALL) -d $(INSTALLDIRLIB)
+- $(INSTALL) -m 644 $(STATICLIB) $(INSTALLDIRLIB)
+ $(INSTALL) -m 644 $(SHAREDLIB) $(INSTALLDIRLIB)/$(SONAME)
+ $(INSTALL) -d $(INSTALLDIRBIN)
+ $(INSTALL) -m 755 natpmpc-shared $(INSTALLDIRBIN)/natpmpc
+@@ -142,20 +140,13 @@
+ $(RM) $(addprefix $(INSTALLDIRINC), $(HEADERS))
+ $(RM) $(INSTALLDIRLIB)/$(SONAME)
+ $(RM) $(INSTALLDIRLIB)/$(SHAREDLIB)
+- $(RM) $(INSTALLDIRLIB)/$(STATICLIB)
+
+ testgetgateway: testgetgateway.o getgateway.o
+ $(CC) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+-natpmpc-static: natpmpc.o $(STATICLIB)
+- $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+-
+ natpmpc-shared: natpmpc.o $(SHAREDLIB)
+ $(CC) $(CFLAGS) $(LDFLAGS) -o $@ $^ $(EXTRA_LD)
+
+-$(STATICLIB): $(LIBOBJS)
+- $(AR) crs $@ $?
+-
+ $(SHAREDLIB): $(LIBOBJS)
+ ifeq ($(OS), Darwin)
+ $(CC) $(CFLAGS) $(LDFLAGS) -dynamiclib -Wl,-install_name,$(SONAME) -o $@ $^
diff --git a/net-libs/libnatpmp/libnatpmp-20130911.ebuild b/net-libs/libnatpmp/libnatpmp-20130911.ebuild
index 0d5e89356db0..e8cef218d69f 100644
--- a/net-libs/libnatpmp/libnatpmp-20130911.ebuild
+++ b/net-libs/libnatpmp/libnatpmp-20130911.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libnatpmp/libnatpmp-20130911.ebuild,v 1.1 2013/09/12 17:23:56 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libnatpmp/libnatpmp-20130911.ebuild,v 1.2 2013/09/13 11:06:31 blueness Exp $
EAPI="5"
inherit eutils toolchain-funcs multilib
@@ -17,7 +17,7 @@ IUSE="static-libs"
src_prepare() {
epatch "${FILESDIR}"/respect-FLAGS-${PV}.patch
epatch "${FILESDIR}"/respect-libdir-20120821.patch
- use static-libs || epatch "${FILESDIR}"/remove-static-lib-20120821.patch
+ use static-libs || epatch "${FILESDIR}"/remove-static-lib-${PV}.patch
tc-export CC
}