summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2012-12-26 13:23:47 +0000
committerAnthony G. Basile <blueness@gentoo.org>2012-12-26 13:23:47 +0000
commitd3576822401b3c647697e94b2d40cd31a557668d (patch)
tree6a3b920ff0882e0a2ab1ef6efc9bdd8f987fc7a4 /net-libs/libmicrohttpd
parentVersion bump, punt older unstable (diff)
downloadgentoo-2-d3576822401b3c647697e94b2d40cd31a557668d.tar.gz
gentoo-2-d3576822401b3c647697e94b2d40cd31a557668d.tar.bz2
gentoo-2-d3576822401b3c647697e94b2d40cd31a557668d.zip
Version bump
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-libs/libmicrohttpd')
-rw-r--r--net-libs/libmicrohttpd/ChangeLog8
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.24.ebuild48
2 files changed, 55 insertions, 1 deletions
diff --git a/net-libs/libmicrohttpd/ChangeLog b/net-libs/libmicrohttpd/ChangeLog
index 25b3a0e99d62..f85d8ea69119 100644
--- a/net-libs/libmicrohttpd/ChangeLog
+++ b/net-libs/libmicrohttpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libmicrohttpd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.23 2012/11/11 02:42:04 blueness Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.24 2012/12/26 13:23:47 blueness Exp $
+
+*libmicrohttpd-0.9.24 (26 Dec 2012)
+
+ 26 Dec 2012; Anthony G. Basile <blueness@gentoo.org>
+ +libmicrohttpd-0.9.24.ebuild:
+ Version bump
11 Nov 2012; Anthony G. Basile <blueness@gentoo.org>
libmicrohttpd-0.9.23.ebuild:
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.24.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.24.ebuild
new file mode 100644
index 000000000000..b041767f08b9
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.24.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/libmicrohttpd-0.9.24.ebuild,v 1.1 2012/12/26 13:23:47 blueness Exp $
+
+EAPI="4"
+
+MY_P="${P/_/}"
+
+DESCRIPTION="A small C library that makes it easy to run an HTTP server as part of another application."
+HOMEPAGE="http://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+IUSE="messages ssl static-libs test"
+KEYWORDS="~amd64 ~arm ~mips ~ppc ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt
+ net-libs/gnutls
+ )"
+
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( >=net-misc/curl-7.25.0-r1[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+src_configure() {
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ $(use_enable test curl) \
+ $(use_enable messages) \
+ $(use_enable messages postprocessor) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+}