summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTomas Chvatal <scarabeus@gentoo.org>2012-05-14 11:12:54 +0000
committerTomas Chvatal <scarabeus@gentoo.org>2012-05-14 11:12:54 +0000
commit4e3fd28c00036f9139af6440d9dd32b2c90fbcd0 (patch)
tree210cadec1d7fb1e54c10df327ab30f8de5a6daff /net-libs/libmicrohttpd
parentnet-im/gajim: Update SA48695 patch with changesets f6f78f3802c07736cb63b3e696... (diff)
downloadgentoo-2-4e3fd28c00036f9139af6440d9dd32b2c90fbcd0.tar.gz
gentoo-2-4e3fd28c00036f9139af6440d9dd32b2c90fbcd0.tar.bz2
gentoo-2-4e3fd28c00036f9139af6440d9dd32b2c90fbcd0.zip
Bump eapi and do not distribute static lib and la file unless needed.
(Portage version: 2.2.0_alpha104/cvs/Linux x86_64)
Diffstat (limited to 'net-libs/libmicrohttpd')
-rw-r--r--net-libs/libmicrohttpd/ChangeLog5
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.19.ebuild20
2 files changed, 14 insertions, 11 deletions
diff --git a/net-libs/libmicrohttpd/ChangeLog b/net-libs/libmicrohttpd/ChangeLog
index 5485c6a183d6..cfab01cdec7c 100644
--- a/net-libs/libmicrohttpd/ChangeLog
+++ b/net-libs/libmicrohttpd/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for net-libs/libmicrohttpd
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.9 2012/03/03 13:58:44 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.10 2012/05/14 11:12:54 scarabeus Exp $
+
+ 14 May 2012; Tomáš Chvátal <scarabeus@gentoo.org> libmicrohttpd-0.9.19.ebuild:
+ Bump eapi and do not distribute static lib and la file unless needed.
*libmicrohttpd-0.9.19 (03 Mar 2012)
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.19.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.19.ebuild
index 9ecd055b30f1..035ba550d1a7 100644
--- a/net-libs/libmicrohttpd/libmicrohttpd-0.9.19.ebuild
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.19.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/libmicrohttpd-0.9.19.ebuild,v 1.1 2012/03/03 13:58:44 chithanh Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/libmicrohttpd-0.9.19.ebuild,v 1.2 2012/05/14 11:12:54 scarabeus Exp $
-EAPI=2
+EAPI=4
MY_P=${P/_/}
@@ -10,7 +10,7 @@ DESCRIPTION="A small C library that makes it easy to run an HTTP server as part
HOMEPAGE="http://gnunet.org/libmicrohttpd/"
SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
-IUSE="messages ssl test"
+IUSE="messages ssl static-libs test"
KEYWORDS="~amd64 ~x86"
LICENSE="LGPL-2.1"
SLOT="0"
@@ -31,19 +31,19 @@ DEPEND="${RDEPEND}
S=${WORKDIR}/${MY_P}
+DOCS="AUTHORS NEWS README ChangeLog"
+
src_configure() {
econf \
--enable-curl \
$(use_enable messages) \
$(use_enable ssl https) \
- $(use_with ssl gnutls)
-}
-
-src_compile() {
- emake || die "emake failed"
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
}
src_install() {
- emake install DESTDIR="${D}" || die "make install failed"
- dodoc AUTHORS NEWS README ChangeLog || die
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
}