summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAnthony G. Basile <blueness@gentoo.org>2013-12-22 22:31:05 +0000
committerAnthony G. Basile <blueness@gentoo.org>2013-12-22 22:31:05 +0000
commit124fec109711c6fa0946a82785121536bb35a0c7 (patch)
treebd97469610cd459d43ce175d78bd0ad0cb996bb1 /net-libs/libmicrohttpd
parentKeyword ~ppc64, bug #465948 (diff)
downloadgentoo-2-124fec109711c6fa0946a82785121536bb35a0c7.tar.gz
gentoo-2-124fec109711c6fa0946a82785121536bb35a0c7.tar.bz2
gentoo-2-124fec109711c6fa0946a82785121536bb35a0c7.zip
Version bump
(Portage version: 2.2.7/cvs/Linux x86_64, signed Manifest commit with key 0xF52D4BBA)
Diffstat (limited to 'net-libs/libmicrohttpd')
-rw-r--r--net-libs/libmicrohttpd/ChangeLog8
-rw-r--r--net-libs/libmicrohttpd/libmicrohttpd-0.9.33.ebuild50
2 files changed, 57 insertions, 1 deletions
diff --git a/net-libs/libmicrohttpd/ChangeLog b/net-libs/libmicrohttpd/ChangeLog
index 239cb35d04a0..f7b925f28784 100644
--- a/net-libs/libmicrohttpd/ChangeLog
+++ b/net-libs/libmicrohttpd/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/libmicrohttpd
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.54 2013/12/22 13:13:06 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/ChangeLog,v 1.55 2013/12/22 22:31:05 blueness Exp $
+
+*libmicrohttpd-0.9.33 (22 Dec 2013)
+
+ 22 Dec 2013; Anthony G. Basile <blueness@gentoo.org>
+ +libmicrohttpd-0.9.33.ebuild:
+ Version bump
22 Dec 2013; Pacho Ramos <pacho@gentoo.org> libmicrohttpd-0.9.30.ebuild:
amd64 stable, bug 488644
diff --git a/net-libs/libmicrohttpd/libmicrohttpd-0.9.33.ebuild b/net-libs/libmicrohttpd/libmicrohttpd-0.9.33.ebuild
new file mode 100644
index 000000000000..1e537c5363fc
--- /dev/null
+++ b/net-libs/libmicrohttpd/libmicrohttpd-0.9.33.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libmicrohttpd/libmicrohttpd-0.9.33.ebuild,v 1.1 2013/12/22 22:31:05 blueness Exp $
+
+EAPI="5"
+
+MY_P="${P/_/}"
+
+DESCRIPTION="A small C library that makes it easy to run an HTTP server as part of another application."
+HOMEPAGE="http://www.gnu.org/software/libmicrohttpd/"
+SRC_URI="mirror://gnu/${PN}/${MY_P}.tar.gz"
+
+IUSE="epoll messages ssl static-libs test"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~mips ~ppc ~ppc64 ~x86"
+LICENSE="LGPL-2.1"
+SLOT="0"
+
+RDEPEND="ssl? (
+ dev-libs/libgcrypt
+ net-libs/gnutls
+ )"
+
+DEPEND="${RDEPEND}
+ test? (
+ ssl? ( >=net-misc/curl-7.25.0-r1[ssl] )
+ )"
+
+S=${WORKDIR}/${MY_P}
+
+DOCS="AUTHORS NEWS README ChangeLog"
+
+src_configure() {
+ econf \
+ --enable-bauth \
+ --enable-dauth \
+ --disable-spdy \
+ $(use_enable epoll) \
+ $(use_enable test curl) \
+ $(use_enable messages) \
+ $(use_enable messages postprocessor) \
+ $(use_enable ssl https) \
+ $(use_with ssl gnutls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+
+ use static-libs || find "${ED}" -name '*.la' -exec rm -f {} +
+}