summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTorsten Veller <tove@gentoo.org>2009-04-28 07:32:07 +0000
committerTorsten Veller <tove@gentoo.org>2009-04-28 07:32:07 +0000
commit76044953bdc66a38b7392dfeb63a5a21b7ca4d79 (patch)
tree99531b672260ee71cf423396228009013230bbb4 /net-libs/liblockfile
parentMinor cleanup and proper keywording (diff)
downloadgentoo-2-76044953bdc66a38b7392dfeb63a5a21b7ca4d79.tar.gz
gentoo-2-76044953bdc66a38b7392dfeb63a5a21b7ca4d79.tar.bz2
gentoo-2-76044953bdc66a38b7392dfeb63a5a21b7ca4d79.zip
Version bump. Thanks Peter Alfredsen (#218619)
(Portage version: 2.2_rc31/cvs/Linux i686)
Diffstat (limited to 'net-libs/liblockfile')
-rw-r--r--net-libs/liblockfile/ChangeLog10
-rw-r--r--net-libs/liblockfile/files/1.08-stale_lock.patch20
-rw-r--r--net-libs/liblockfile/liblockfile-1.08.ebuild33
3 files changed, 61 insertions, 2 deletions
diff --git a/net-libs/liblockfile/ChangeLog b/net-libs/liblockfile/ChangeLog
index d024fffb8395..1d55359f73bc 100644
--- a/net-libs/liblockfile/ChangeLog
+++ b/net-libs/liblockfile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/liblockfile
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/liblockfile/ChangeLog,v 1.52 2008/09/21 06:33:57 vapier Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liblockfile/ChangeLog,v 1.53 2009/04/28 07:32:07 tove Exp $
+
+*liblockfile-1.08 (28 Apr 2009)
+
+ 28 Apr 2009; Torsten Veller <tove@gentoo.org>
+ +files/1.08-stale_lock.patch, +liblockfile-1.08.ebuild:
+ Version bump. Thanks Peter Alfredsen (#218619)
21 Sep 2008; Mike Frysinger <vapier@gentoo.org>
liblockfile-1.06-r2.ebuild:
diff --git a/net-libs/liblockfile/files/1.08-stale_lock.patch b/net-libs/liblockfile/files/1.08-stale_lock.patch
new file mode 100644
index 000000000000..c64c52599e8d
--- /dev/null
+++ b/net-libs/liblockfile/files/1.08-stale_lock.patch
@@ -0,0 +1,20 @@
+http://bugs.debian.org/505851
+--- liblockfile-1.08.orig/lockfile.c
++++ liblockfile-1.08/lockfile.c
+@@ -391,13 +391,10 @@
+ * Without a pid in the lockfile, the lock
+ * is valid if it is newer than 5 mins.
+ */
+-#if 0
++
+ if (now < st.st_mtime + 300)
+ return 0;
+-#else
+- if (now < st.st_mtime + 10)
+- return 0;
+-#endif
++
+ return -1;
+ }
+
+
diff --git a/net-libs/liblockfile/liblockfile-1.08.ebuild b/net-libs/liblockfile/liblockfile-1.08.ebuild
new file mode 100644
index 000000000000..1f49b09b99ed
--- /dev/null
+++ b/net-libs/liblockfile/liblockfile-1.08.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liblockfile/liblockfile-1.08.ebuild,v 1.1 2009/04/28 07:32:07 tove Exp $
+
+EAPI=2
+
+inherit eutils multilib autotools
+
+DESCRIPTION="Implements functions designed to lock the standard mailboxes"
+HOMEPAGE="http://www.debian.org/"
+SRC_URI="mirror://debian/pool/main/libl/${PN}/${PN}_${PV}.orig.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-stale_lock.patch
+ epatch "${FILESDIR}"/${PN}-1.06-respectflags.patch
+ epatch "${FILESDIR}"/${PN}-orphan-file.patch
+ eautoreconf
+}
+
+src_configure() {
+ econf --with-mailgroup=mail --enable-shared
+}
+
+src_install() {
+ dodir /usr/{bin,include,$(get_libdir)} /usr/share/man/{man1,man3}
+ emake ROOT="${D}" install || die
+ dodoc README Changelog || die
+}