summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2006-12-20 13:22:11 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2006-12-20 13:22:11 +0000
commit2094ad1b27a160f3babefe710763bd51e154ce34 (patch)
tree0594376bf1e8958ab989cb998b6b2cacc180b4a2 /net-libs/liblockfile
parentStable on sparc wrt security #158571 (diff)
downloadgentoo-2-2094ad1b27a160f3babefe710763bd51e154ce34.tar.gz
gentoo-2-2094ad1b27a160f3babefe710763bd51e154ce34.tar.bz2
gentoo-2-2094ad1b27a160f3babefe710763bd51e154ce34.zip
Add patch from bug #145450
(Portage version: 2.1.1-r2)
Diffstat (limited to 'net-libs/liblockfile')
-rw-r--r--net-libs/liblockfile/ChangeLog8
-rw-r--r--net-libs/liblockfile/files/digest-liblockfile-1.06-r23
-rw-r--r--net-libs/liblockfile/files/liblockfile-orphan-file.patch19
-rw-r--r--net-libs/liblockfile/liblockfile-1.06-r2.ebuild42
4 files changed, 71 insertions, 1 deletions
diff --git a/net-libs/liblockfile/ChangeLog b/net-libs/liblockfile/ChangeLog
index 036997af31ab..57ffee728461 100644
--- a/net-libs/liblockfile/ChangeLog
+++ b/net-libs/liblockfile/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-libs/liblockfile
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/liblockfile/ChangeLog,v 1.40 2006/10/21 18:19:54 kloeri Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liblockfile/ChangeLog,v 1.41 2006/12/20 13:22:11 ferdy Exp $
+
+*liblockfile-1.06-r2 (20 Dec 2006)
+
+ 20 Dec 2006; Fernando J. Pereda <ferdy@gentoo.org>
+ +files/liblockfile-orphan-file.patch, +liblockfile-1.06-r2.ebuild:
+ Add patch from bug #145450
21 Oct 2006; Bryan Østergaard <kloeri@gentoo.org>
liblockfile-1.06-r1.ebuild:
diff --git a/net-libs/liblockfile/files/digest-liblockfile-1.06-r2 b/net-libs/liblockfile/files/digest-liblockfile-1.06-r2
new file mode 100644
index 000000000000..d33913ce9d1c
--- /dev/null
+++ b/net-libs/liblockfile/files/digest-liblockfile-1.06-r2
@@ -0,0 +1,3 @@
+MD5 2de88389da013488bfd31356523070c0 liblockfile_1.06.tar.gz 32007
+RMD160 704222295720c1b07e7474b49de1098cc5e2c997 liblockfile_1.06.tar.gz 32007
+SHA256 14f9690328318d11f9ba13a9356a2c008bdd169b7a817f38cb7f9eb32cf7240e liblockfile_1.06.tar.gz 32007
diff --git a/net-libs/liblockfile/files/liblockfile-orphan-file.patch b/net-libs/liblockfile/files/liblockfile-orphan-file.patch
new file mode 100644
index 000000000000..4a8c75ac4129
--- /dev/null
+++ b/net-libs/liblockfile/files/liblockfile-orphan-file.patch
@@ -0,0 +1,19 @@
+diff -ur liblockfile-1.06-orig/Makefile.in liblockfile-1.06/Makefile.in
+--- liblockfile-1.06-orig/Makefile.in 2006-11-28 06:19:09.000000000 +0100
++++ liblockfile-1.06/Makefile.in 2006-11-28 06:24:30.000000000 +0100
+@@ -5,6 +5,7 @@
+ #
+
+ VER = 1.0
++MVER = 1
+ NVER = 0.1
+
+ CFLAGS = @CFLAGS@ -I.
+@@ -55,6 +56,7 @@
+ install_shared: shared install_common
+ install -m 755 liblockfile.so \
+ $(ROOT)$(libdir)/liblockfile.so.$(VER)
++ ln -s liblockfile.so.$(VER) $(ROOT)$(libdir)/liblockfile.so.$(MVER)
+ ln -s liblockfile.so.$(VER) $(ROOT)$(libdir)/liblockfile.so
+ if test "$(ROOT)" = ""; then @LDCONFIG@; fi
+
diff --git a/net-libs/liblockfile/liblockfile-1.06-r2.ebuild b/net-libs/liblockfile/liblockfile-1.06-r2.ebuild
new file mode 100644
index 000000000000..e22c72b4865a
--- /dev/null
+++ b/net-libs/liblockfile/liblockfile-1.06-r2.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/liblockfile/liblockfile-1.06-r2.ebuild,v 1.1 2006/12/20 13:22:11 ferdy Exp $
+
+WANT_AUTOCONF="latest"
+WANT_AUTOMAKE="latest"
+
+inherit eutils multilib flag-o-matic autotools
+
+DESCRIPTION="Implements functions designed to lock the standard mailboxes"
+HOMEPAGE="http://www.debian.org/"
+SRC_URI="mirror://debian/pool/main/libl/${PN}/${PN}_${PV}.tar.gz"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
+IUSE=""
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+
+ epatch "${FILESDIR}/${P}-glibc24.patch"
+ epatch "${FILESDIR}/${P}-respectflags.patch"
+ epatch "${FILESDIR}/${PN}-orphan-file.patch"
+
+ eautoreconf
+
+ # Do not use lazy bindings on setXid files
+ sed -i -e 's~-o dotlockfile~'$(bindnow-flags)' &~g' Makefile.in
+
+}
+
+src_compile() {
+ econf --with-mailgroup=mail --enable-shared || die
+ emake || die
+}
+
+src_install() {
+ dodir /usr/{bin,include,$(get_libdir)} /usr/share/man/{man1,man3}
+ make ROOT="${D}" install || die
+}