summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohannes Huber <johu@gentoo.org>2012-03-19 17:15:57 +0000
committerJohannes Huber <johu@gentoo.org>2012-03-19 17:15:57 +0000
commitf11721e4f33df17b6bc3d05dea01a0408d5b9c83 (patch)
tree80d4648abdf09577fc77471f0c42e38a1b7ae9c3 /net-libs/libktorrent
parentadd openrc to rdepends (diff)
downloadgentoo-2-f11721e4f33df17b6bc3d05dea01a0408d5b9c83.tar.gz
gentoo-2-f11721e4f33df17b6bc3d05dea01a0408d5b9c83.tar.bz2
gentoo-2-f11721e4f33df17b6bc3d05dea01a0408d5b9c83.zip
Version bump by Pavlos Ratis <dastergon@gmail.com> wrt bug #407993.
(Portage version: 2.2.0_alpha92/cvs/Linux i686)
Diffstat (limited to 'net-libs/libktorrent')
-rw-r--r--net-libs/libktorrent/ChangeLog7
-rw-r--r--net-libs/libktorrent/libktorrent-1.2.0.ebuild51
2 files changed, 57 insertions, 1 deletions
diff --git a/net-libs/libktorrent/ChangeLog b/net-libs/libktorrent/ChangeLog
index 7b79a285fb1f..a8598e71f799 100644
--- a/net-libs/libktorrent/ChangeLog
+++ b/net-libs/libktorrent/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-libs/libktorrent
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/ChangeLog,v 1.30 2012/03/12 09:44:14 johu Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/ChangeLog,v 1.31 2012/03/19 17:15:57 johu Exp $
+
+*libktorrent-1.2.0 (19 Mar 2012)
+
+ 19 Mar 2012; Johannes Huber <johu@gentoo.org> +libktorrent-1.2.0.ebuild:
+ Version bump by Pavlos Ratis <dastergon@gmail.com> wrt bug #407993.
12 Mar 2012; Johannes Huber <johu@gentoo.org> -libktorrent-1.1.1.ebuild:
Remove old.
diff --git a/net-libs/libktorrent/libktorrent-1.2.0.ebuild b/net-libs/libktorrent/libktorrent-1.2.0.ebuild
new file mode 100644
index 000000000000..243243726df9
--- /dev/null
+++ b/net-libs/libktorrent/libktorrent-1.2.0.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libktorrent/libktorrent-1.2.0.ebuild,v 1.1 2012/03/19 17:15:57 johu Exp $
+
+EAPI=4
+
+KDE_SCM="git"
+if [[ ${PV} != 9999* ]]; then
+ inherit versionator
+ # upstream likes to skip that _ in beta releases
+ MY_PV="${PV/_/}"
+ KTORRENT_VERSION=$(($(get_major_version)+3)).$(get_version_component_range 2-3 ${MY_PV})
+ MY_P="${PN}-${MY_PV}"
+ KDE_HANDBOOK="optional"
+ KDE_DOC_DIRS="doc"
+
+ KDE_LINGUAS="ar ast be bg ca ca@valencia cs da de el en_GB eo es et eu
+ fi fr ga gl hi hne hr hu is it ja km ku lt lv ms nb nds nl nn oc pl
+ pt pt_BR ro ru se si sk sl sr sr@ijekavian sr@ijekavianlatin
+ sr@latin sv tr uk zh_CN zh_TW"
+ SRC_URI="http://ktorrent.org/downloads/${KTORRENT_VERSION}/${MY_P}.tar.bz2"
+ S="${WORKDIR}"/"${MY_P}"
+
+ KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+else
+ KEYWORDS=""
+fi
+VIRTUALX_REQUIRED=test
+inherit kde4-base
+
+DESCRIPTION="A BitTorrent library based on KDE Platform"
+HOMEPAGE="http://ktorrent.org/"
+
+LICENSE="GPL-2"
+SLOT="4"
+IUSE="debug"
+
+RDEPEND="
+ app-crypt/qca:2
+ dev-libs/gmp
+"
+DEPEND="${RDEPEND}
+ dev-libs/boost
+ sys-devel/gettext
+"
+
+src_prepare() {
+ kde4-base_src_prepare
+ # do not build non-installed example binary
+ sed -i -e '/add_subdirectory(examples)/d' CMakeLists.txt || die
+}